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Chapter 0 環境建立
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CH 0 環境建立

登入工作站之後，點選桌面底下的資料夾圖示

跟學長取得PDK壓縮檔後，將壓縮檔上傳
到自己的工作資料夾底下後，在PDK.zip
檔案上按右鍵，點選Unzip ，就可以將檔
案解壓縮

連點兩下這裡可以關掉視窗!!!
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待解壓縮完之後，在同一個資料夾下，選
File -> New Folder 建立一個新的資料夾
(可以為任何的名字，此為cadence) ，此資
料夾為自己工作環境的資料夾

CH 0 環境建立
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將解壓縮後的PDK資料夾裡面的cds.lib
以及display.drf以跟複製PDK.zip檔案同
樣的方式，複製到新建立的資料夾中，
環境建立結束

CH 0 環境建立
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Chapter 1 Library建立
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CH 1 Library 建立

環境建立完後，關掉資料夾視窗，到桌
面上，按右鍵開啟工作選單，點選Tools 
-> Terminal ，就會跳出Terminal視窗
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CH 1 Library 建立

在Terminal的視窗中，輸入cdΔ新建
立的資料夾名字(此為cadence) -> 
Enter，再輸入icfbΔ& -> Enter
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CH 1 Library 建立

關閉跳出的What’s New視窗，在CIW
上，點選 Tools -> Library Manager

此為CIW (Command Input Window)
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CH 1 Library 建立

在Library Manager的視窗上，點選
File -> New -> Library
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CH 1 Library 建立

輸入想要取的名字 (此為
Cheng_Group) ，然後點OK
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CH 1 Library 建立

選擇 Don’t need a techfile，
然後點OK，Library建立完成
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CH 1 Library 建立

要增加tsmc018rf製程的
Library，首先點選CIW的
Tools -> Library Path Editor



15MSIC EE NCU Shih-Hsiu Chen

CH 1 Library 建立

在跳出來的視窗中，點選Edit -> Add Library
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CH 1 Library 建立

出現Browse視窗
後，用..到上一層
資料夾

到PDK資料夾中的PDK13進去
後，在Library那欄就會出現
tsmc18rf，點選反白後，就可以
點OK離開，tsmc18rf Library就
會成功加到自己的Library path裡
面，之後的MOS元件就是到這個
Library裡面找
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Chapter 2 電路建立
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CH 2 電路建立

在Library Manager的視窗上，點選剛
建立好的資料夾後，在到上窗上，點
選 File -> New -> Cell View
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CH 2 電路建立

在Cell Name欄位上面，輸入電
路名字(此為inv) ，Tool欄位為
下拉式選單，選擇Composer -
Schematic，然後點OK
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CH 2 電路建立

按此鍵或是”I”開始放置元件
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CH 2 電路建立

呼叫Instance之後，用Browse來選擇
需要的元件



22MSIC EE NCU Shih-Hsiu Chen

CH 2 電路建立

在Library Browser中，在Library欄位選擇
tsmc18rf ，在Cell欄位選擇nmos2v (nmos 低
電壓製程)，在View欄位選擇symbol ，然後點
Close
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CH 2 電路建立

之後回到視窗Add Instance，Rotate可
以順時針旋轉物件，Sideways可以左
右鏡射物件，Upside Down可以上下
鏡射物件

l (M) 欄位為通道長度L，w (M) 欄位為單
位Finger的通道寬度W，total_width (M)
為總通道寬度(最小為220n)
其定義為 : w * Number of Fingers
以上單位都為公尺，n為nano，u為micro

Number of Fingers為MOS的並聯數
(尺寸大的時候就會用到)，Multiplier
為MOS的元件數(一般都為1)

決定好尺寸參數後，點選Hide
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CH 2 電路建立

黃色的部分為未決定
部分，在想要的地方
點一下滑鼠左鍵即可
放置
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CH 2 電路建立

放置好元件後，開始
幫端點或節點位置拉
線

點選此鍵或是按”w”即
可拉線，方法為在端
點或是想要的節點點
一下左鍵，然後移動
滑鼠到想要的地方再
點一下左鍵，即可完
成拉線

拉線時，元件端點的
地方會出現菱形的方
塊，即可拉線之端
點，當方塊出現時，
可以按”s”快速決定想
拉之端點
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CH 2 電路建立

拉好線後，接著放置Pin腳

呼叫Pin腳，可以使用左邊工具列圖示
或是”p”，就會出現左邊的視窗
Pin Names的欄位中，可以一次輸入多個
腳位名稱
Direction可以決定輸入或是輸出
結束後點選Hide即可回到電路圖放置Pin
腳
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CH 2 電路建立

Pin腳放置好後，點選此鍵
檢查電路圖及存檔，電路
建立完成
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Chapter 3 Symbol建立
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CH 3 Symbol建立

電路建立好之後，到功能表上
面點選Design -> Create 
Cellview -> From Cellview
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CH 3 Symbol建立

出現這個視窗後，直接點選OK

之後會出現這個視窗後，在Pin 
Specifications決定Pin的位置



31MSIC EE NCU Shih-Hsiu Chen

CH 3 Symbol建立

除了綠線以外，其他都不能刪除

刪除掉的綠線，可以用此鍵來重新畫
形狀，其他形狀，可以用功能列上的

Add -> Shape挑想要的形狀出來

不小心做錯可以
按此鍵回到上一
步
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CH 3 Symbol建立

建立好的Symbol就會像這樣(此為inverter)

畫完按此鍵存檔
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Chapter 4 直流分析
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CH 4 直流分析

首先，建立一個電路(此為分析
一顆nMOS)，在預觀測電流的
地方，掛上一顆1y的電阻

理想電阻放在analogLib裡面，
這個Library裡有理想的被動元
件以及各種Source，此電路的
所有Source都以Pin來提供，
也可以換成理想的Source (ex: 
vdc, idc…) ，以Pin來提供的
設定會在稍後介紹

電路建立好之後，點選
Tools -> Analog 
Environment
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CH 4 直流分析

出現此視窗後，先設定Setup -> Model Libraries
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CH 4 直流分析

在設定視窗中，先點選Browse來找尋Spice 
model，spectre專用的model放在PDK資料夾裡
面的/PDK13/models/spectre/rf018.scs，找到之
後，就會出現在Model Library File的欄位裡，然
後在旁邊Section (opt.)的欄位打上tt也就是TT 
corner，之後點選Add，加入成功後，點選OK離
開

要換corner的話，先點選已經加入成功
的model (反白部分)，然後再到Section
的欄位輸入需要的跑的corner (ff, ss, sf, 
fs mc)，之後再點選change
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CH 4 直流分析

設定好model後，接著設定輸入訊號

到Setup -> Stimuli裡面設定所有
input pin的訊號格式

這個選項可以改溫度
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CH 4 直流分析

在設定視窗中，先點選欲設定的
Pin，然後勾選Enable，選擇
Function，然後再選擇Type，之後再
到下面的欄位輸入需要的資訊，在此
為設定DC電壓源，在DC voltage的
欄位中， 可以輸入數字或是變數名
稱(在此輸入變數名稱Vd)，設定完
後，要點選Change，然後用同樣的
方式設定其他的input Pin，全部設定
完後，點選OK
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CH 4 直流分析

如果在設計中，有以變數名稱取代數字的話，在選擇分
析模式之前，要先來設定變數 Variables -> Edit (如果是
在電路設計裡面也有變數的話，就可以選擇Copy From 
Cellview)
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CH 4 直流分析

設定變數的方式，首先在Name的欄位裡面，輸入變數名
稱，然後在Value裡面輸入數值，完後點選Add，再以同
樣的方式定義其他變數，結束點選OK
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CH 4 直流分析

變數設定完
後，到
Analyses -> 
Choose裡面
選擇想要的
模擬

設定好的變數就會出現在這
邊，在上面連點兩下即可修
改數值
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CH 4 直流分析

在Analyses中，有許多分析選項，在
此選擇dc(直流分析)

勾選Save DC Operating Point可以
查看MOS是否在飽和區，以及可以
看跨壓和電流

此電路是為了看Ids與Vds的關係，所
以在Sweep Variable中，選擇Design 
Variable ，然後再Variable Name的
欄位中，輸入先前設定的變數，然後
在Sweep Range中，輸入起始值及
終止值，選擇Sweep Type，以及解
析度或是想要掃多少點，最後勾選下
面的Enabled，結束點選OK(有其他
模擬要一起做的話，點選Apply，在
去其他模擬選項設定)
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CH 4 直流分析

因為在分析中，有需要觀測電流，所以要到Output -> 
Save All裡面設定要將電流結果存起來
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CH 4 直流分析

在Select device 
currents (currents)的
地方，勾選all，然後
在點選OK
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CH 4 直流分析

在To Be Plotted的選項中，可以先設定欲觀看的
點，或是之後可以在Results裡面選擇
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CH 4 直流分析

點選Select On Schematic之後，就到電路圖裡面選擇要觀看
的點，電流部分就是選擇端點 (紅色的部分) ，由於不能直接
選擇MOS端點來觀察電流，所以才要加掛一個非常小的電阻
來觀看，選完之後，就可以回到之前的視窗
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CH 4 直流分析

當所有設定都完成後，就可以點選此
鍵來開始模擬
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CH 4 直流分析

當模擬跑完之後，如果有
先設定觀看端點，結果圖
就會自動跳出

在波形圖的Trace功能
裡面，有4種Cursor可
以選擇，可以依照需要
來點選，使用Cursor找
到要的數據後，可以按
M鍵來標記出來
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CH 4 直流分析

當模擬跑
完之後，
如果沒有
先設定觀
看端點，
可以從
Results -> 
Direct Plot
裡面來選
擇想要看
的圖

由於只有跑dc模擬，所以只有Main 
Form及DC可供選擇，在這個模擬設
定下，兩種都是一樣的
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CH 4 直流分析

如果當初有勾選Save Operating Point ，可以從Results 
-> Annotate -> DC Operating Points 選項來看MOS的跨
壓及電流大小(沒有包含Sweep的結果)
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CH 4 直流分析

如果當初有勾選Save Operating Point，還可以從Results 
-> Circuit Conditions選項來看MOS有無在飽和區
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CH 4 直流分析

在Circuit Conditions的視窗裡，勾選Linear <MOS>，選想要標記的
顏色，然後點選Place，就會在電路圖將位於線性區的MOS給框起
來，再設計類比電路時非常好用，點選Clear可以清除框起來的元件
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CH 4 直流分析

在 Tools-> Parametric Analysis選項裡，可以在現在模擬的設定下，改變其他
的變數做同一件模擬，在此是以改變Vgs的電壓，來觀看不同的Id曲線
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CH 4 直流分析

在Parametric Analysis視窗中，Variable Name輸入其他的變數(不同
於dc Sweep裡面的設定)，設定方法，跟設定dc sweep一樣，然後在
勾選Select
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CH 4 直流分析

以上設定為Variable Name輸入Vg，
From 0.2 To 1.8，Step Control裡設
定為Linear Step，Step Size為0.2，
設定完後，點選Analysis -> Start或
是Start Select

可以在Setup裡面增加新的一組變
數，但是要注意，如果分析的時候，
所有要掃的變數都Select，按下Start
時，跑的數目會相乘，也就是說同時
做兩種變數的Sweep(例如同時掃Vg 
及Vs或是其他像電阻、尺寸等)
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CH 4 直流分析

模擬結果會如上圖，不同的Vgs下的Id curve
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Chapter 5 交流分析
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CH 5 交流分析

此電路是以理想
diffamp來作為模擬範
例，所以沒有Vdd及
Vss
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CH 5 交流分析

Pin的設定上，AC magnitude要設
定1(小訊號)，Vin的部分，可以設
為0(若有offset的部分，則可以輸入
offset電壓)

因為電路裡面有使用Vss電壓源，
所以需要到Global Source裡面去設
定，方法跟設定input是一樣
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CH 5 交流分析

模擬選擇ac，在Sweep Variable上面
選擇Frequency，範圍從1掃到
100M(可以依需求來改)，Sweep Type
選擇Logarithmic，總共掃1000點，然
後點選Enabled，在點選OK，設定完
後，就可以點開始模擬
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CH 5 交流分析

模擬完後，在Results -> Direct Plot上面就會出現交流分析
的結果，選AC Magnitude & Phase就會同時跑出20dB增
益跟相位圖



62MSIC EE NCU Shih-Hsiu Chen

CH 5 交流分析

此鍵可以將這個結果分成兩個圖，其他有關量測OP特
性的方法會再另外一份講義裡面
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Chapter 6 暫態分析
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CH 6 暫態分析

此電路為CH3所建立的
Inverter，圖中框起來的元件叫
noConn，放在basic library裡面
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CH 6 暫態分析

在輸入部分，Function要改為pulse，設
定如下:
Voltage 1: 起始電壓
Voltage 2: 最終電壓
Delay time: 延遲時間
Rise time: 上升時間
Fall time: 下降時間
Pulse width: 波形寬度
Period: 週期
輸入完之後，點選Enabled和Change，
之後不要忘記設定Global Sources (有
使用的話)，設定完就點選OK結束
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CH 6 暫態分析

在模擬選擇上，選tran，然後在stop設定要觀看的時間，設定
完後點選Enabled，然後點OK結束，設定完成後，可以先將要
看的位置用Outputs裡面的設定(不是這個視窗)先選好，再跑模
擬
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CH 6 暫態分析

這就是跑出來的結果，綠線部份是Vin，藍線部份是output
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Chapter 7 KVCO
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CH 7 KVCO

這是這章用來講KVCO的電路
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CH 7 KVCO

將Vc設為變數，Vdd及gnd都設定好後，分析選擇
tran，接著從Outputs -> Setup設定想要看的結果
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CH 7 KVCO

出現Setting Outputs的視窗後，在Name的欄位上，打上自己定
義的名字，然後Expression的欄位，要利用Calculator來設定，
點選Open就可以開啟Calculator視窗
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CH 7 KVCO

在Calculator的視窗視窗裡面，先選擇上面欄位的tran下的vt，接
著電路圖就會跳出，點選要觀看的net之後，再回到這個視窗，
點選frequency，式子就會出現
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CH 7 KVCO

回到Setting Output的視窗，點選Get Expression，就可以將式子
Copy到Expression的欄位，然後就點選Add，設定好後就可以點
選OK，也可以把Calculator的視窗關掉
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CH 7 KVCO

對於一個震盪器的模擬，一定要設定Initial Condition，點選
Simulation -> Convergence Aids -> Initial Condition 
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CH 7 KVCO

出現Initial Condition Set的視窗
後，先在電路圖上點選要設定的
net，然後再回到Set視窗，點選欲
設定值的net，然後在Node 
Voltage上輸入想要的電壓，接著
點Apply，目標net的Initial 
Condition電壓就會變成輸入值，
設定好後點選OK
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CH 7 KVCO

接著就設定Parametric Analysis (因為tran沒有變數Sweep功
能) ，輸入欲掃的範圍後，就可以在Analysis選Start開始模擬
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CH 7 KVCO

跑出來的KVCO結果就會如圖所示
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Chapter 8 Phase Noise
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CH 8 Phase Noise 

CH7的模擬不掃Vc的話，Kvco的結果就會出現單一頻率值，此值是根據Vc的
電壓來決定，這個頻率就是此模擬需要用的中心頻率(如果要看其他頻率，要
將Vc設定會產生目標頻率的電壓)



80MSIC EE NCU Shih-Hsiu Chen

CH 8 Phase Noise 

模擬先選擇pss，然後點選Beat 
Frequency，輸入剛剛所得的中心頻
率，在Number of harmonics中輸入
10，Accuracy Defaults選擇
moderate，Additional Time for 
Stabilization中輸入電路需要多少額外
的時間穩定，然後勾選Oscillator，
Oscillator node用旁邊的Select鍵在電
路圖上面選擇輸出點，Reference node
用同樣的方式選擇接地點，最後勾選
Enabled -> Apply (還有其他模擬要設定)
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CH 8 Phase Noise 

設定完pss之後，接著設定pnoise
在pnoise設定中，在Sweep Type欄位選
擇relative，Relative Harmonic欄位輸入
1，掃描範圍看個人喜好(此是設定10k到
10M)，Type選Logarithmic，掃3點，
Maximum Sideband輸入30，Output型
態選voltage，Positive Output Node選擇
輸出點，Negative Output Node選接地
點，Input Source選none，然後勾選
Enabled -> Apply -> OK，設定就完成
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CH 8 Phase Noise 

跑完模擬後，到Result選Main Form
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CH 8 Phase Noise 

在Main Form的視窗中，點選pnoise
-> Phase Noise -> Plot
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CH 8 Phase Noise 

點選Plot之後跑出的結果
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Chapter 9 眼圖
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CH 9 眼圖

跑眼圖要先跑暫態分析，得到頻率以及輸
出波形
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CH 9 眼圖

從輸出波形中，選擇一點最高點的時間當作眼圖設定起
始時間
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CH 9 眼圖

之後從Tools裡叫出Calculator
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CH 9 眼圖

在Calculator視窗，先到上欄位的tran點vt，然後在選擇輸出點，之後再
到function裡面點選eyeDiagram，然後輸入剛剛得到的起始時間，以及
想要的終止時間，最後在Period輸入1.5*(1/f)，f為頻率，輸入完後點
Apply，在點此鍵，就會跑出眼圖
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CH 9 眼圖

跑出來的眼圖就會像這
樣，不過Trace的功能沒有
辦法使用，只能用Zoom的
功能

交叉點對應時間的
寬度就是Jitter量
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