Verd
Basic Training & Technical Overview

Novas Software, Inc

Based on Verdi 5.4v6 M



Training Course

o

Verdi Background and Overview
Loading Your Design

nTrace

nSchema & nState

Break

nWave

Debugging with Verdi

Verdi 5.4 Basic Training -02/22/05 MVAS



Verdi Background and Overview

Concepts and Technology

Novas



Debug in the Design Flow

ESL RTL

pebig
) w

% of Design/Verification Spent in Debug

Do you know how much time your
teams spend debugging?

50

401

30+

20

10+

# of respondants

What else could you be doing with

th a.t tlme? 0-10%  11-20%  21-30% 31-40%  41-50% 51-60% 61-70%  71-80%  81-90% 91-100%

Source: Novas Customer Survey, 161 Respondents
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The Barriers To Efficient Debu&

Pl

—

® Complex Designs

® |ncreasing device size and complexity

® Barrier to required design understanding
® Complex Behavior

® Complex design cause and effect scenarios

® Increases conditions to be verified Sw

® Complex multi-tool, multi-lingual,
multi-team environments

® Compounds methodology complexity oy
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Novas Solves the Tough Debug Issues

Issues

Complex Environments
Complex Behavior
Complex Designs - \

Comprehension

Unification
Knowledge sharing Reusner
Increasing automation

Powerful comprehension and debug

Nows
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Novas Technology

Design, .
Testbench, Open Analysis
Assertions, Databases Engines

Specification,
Layout Info

Visualization

Behavior Flow Graph

KDB Behavior Analysis
Knowledge Source Code Trace

Structure Analysis

Waveform / Event

: ' nWave
Behavior Exploration ( )

Schematic /7 Structure

nSchema
FSDB Behavior Query ( )

"R E Event
'\%, ] Database FSM / Flow Chart

nState
Knowledge Reuse ( )

Full Range Block Diagram /

of Tools Documentation

Comprehensive Debug System - More Than Simple Visualization
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Structural / Event Debug Proc

Current process involves comparing events, code and structure
across multiple windows to track possible issues
- Time consuming, error prone, complicated

Session Tools Source Trace Options Windo

[l [mlnim) - [alo (o]0 | | W] L] ] by =kl
]

<Debussy:turboTracer:1> system.i_cpui_PCU T

3
i) system 44| 0 (cl oy ?
) assign TOBO = (Cl = IDE : TDE;
E%{S‘.’“A(f = 4 Fm
é--{,?:lifcc 45 Schematic View Analyze Trace
q Qﬁf'imiicnf' 46| always @(negedge C5 or negedge reset) begin D
a . * =) i)
] i_pram { 47 if (“reset) IDR = & h00; 2 I ZI %I |* Itl ‘I |‘IQI \JI'
1 20
48 else IDR = TOE0;
Fzm 2|
49 end
50| assign data = (“Cl) 7 IDRE : 8"bzzzzzzzz;
5 DATA| a F=20
52| oluoys @{negedge 51 or negedge reset) begin

53 if (“reset) PC = & ho0; =
af

1]
54 else PC = ALLL
a5

v v e verd_dewma_tanes e, 1 ¢ G2 ages_veesh U pepsbemauill
Wavelm Ansiog Tooh Window bl
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Automating Debug

Critical Productivity Enhancer*nt

——

Utilizing behavior based debug to automate time consuming aspects of

debug process

® Time and structure in single view

® Immediate visual of design
behavior

View Trace Tools Help

() W
M MF.[E-._ﬁt‘Qawgg‘w‘" - il ‘C\Uck o olocke
ol AL
L™

e sl o Working Scope: th_CPUsystem
i I‘I'lilfl i} -

| 650

BYEH

® Automated cause / affect tracing

Schematle View Analyze Trace i

® Understand problem areas
quickly

® Link back to regular views

[zl z[] e T |5
Telectadt (0}

® Bind problem to modelling issue
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Benefits

Captures design structure and behavior.
Generates structural diagrams of RTL or gates.
Verification results put in context of the design.

O
O
O
® Helps you understand unfamiliar or legacy code.
® Automates difficult debug operations.

O

Maintains consistent view of the design through design and
verification process.

® Dramatically cuts your debug time over traditional methods.
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Training Course
-

Loading Your Design
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Before you start...

-~

® Environment Setup

® Verdi Setup File — novas.rc
® Library Mapping

® Symbol Libraries
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Environment Setup

-~

® Add binary to the search path.

® setenv NOVAS <Novas_install_dir>.
® set path=($NOVAS/bin $path).
® Specify search path of license file.
® setenv NOVAS LICENSE_FILE <license _file>
or
® setenv LM_LICENSE_FILE <license_file>:$LM_LICENSE_FILE
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Verdi Setup File — novas.rc

2

—

Pl

® The setup file for Verdi is called novas.rc and contains:
® Mapping information for pre-compiled designs.
® User preferences (set via Tools = Preferences).

® Reference to another novas.rc file (optional)

® Search sequence for novas.rc files:
1. -rcFile <filename> command line option (read/write pointer)
2. NOVAS_RC environment variable (read/write pointer)
3. ./novas.rc
4. $3HOME/novas.rc
5. <verdi install>/etc/novas.rc
® Specify path for Verdi setup file
® setenv NOVASRC <path>/novas.rc

® Use —rcFile on the verdi command line to overwrite the environment variable.
Nowus
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Logical Library Mapping De@s — novas.rc

-~

—

® Map a library logical name to a physical location in the novas.rc
file.

® Mapping format (in novas.rc):

[Library]
logical name = physical location
pack = ../library/pack

Example:

[Library]

pack = ./work

vital = ./work

® Necessary for VHDL or mixed language designs.
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Symbol Libraries

® \Why are symbol libraries important?
® \Without the symbol mappings for gate cells...

® Active fan-in cone, Fan-in cone and Fan-out cone schematics
will NOT function properly.

® Schematics will show ONLY squares instead of logic cells.
® Symbol mappings differentiate logic gates from Sequential.

® Check the Novas web page, in the downloads
section for a list of available libraries, Library Developer’'s Guide and
cell definitions.

Unmapped L l K f Mapped
fanin cone || 1 == anin cone
] caizldo — _E:> ﬂ/\:Bjj /
\ _ :‘
=

Command Dong * |Command Dong

| b BN
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Creating Symbol Libraries ;

——'-

=

® Automatic (recommend) - If the .lib files of Synopsys are available

® Use the syn2SymDB utility to create symbol library
target_lib.lib++

syn2SymDB —o target_lib synopsys_technology.lib
® Manual - If the .lib files of Synopsys are not available
® You have special cells to create (ASIC/FPGA macro cells)

® Create a .map file using the , then use
the map2SymDB utility to create the symbol mappings library
target_lib.lib++

map2SymDB —o target_lib manual _technology.map
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Use common delimiters between libraries and paths.

For NOVAS_LIBS only specify the root of the <root>.lib++ directory
name.

setenv NOVAS LIBS “<LIB ROOT#1> <LIB ROOT#2> ..”
setenv NOVAS LIBPATHS “<Directory#1> <Directory#2> ...”
EX:

setenv NOVAS_LIBS “abc def etc”

setenv NOVAS_LIBPATHS “/home /home/on/the/range /etc”

Where abc, def and etc represent libraries abc.lib++, def.lib++ and
etc.lib++ and they can be found in the different paths listed.

For the performance issue, set the same process libraries to
NOVAS LIBS.
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Loading Your Design

Pre-Compiling Design

Pre-Compiling VHDL - vhdlcom Utility
Pre-Compiling Verilog - vericom Utility

Verdi Command Line Options

Load Pre-Compiled Design from Command Line
Load Design Files from Command Line

Load Pre-Compiled Design from the GUI

Load Design Files from the GUI

Using Virtual Top
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Pre-Compiling a Design (KDB;L;

-~

® Compile once, load many times.

—

® Saves load time and overall memory
® Necessary for mixed language or VHDL designs.

® Pre-compile VHDL source files using vhdlcom utility.
® Optional for Verilog language designs.

® Pre-compile Verilog source files using vericom utility.
® By default, a library called work.lib++ Is created.

® Uses the novas.rc file logical mapping mechanism
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Pre-Compiling Verilog — verii)m Utility

Pl

—

vericom [Verdi options] [<your verilog options>]
® Use vericom -h to get all command line options.

® Use vericom to replace verilog simulator commands to create the Verdi
mirror database optimized for debug.

® MTI: vlog top.v —work /home/work —f other_files.f
® NC: ncvlog top.v -WORK /home/work —FILE other_files.f
® VCS: vcs top.v —f other_files.f

® Verdi: vericom top.v —work /home/work —f other _files.f.
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vhdlcom [verdi options] [<your vhdl options>]

® Use vhdlcom -h to get all command line options.

® Verdi provides pre-compiled versions of STD, IEEE, SYNOPSYS, and
NOVAS libraries which are located at: SNOVAS/etc/kbd/vhdl/

® Use vhdlcom to replace vhdl simulator commands to create the mirror
database.

® MTI: vcom —93 top.vhdl —work /home/work —f other_files.f
® NC: ncvhdl —Vv93 top.vhdl -WORK /home/work —FILE other_files.f
® Verdi: vhdlcom —-93 top.vhdl —work /home/work —f other_files.f

® The vhdlicom or vericom library is of the format work.lib++, pack.lib++,
etc. Thus it never conflicts with simulators libraries.
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Verdi Command Line Options}__

- =

verdi [general options]...

® Use verdi -h to get all command line options.
-f <fileName> : specify a file that lists all source files
-vhdl | verilog: specify language type for import design from source
-vtop : loads Virtual top file
-play commandHistoryFile : play command history file.
-ssc licenseFile : specify the license file name.
-ssr sessionFile : load session file (*.ses).
-ssf fastFile : load fast file (*.fsdb).

-sswr restoreFile(s) : load waveform restore file(s) (*.rc).
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verdi -lib <pre-compiled source> -top <top level>

® Reference pre-compiled source on the command line.

verdi —lib abc —top system

® \Where abc is the pre-compiled library, abc.lib++ that the design was
pre-compiled into with vericom/vhdlcom.

® \Where system is the top level module/architecture
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Load Design Files From CoTand Line ¥

-~

—

verdi [verdi options] [<your verilog options>]
® Reference source files on the command line (Verilog only).
® Verdi takes all the Verilog command line options.

verdi —f run.f

® Where run.f is a file that contains the verilog source files and any
command line switches.

verdi —ssv —v lib.v +libext+.v —ssy —y /src/abc —y /src/def top.v

® Where —ssv and —ssy are needed only once for design modules
specified with the —v and —y and top.v is the design file.
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Load Pre-Compiled Designsjom the GUI ¢

__--'_

-

— —

® Specify library mapping before importing design.
—‘i Import Design

® Use File = Import Design... Fron Loy | Fron Fie]

B
or Import Design icon L“k';’wl e |
H . * | fhomeddebussy/demoli FOWSE... |
to import your design.
_ Dekte_|

® Select From Library tab. E J -

] [
® Lists all libraries in current directory | usay DesignUnte [syoen
or specified in map file. . [T g g A
IEE€ (1 mprom
. . st 85 novas
® Supports mapping file to set o ey J
a Virtual TOp oves _:-Eﬁéﬁxatgmé iy
-~ ] -

happing Path: fhomefdebussy/demoirtliwork lib++

Cptions.. Refresh [0]:4 | Cancel |
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Load Design Files from theiJI

—

® Use File = Import Design...

or Import Design icon
to import your design.
S|
® Specify language and run file
or individual source files.

® Select From File tab.

® Supports mapping file to set
a Virtual Top.

Note: The imported design does
not get saved as a library.
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From Library | From File

Language: Yerilog =

Default Directory:

Inport Design

Virtual Top:  — || map.dat | Browse... |

I Momebeckydemosieriloaicpuise

Design Files:

Browse. ..

—f hometheckyidemosdveriloakpuiasiun f

Delete

Delete All

flel

Options. ..

I Momebeckydemosiverilogicpuierciun f

B{_| ‘home/becky/demos/verilog/cpu

B{_] debussylog
BAsrE

i T

. B{_] debussylog
& memory

¢ B{ 1nLintLea

[¥] aluwe Add
[¥] maprom.v

[¥] micrerom v

[¥] microrom_fix.v

[¥] pram v

-2

A
ol

+f D
3 5




Compile Design in GUI

X

Library Mame: § 4 Mapping...
Working Directory:
| /homeshindesh/testveriloger Browse..

Design Files:
Delete
Delete All

Compile Design

® File - Compile Design

® File - View Import Log

<Debussy:nTraceMain:1> system system (system.v)

File View Source Trace Tools Window Help
— = - Options...
= Botiebont v 5B & R o [
23| module
5 k) systern 24 nt
B | CHILDT (fsm_child1) 25| parameter CYCLE = 50; & -
B | CHILDZ (fsm_child2) 26 log/r 1 debussylLog [¥] chilg 1.y N Add
B 1 CHILDS (fsm_child3) 27| reg clock; JvericomLog [¥] child2.y
8 [ | MASTER (fam_master 28| reg reset_cpu; Iwork.lib++ BchiIdS.v
@] 1_cpu (CPU) 24| reg reset_fsm; ALUBw master.y
S i_pram (pram) 30|wire [7:0] addr; % %
31|wire [7:0] data: Celly HElE
32| reg Threeonly, FirstDataInRdy; [FIPCULY [¥] pram.y
33| wire En_g, En_E, En_C, En_D; W Topvoduley ¥ G
34| wire [1:0] Muxl_Sel, Mux2_Sel;
35[wire En_AB,En_AC,En_AD,En_BC,En_BD,En_CD; Klaluy £l system.
36[wire [1:0] Mux3_Sel;
37| wire FirstDatadutRdy:
38| wire StartFSM1, StartFSM2, StartFSMa; Deb ace ple ompile Log File - fhome/bind m| 0 A
: Options GUI will
E' & R
| e -’" l 1| *design* Debussylib {btIdent 3.2v4) & epen On
source file "childl.v 2| Cammand arguments:
source file "child2,v" 3 +define+verilog
source file "child3.v" 4 —inc L
source file "master.v" 5 —f shamesbindesh/test/veriloa/rtlfrun. £ anguage
Linking... 0 erroris), 0 warning(s) E system. v
Total 2 errar(s)., 0 warningis) ; D\:a,r:é; : o
[ ' = = 3
Any error or warning message, please refer to : T
10 ALUB.w )
11 ey :
] 12 ROy Compile Close
13 alu.v
14 childi.v
15 childz.v
16 childa.v
i master.v
18

18[*Errar* syntax error
200 "alu.v", 33 input<

22| *Errar* port cin not input, output or inout

3431 I‘;?;Eé;gjlzvél modules:
25| system !
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Using Virtual Top

® Scenario;

® Design top doesn’t match simulation top (i.e. don’'t wish to include the test
bench, test bench code not available or only looking at a portion of a
design)

® Solution:

® Create a file called map.dat that maps the top design module to the
simulation hierarchy.

Format: <module name> = <full hierarchical path>
Example: CPU = system.i_cpu

® Add —vtop map.dat to the Verdi command line and a pseudo hierarchy will
be created.

® Why?

® |[f a virtual top is not used, active annotation will not work and D&D to
nWave will not work because hierarchical paths will not match.
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Loading Your Design — Sumgary

o

® At this time you should:

—_—

® Understand the Verdi environment setup
® Know how to pre-compile a design

® Know how to invoke Verdi

Verdi 5.4 Basic Training -02/22/05 MVAS



Training Course
o

Verdi 5.4 Basic Training -02/22/05 MVAS

nTrace — View and Debug Source Code



nTrace - View and Debug S%rce Code

o

—_—

® Mouse Actions

® Overview
® Hierarchy Browser
® Source Code Browser
® Message Window

® Searching
® Find Scope
® Find Signal/lnstance
® Find String

® Trace Drivers and Loads

® Bookmarks

® Source Code Editing

® Miscellaneous

® Lab
Verdi 5.4 Basic Training -02/22/05 MVAS



Mouse Actions (all modules)

2

——'-

=

® [eft Mouse Button(LMB)

® Single-click to select design objects like signals, instances,
groups, etc.

® Hold the Shift key and click the LMB to add object to selection
list.

® Double-click(DC) to take action.
® Drag LMB through an area to select the objects enclosed.
® Drag LMB in schematics or waveforms will zoom in area.
® Middle Mouse Button (MMB)
® Drag & Drop (D&D) across windows.
® Right Mouse Button(RMB)

® Context sensitive menu.
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nTrace Overview

o

® Displays source code and hierarchy
® Compiles the design
® Required for nNSchema and nState

® Context sensitive tracing of drivers and loads
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nTrace - Overview

Hierarchy Browser Source Code Browser

..|'@|t 1@!\J_>++L_| _||E _|ﬁ" ﬁ|%amad:(1;|x&l

AT ‘
syﬂernibﬂﬂ : 98] always E{negedge clock or negedge resetd
child? (fem_child1) 94| beqin
child2 (f=m_child2) i] 100 if ¢lpesetd MR tmp = 8°ho0:
child3 {fam_child3) i] 101 else [EGIRANY = s
i_cpu (CPLY 102 end
103
x| E! 3 primitives 104] always @inegedoge clock or negedoge reset)
i_alu (arithlogiclarithle 105| begin
Coucou 108 if {lreset? ACC_tmp = 8 hoo:
: i_PCLU {peutpeul) 107 else ACC_tmp = ACC:
i_pram {pram@(pram)j| 133 end
ter (f i
master il maste) 110| always @{posedoge T3 or negedge reset)
al [l |

£ 1» system,i_cpu,i_ALUR, I¥R_tmpl7:0] 7% results of trace driver %7
*<I0x uer‘llng.fHLLlB 9{100} if {lreset? IKE tmp = Bhi0:

& 2 drluer{s}
#Total 3 2 driveris:

#zysztem,i_cpu,i FlLUB

Message Window
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® Displays VHDL architectures and packages, Verilog modules, primitive
iInstances, tasks and functions.

® Expand/Collapse
design tree.

® Double click folder
to change current
scope.

® Open Folder icon m/

indicates current
scope.

]

m !I n1as¢erifsn1 master)
| Oy =td_logie 1164
@ 4 standard

i veo Dka

module CPU{clock, reset, WHA, E_W, data, addri:
input clock:

@|lll|@|t 1ttqg+ v Lo @80 A& a2

input reset}
output WA
output R_kr
inout [7:0] data:
output [7:01 addr:

wire [4:0] CH:

wire [2:0] alu_mode?
wire [2:0]1 bus_modes]
wire carry_mode:
wire 51z

wire [7:01 ALU:

ET e 18 e
= Loading package pkg,

® Use File & Print to print out design tree.

Verdi 5.4 Basic Training -02/22/05
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r .

® Color-coded source code display.

® Double click

® [nstance name to go to architecture or module definition.

® Module name or architecture type to return to calling instance.

® Architecture name to go to
entity definition.
® Signal name to find the

driver.

® vi compatible binding keys.

Verdi 5.4 Basic Training -02/22/05

snTracetaingly system.i_cpu CPU {verilog/Toptodule,w)

File Exploration View Source Trace Tools Window Help
o EDE @t.ree a4 LB ¥
AT
;ﬁsystemtblkﬁ 28| “timescale 1 ns 4 1 ng
B i, | child1 {fzm_c 29
Bi Child-'-? Itsm_c 20| module m{clock, reset, WMA, B_W,. ‘data, addri:
i § EhiIGs il e 3| tnput clocks
Bl i_cpu (CPL 32| input reset:
B | I ALUE (A 33| output Vi
Bl ] i CoU (o 34| output 11
© LI Ei PCU pe 25| inout [730] data:
L% pram (pram 36| output [7:0] =00z
e
Bl | mester ifam_ 7 :
'.i!_ sitd_logic_11l34 38 Wire [4:0] EH:
(| bl 3
—-- Loading package pka.
—-= Loading architecture pram of pramz,

Nows



nTrace — Message Window *

...-l""
-

——

® | og of debug session.

® Double click on line to go to that location in source code.

:nTracetlainil> system,i_cpu,i_ALUE ALUE (verilog/ALUB.w)
IEiIe Exploration Wiew BSource Trace Tools Window Help
A EODE »/tved an b L 0B |2
SYSLUIIII.LIII'.J 9?
Ch”d1 H5n1_chﬂc 98| always Binegedge clock or negedge reset)
child2 (fsm_chile 93| begin
child3 {fsm_chilel (] 100 if {Ireset) IHR_tmp = B7hO0:
e ] 101 else TTRENY = (103
AL ALLIE ALY 102| end
Ea 3 primitive 103
E i"!E-LJahJ(arnr 10d| alwayz Binegedoe clock or negedge resetl

=l I3

£ 2% system,i_cpu,i_ALUBR,IXR_tmp[7:0]1 /% results of trace driver %7
#<[ werilog/ALUR, w100 s if (lreset) IHE_tmp = 87 hoo:
#<[ werilog/ALUR,wil0li: elze [HE_tmp = IHR:

*zyztem, i_cpu.i_ALUE 3 2 driveris;
#Total 2 driveriz}

s yPprhbrn\yr\ooyoryyoivY¥Uvo
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nTrace — Find Scope

® Source =2 Find Scope... is a fast way to directly open a Verilog
module or VHDL architecture if the design tree is deep.

® Choose by type: File, Module, Task or Function.

® Enter search filter using wildcards.

- |I:I|i| ¥ Open - ||:| |i|
Type: w Flle w Task ~ Function Type: ~ Module -« Task ~ Function
Sorted: 4> By Alphabet + By Call Level Sorted: 4 i Aabne
oo CCUv |
BCll FCUy
S Tophodu
fatn_child aluly
fam_child2 child v
fatn_child3 childz v —
famm_master childa.y
pram master.v {
system
S neTaneA T Filter: | 1 module define in file CCLLy Filter: I
Save.. | GoTo | Close | Save.. | GoTo | Close |

Open by Module Open by File ”
OVAS
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nTrace — Find Signals and I;tances

® Source =2 Find Signal..
signals/instances/Instport in full design or selected scope.

——

. Is a fast way to find

® Supports wildcard characters and regular expressions.

signal
. Instance

- Instpaort

Verdi 5.4 Basic Training -02/22/05

Find Signal

-

Find; @ =

——

|13¥STEm-“C?U"E _| Find Bmwse...l

system. clock m
system. 1_cpu. carry mode
system. 1_cpu. clock

system. 1_cpu. 1 ALUB. carry mode

system. 1_cpu. 1 ALUE. clock

[ [

— Options
Delimiter: | W Search Full Scope
W hiatch Case _| Include Library Cell

Saue...l Close |

Nows



nTrace — Find Strings

Pattern: |ALU

7 Match Case

_| Language Determines Case Sensitivity

“ |n Current File Previous | [ext |

~ I All Files i |
in

Close |

® Find String on toolbar quickly locates a string in current scope.

® Enable/disable case matching under
Tools - Preferences, Source Code tab, lI j

Miscellaneous tab.

® Use Source = Go To command to jump to specified line or First
Executable Line.
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nTrace — Trace Drivers andjlkoads

-~ -

® To quickly find all the drivers of a signal
® Double click a signal.
® Select signal and click on Trace Driver icon.
® Trace - Driver or Right Mouse Button menu.
® To quickly find all the loads of a signal
® Select signal and click on Trace Load icon.
® Trace -> Load or Right Mouse Button menu.
® To quickly find all the drivers and loads of a signal
® Trace - Connectivity or Right Mouse Button menu.
® Dropping a signal in the source window will trace the connectivity of the signal.
® By default, tracing will cross hierarchical boundaries.

® Use Trace > Trace Cross Hierarchy to keep within a hierarchy.
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nTrace — Trace Driver/Load Toeol Bar Icons %

E

——'-

=

Forward History Show Next

Trace Load

A
@i%xﬂ" L}‘t‘ ¥

Trace Driver

Backward History Show Previous
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Show Previous Instance

v
+3
)

Show Next Instance
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nTrace — Search, View and Debug Source =&

Code
v

® Searching

® Find Scope
® Source = Find Scope

® Find Signal/lInstance
® Source = Find Signal

® Find String
® Source = Find String

® Bookmarks E

® Source - Bookmark
® Multiple Source Code Windows IE

® Editing Source Code "E’I

® Tools - Preferences... to select your preferred editor.
® Source - Edit Source File
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® Display simulation results on source.

® Source 2 Active Annotation in nTrace
® Signal values/transitions are synchronized with cursor time.

® Select signal(s) and go to next or previous transitions.

® Any Change, Rising [o s v s tus s s oo
i A EDE 2/ t.ve® b v B8 &%
or Falling R -—

n|_

JFadb

G ALUR, 3 — Ahome

Sekected: (1) 51

30 5] Y0 = IXR_tmp:
E-Eﬁ =yaternibli) a 55-;:20P
@l | child1 {tsm_child1} 91 E: \;0 = HS%E_tmp:
@A | child2 (tsm_child2) g2 e W0 = B7h00:
o g
94
- i_alu {arithlogic 95 'assign net_1 = {IR[0) == 0 ? zero_flag i carry_flag:
E‘ [ L i_GCL {CCUY a a a o
1 B?. I — + + | Elq-SI:E i PoU {peulpeul) ] 96| as=sian ?:: NE_:+|_'|[0] | (NEEIH[l] & (_IOR[:I.] - 'T]et_i});
i_pram (pram2 pram a7
:: 8 master (fam_master) )
m 65 =td_logic 1164 98| always B{negedge clock or negedoge reset)
f = M standard * |
al |
E 2> system,i_cpu,i_ALUB.S1 A% results of trace driver #/
<0 werilog/TopModule,wiB32: . ,51(51}
system,i_cpu 3 1 driver pazs-throughis}
#*{D> verilog/ALUB.w{(36Y: assign 51 = “CHLOD | {“CHOL] & €IRC1D © net_100:
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nTrace — Trace Results and Report

e Trace - Save Trace Result saves
Driver/Load/Connectivity in a file for future review.

® Record maximum 32 level trace results.

Trace History: | Selected:

1 =0 =ystem.icpu.datal7:0]

pu.datal7:0]

File Exploration View Source Trace Tools Window Help

4 =G> system.iopu.LALUBALLT:

@| bl [ .| '@‘ LY o4 ¥ B h 5 <G> systemicpu.LALUBSmoLD

73 if RW = 17 then —- Hemory Read eb;aial L]
{] 8o S <= memito_natural{addrris

e ]

: i a1 fazdblumpMenMowt " F=ystemi_pram/mem"
EE" .3|JrIITIItI‘-."B.5 az else —— Memory Write
' ot 83 — memito_natural taddei? <= dout:
'—E:CU {oou [ a4 mem{to_natural taddr}r += dout:
i_PCU [peufpe 85 fedblumpMentowt " fsystend i _pramdman”
i p['inll:p'F.l'l'L:?t[r
=l ¥ v
{IL> whdl/system_state,whd{121}: . dout => data i [ P i |
systen 3 2 driver pass—throughiz), 2 load pe
<DL werilog/TopHodule,w(E23: . .dataidatal Preview:
aystem,i_cpu : 1 driver paszs-throughts), 1 load pz - £l
i hdl/pram_mi W out <= memito_naturalladdrdi: g - =
WL> Whal/pran mixed vhalidrs menttn nstural laddr)) o= dout? - ::::ﬁ:i:::iz::::jﬂ;f: :Z‘; =
#<D> whdl/pran_mixed,vhdt83}: dout .<_ tothers =»"773; system.i_cpu : 2 driver pass-throughis), 2 load pass-throughis)
¥system,i_pram ; 2 driverfs}, 1 loadis} <DL > veriloaTaphodule vE2): | dstaldata)
<[> whdl/PCU_record.vhdi98): data <= (others => "Z73: systerm.i_pram 1 driver pass-throuahis), 1 load pass—thraughts)
#{0> whdl/PCU_record,vhdt100}: data <= n_gh: *<D= vhdlipram_mixed vhd(80): dout <= memito_naturaliaddr));
#{L> uwhd]l/PCU_record,vhdt{160}? process (C1. pocu_dout,one_bit, datal *<L= vhdl/pram_mixed vhd(84): memito_naturalizddr)) = dout; i
#<] > yhdlAPCU_record,whd(16E67: pou_din.eight_bit <= data: B = P
#zystem,i_cpu,i_PCU ¢ 2 driveriz), 2 loadis?}
*Total 3 4 driveriz), 3 loadiz), 2 dri

Nows

Verdi 5.4 Basic Training -02/22/05



nTrace — Bookmarks

= —

Click on Bookmark icon E on toolbar or use Ctrl-F2 to toggle a
bookmark on/off at the current line.

® Use Source - Bookmark command to get list of current
bookmarks.

® Supports unlimited bookmarks.

..... e = — = Bookmark.
rTracetiainil> systen, i_opu, i_ALUR ﬁu Joaknark
File Explaration View Source Trace Tools Window He| Bookmarks:

ﬂ|‘®| %, .‘*t\m o + * | I MName | Loecation |--' Goto |
veriloglal LIB wiGE): assign net_2 = (AL ==&'h30) & (~CH[1];
systemntblk) gi ok (T eTodks CHDAT: arithlogic.vhd{E3|vhdliarithlogic.vhdiBS): result :=result1(s downto 0y, Delete |
child fam_child1) E2| and ¢T3, clock, CHIZID: PCU_record vhd|vhdl/PCU_record.vhd{100}): data <= n_q0;
child2 {fam_child2) B3|and (T2, clock, CHL21): s |
child3 (fsm_child3) &4
i_cpu (CPLY E5
B i_ALUB (ALUB) [ B6|Essign net_2 = {ALU == &
@ (2] 3 primitives 67| az=ign net_3 = & (IR
“""- i_alu farithlogicia B8] assign error_out = net_2 e
(] 1_CCU (oL B3 o] e
i PCU [peulpou)): &
= oppei _Giose |
-- Loading package body functions,
-==—--
ﬂ—]_l
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nTrace — Source Code Editig

— ——

® Use Source - Edit Source File command or click icon ‘%ﬁl to edit
your current module.

® Use Tools = Preferences... to select your preferred editor.

Source Code] .Waveforrn] Schematics] FSM] Mernory] Slmulation] Editor] General] Auta Source]

Your Favorite Editor :

nEditor| W1 | Emecs| TextEditor| Other]

Gommands Before Invoking Editor:

I xterm —font 9x15 —fg black ~bg gray -&

Editor: I vi

Optiens: I +H{CurLine} ${CurFileMame}

‘['_ Set as Default Editor

OK | Cancell

® Use File 2 Reload Design command to update the changes.
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nTrace — Miscellaneous

® Use Tools > Preferences... to customize the appearance and fonts
of the hierarchy browser and source code browser.

=]

Saunce Code] Waveform] Schematics] FSI"."I] Mernory] Simulation] Editor] General] ALt Source]

Color] Design Tree] Imparting Design] Yiew Options] UerilogNHDL] Spice] nLint] Miscellaneous]

Example:

Font: Small12 — | _I 3D Active Annotation  _| Show Special Comment

Type: Cutput Signal — | Tab Size: I g

HEEDT ]
mmEEEs

.  § § RN
s “T AR
{11 | Imimimi
EREEDO0

EEEEEN
EEEEE ] Default |
Awwl

OK | Cancell

® Use Help - Command Reference for additional information.
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nTrace — Wrap-up

o

® Questions?

® Take 20 minutes to complete
the nTrace LAB

D> |

Verdi 5.4 Basic Training -02/22/05 MVAS




Training Course

-~

nSchema — View and Debug Designs Graphically
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nSchema — View and Debug D

Overview

Invoke nSchema
Resultant Schematics
Display Source Code
Traverse Hierarchy

Searching Commands

Display Options

Verdi 5.4 Basic Training -02/22/05

Signs Graphlc'glly

b

.F-"_'

.‘_

® Schematic Window Types
® Full Hierarchical
® Browser
® Flatten

® View Detail RTL

® Clock/Reset Tree

® Miscellaneous

® Lab

Nows



nSchema Overview

o

® Automatically generates schematic of design
® Gate Level, RTL, behavioral Level
® Hierarchical or flat
® Fan-in or fan-out cones

® Highlight logic between registers
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Invoke nSchema

® The “New Schematic” icon ﬂ\

® Select an instance in Hierarchy Browser and click on New
Schematic icon.

® Drag & Drop an instance from the hierarchy browser or a Verilog
module or VHDL architecture from the Source Code Browser to
New Schematic icon.

® Execute Tools = New Schematic = Current Scope in nTrace.

Verdi 5.4 Basic Training -02/22/05 MOVAS



nSchema — Resultant Schegtics

— ——

® Storage elements need to be recognized for complete tracing ability.
Gate level schematic displays cell level netlist.(Symbol libraries required)

® RTL logic diagram displays synthesized view.

® Signal type -- clock, reset, set, flip-flop / latch output or tri-state output

® Block type -- latch, flip-flop or combinational logic

® Enable/Disable Detail RTL option under
Tools > Preferences, Schematics tab, e e e
RTL tab. —Detml AL Opten——————— RTL Opton
® State machine recognition as symbolic or '7 B
logical views. . - .

—Toggle Detaill NonDetail RTL

7 Detail RTL

Hots

® Enable/Disable FSM Recognition option under | [ s
Tools & Preferences, Schematics tab,

RTL tab oKk | cancel |

Apply
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e To quickly understand what RTL construct created a logic cell

e Double-click on the lowest level RTL to opens View Source Code box of the
corresponding RTL code.

e Drag & Drop a schematic object to nTrace dlsplays the corresponding
source code. p—

~ FI|E Exploratlon ‘u"lew Source Trace Tools Wlndow Help
File Wiew \Window . =T 8§ SO _|| EE— |>>|
E | ﬁ" ‘& 72 +ealu_out(ALUY L carryicarry) |, Lzerofzeroll:
systemibli)
1B & |1 child1 ifsm_child1)
2[ 44 1==bverilog/ALUE.w - werilog/ALUE,w SeHTd T o#81 11 child2 {fsm_child2)
3| always Bibus_mode or IXRE_tmp or ACC_tmp or FC or IDE 3 child3 ifsm_child3)
4 caze (hus_model
g 0y Ho = [EE_tmp:
E 1t H0 = ACC_tmp:
7 e ¥ = PC:
g e H0 = ACC_tmp:
i default: Ho = IDB:
10 endcaze =i [ |
11 record,vhdt 166} : pou_din,eight_hit <= data: E
([ 2 driveris?, 2 loadisd
[« )
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nSchema — Traverse Hierariy

—

® Push Into a Module
® Double click on instance or instance port.
® Select an instance and click the Push View In icon E
® Invoke right mouse button menu and select Push View In command.
® Pull down View - Push View In.
® Pop View Up
® Use the Pop View Up icon m
® Double-click on a schematic port.
® |nvoke right mouse button menu and select Pop View Up command.

® Pull down View - Pop View Up or View > Pop View Up from Port.

® Click the Last View #==| icon to go to previous view.
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T —

® Schematic - Find Signal/Instance...

finds signals or instances in full design.

finds signals or instances in current scope. | [ssem ma] 4 | S | T

Find Signal

® Schematic - Find In Current Scope... Find:  signal

I syetem.i_cpu.alu mode[2:0]

Verdi 5.4 Basic Training -02/22/05

Find: F——— syvstem.i_cpu. bus mode[2:0]
system.i_cpu.carry mode
Al mpde e 0 svetem. 1 cpu.i ALTE alu mode[2:0]
i et zen system.i_cpu.i_ ALUE bus modes[2:0]
carmys mode | e |
— Options
w il I ; ™ Search Full Scope
| I3
I Match Case I Include Library Cell
Type
“* Signal  ~ Instance
I Match Case Save. . | Close
Sawve As. . | Close |

- Nows



nSchema — Schematic Winiw Types

T —

® Full Hierarchical Window — default type
® Partial Hierarchical Window
® Browser Window

® Partial Flatten Window Full Hierarchical
. Duplicates Current Schematic
® Flatten Window /
® Fan-In/ Out Cones e Aeore |_> Partial Hierarchical I
\__ﬂew Schematic I | Flatten Window )

Browser Window

Mew Design Sheet B By Seiealeg
De=ign Sheet Editar ECOWindaw far All
ECO Utility e | B Do el

Extract Interactive FSM... Fan-In Cone Partial Flatten
i Fan-Out Cone

o
L LAY LA LAY

- - - Diriver
Metlistcom information... =
e ; Load
Browse Structure Signal... = .
= Connectivity
Freferences... et

Options " | ResetTrese y,
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View, traverse and understand design hierarchy graphically.

Double click a symbol port to push into the lower level and highlight the

associated net. E—
. ) : Vi E T S e e
Double click on a net to highlight |

all instances which connect to this net.
Trace menu will highlight a variety

of different objects in current window.

Search commands

ol
-

£l
I@I Command Dane

® Schematic - Signal/Instance/lnstport...

® Schematic - In Current Scope...
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nSchema — Active Annotati;

==

® Display simulation results on source.
® Schematic - Active Annotation in nSchema

® Signal values/transitions are synchronized with cursor time.

VerdimSchema:2> system.i_cpui ALTUE = |D |i|

. Select SI nal S and O chematic Trace Tools Window Help B —
9 ( ) g |Q®\1%°|@|¢°t.'1|it\m9+*{Jﬁy:f ++|me

i

Selected: (1) Met; n740

to next or previous
transitions.
® Any Change, Rising

or Falling

&| Command Dane
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nSchema — Create Partial Hierarchical

Schematics

® Focus on a specified instance or net for debugging.
® Select net(s) or instance(s) while holding Shift key.

® Use Tools - New Schematic - Browser Window to generate partial
schematic.

® Hierarchical schematic with only those instances connected to selected nets.

® Hierarchical schematic with only those nets connected to selected instances.

® Double click on symbol port to push into the lower level and highlight
the associated net.

® Double click on I/O port to pop up one level.
® Add / delete objects.
® Undo / redo edits.
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-
=
bt

[E " nchenatd> Partial Hierarchical View EElE]

File Edit View Schematic Tocls Win ] File Edit Wiew Schematic

0| o 2 4| B - b 3 dD Ayl rojelaay

||| Selected: (1) Met: ALU[Z:0]

nSchema — Browser Windo

L[ 7:0]

I I [=] I I [=] T a =]

arithlogiciarit...
1

|

I P N EC i R I R [ IR T R i FR i F 5

& | Command Done & | Command Dons
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nSchema — Create FIattene%Schematics

Pl

—

® Focus on a user specified area of the design.
® Select primitive.

® Use Tools - New Schematic - Flatten Window to generate flat
schematic.

® Add logic by double clicking an instance pin or drag and drop from
other windows.

® Select object and use <Delete> key or | 4 | icon to remove object
from schematic.
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File Edit View BSchematic Trace Tool
QA Y| 22| B -] 2y

|| Selected: . Instapstern.i_cpu.i ALUB. U250

{1

|| Command Dane

&
_made_reagld]

I

_ -:E‘.*|Tr:.=1c:_5e Stop at 0 Port(s), 0 Reals), 1 Mon-Reg(s)
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nSchema — Create Flattened Schematics — &

Fan-in / Fan-out Cones

Pl

® Focus on all drivers or loads of selected object.
® Select object (net or primitive instance).

® Use Tools » New Schematic = Fan-ln Cone / Fan-Out Cone to
generate flat schematic.

® Add logic by double clicking an instance pin or drag and drop from
other windows.

® Select object and use <Delete> key or # | icon to remove object
from schematic.
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- . .
=] L e e e T e e e e
A= Cihachemaias View frace Fan—lp Longe Result o LT

File Edit View BSchematic Trace Tools Window Help
Q & W B L By o |- -bl »

Al

i
ﬁﬂ Command Daone _
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® New option: View - Detail RTL

® Effective in that window only

- == S - e e
= : . nSchemas?y system.i_cpu.i ALUB. el [~ ' nSchenas2y system,i_cpu,i ALUE [
File Wiew Schernatlc Trace Toals Window Help | File Wiew Schematic Trace Tools Window Help

2, Toalbar... | Ly & ¥ 5,
| el © Message Line

b b

vy o |) Q@D B etV € ood ¥4

| Selected: (0)

-

InztPart Mame
12 Port Name
" Module Name
F Entity Name
r Arch Name
Instance Nams
Het Name

Complete Name

© Preselect
Parameter List
High Contrast

< Detail RTL >

Zoom

Fan
Pop View Up Fram Port ...
Pop Wiew Up

Push View In

folc_ LetViow Non-detail RTL ] & Command Dons Detail RTL
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nSchema — View Detail RTLon Instance B! % :‘ \*

?’%

L

® On RTL Block, RMB - Display Detail RTL Block
® New window with details will pop up

= . ansch 2 system, i_cpu, i ALUE | ] = thich atten Window NEE]
File Wiew Schematic Trasce Tools Window Help File Edit Miew Schematic Trace Tools Window Help

e[t e ant v 2 m oy [R8F[Scb[@Fw]adofs sofjer]  on

| Selected: ..1) InstALUEB:SigCpd: 97 97 Comba e

L3,

Imet..B:Siglpd:87:97 . Cambe
Drag Cirl+o

Drap Cirl+w
Copy Full Path To Clipboard  Gtrl+h

Trace Driver

Trace Load

: Wl Trace Connectivity

[ Focus Connection

Show Ma, of Driver
Show Mo of Load

PR

F'op View Up

]
]
]
| |
Push Wiew [n
Display Source Coae T
QLizplay Detail RTL Block 2 & | Command Dene

@

List Ports

[ & | Command Done
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==

® Select one or more pins then invoke RMB - Show Detail

Connection

® All detailed connection information will be shown and can be

saved as text file.

Trace Tools Window Help
t

T e e

2in: i_CCU : CHE:0)

InstParti_CCUCH[4:0]

rar Cirl+c
ap Citl+y
py Full Path To Clipboard  Ctrl+h

ace Driver

ace Load

race Connectivity
Facus Connection

Show Mo. of Driver

Show Mo. of Load

Pap Yiew Up
Push Yiew In

i
15t Ports

kulti-selected ahj

Select multiple pins

‘Bus Connection

Selected obj

|Fr0m

[

Ta

system.i_cpui_CCU.CH[4:0)

system.i_cpui _CCLLCH[4]

system.i_cpu. CHI4]

systerni_cpui_ CCU.CH[E]

system.i_cpu, CHI3]

systerni_cpui_CCU.CHE2]

systerni_cpu, CHI2]

systerni_cpui_CCU.CH[1]

systermn.i_cpu. CHIT]

systerni_cpui_CCU.CHO)

systermn.d_cpu. CHIO]

system i_cpui_CCU.alu_mode[2:0]

systemii_cpui_CCL au_mode[Z]

systerm.i_cpu.al_moade[2]

systern.i_cpui_CCU & _rmode[1]
| —— ; r

system.i_cpu.alu_mode[1]

I

< SaueDl Close |

J Save as a text file
Verdi 5.4 Basic Training -02/22/05 OVAS



nSchema — Miscellaneous *

...-l""_

— ——

® Use Tools - Preferences... to customize the appearance globally.

Source Code] Waveform] Schemafics] FSM] Men‘nory] Simulation] Editor] General] Auta Source]

ColorFont] RTL| Symbol Map | Symbol Lib | Misc| Viewing | Select| SDF| Trace | ECO] Reusner|
Type: Background —~ Fent Style and Size: |
Line Style: = I Autom
N Gom——— ricoi Ao Helvetioa 8 \ Manually control the font used
“F pmmEm carke Hobet e for names on schematics
..... SRS e
1 I Courier 18
.‘.'. gL_H | Font:
I ]
.'.-.. :
HEEEE _' Default

_— Apply settings without leaving
(Q Aoy | ) the Preferences window

oK | Cancell

® Use File - Print to print multi-page schematics.

® Use Help - Command Reference for additional information.
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nSchema — Miscellaneous (gunt.)

- —
--'5- - =

® Use Tools - Options > Trace Cone Stop On Module Boundary or
Tools > Preferences... - Trace tab to force Trace - Fan-In Cone/
Fan-Out Cone to stop on module boundary.

® Set the constrain for tracing the inter-connection net.
_\-'{P"Ieferen-:::ez: i il

Source Code] Wavefc:rm] Schematics] FSM] Memory] Simulatinn] Editnr] General] Auta Source]

ColorFont| RTL| Symbol Map| Symbol Lib| Misc| viewing| Select] SDF | Trace| ECO| Reusner]

< ~ [o Mot Trace Inter—-connection MNet \)
~i Wnstance Mumber |s More Thanl 100
Fan-InfOut Level: I 1 I Group Cel TYFES ot ack Boxzes
_I Expand to RTL boundary for Detail RTL window When Trace Driver,Load, Connectivity

7 Stop On Clack Pin of Macra Cell When Extract Clock Ciomain
_I Distinguish Async/3ync-reset on Reset Tree (Cnly for detail BTL mode]

Trace Cone
_| Stop On Module Boundary

_I Recognize Assign_statement As Met

I Clock Analysis With Polarity Information

Apply |

0136 | Cancell
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nSchema — Summary

-~

® At this time you should
® Understand the nSchema functionality.

® Be able to open a schematic and relate the symbols back to the source
code.

® Know how to locate signal(s) or instance(s) and generate different partial
schematics.

® Be able to access and change the preferences.

Verdi 5.4 Basic Training -02/22/05 MVAS



Training Course
-

Verdi 5.4 Basic Training -02/22/05 MVAS

nState — View and Analyze State Machines



nState — View and Analyze State Machines ¥

T

o

—_—

Overview

Invoke nState

Display Options

Partial FSM

State Animation
Analysis Report
Interacting FSM Display
Miscellaneous

Lab

Verdi 5.4 Basic Training -02/22/05 MVAS



nState Overview

® Display and analyze finite state machines.
® Show or hide conditions / actions on a state or a transition.
® Search by State Sequence.
® State Animation using current simulation results.
® Generate analysis reports using current simulation results.
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Invoke nState

I " T e T
| “'-“‘1 S 132 th, | _Blker :?s

S et

File View Schematic Trace Tools Window Help

a ® 1@9\ @-| - i, "1\ X TR A

| Selected: >3

[&| Command Dene

File VWiew FSM Tools

aa¥[@~[o 0o e b

Minus 10

AL
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nState — Display Options

® Use View > State Action to SR ) s
display signal assignments for a@ﬂ%él@l*-\a;**a\%@levre 43

each state. i e

HexbCard=1°kl;
OE=1°hb0;
Fail=1"kL0;
bEemp_Ace=1"hb0;

® Use View - Transition
Condition to display transition
condition on the state diagram. T

Fail=1"kE0;
Eemp tobkal={Tokal + Cardl:
bemp_Ace={{Card == Ll| | Aoe|;

® Use View - Transition Action
to display signal assignments for
each transition. e
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nState — Partial FSM

® Create partial FSM views to aid understanding

File View FSM Tools Window Help File Wiew FSM Toaols Window Help

Q&AW @ o e|BE Bve g e QAW @ | & oo e BE By 62
.

I
5| Seamh By States
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nState — Interacting FSM Diay

—

= |

® Use Tools > Extract Interactive FSM... in nTrace or nSchema.
® Shows the interaction between multiple state machines.

—l°  .nState:f> system.child3,Fsm_child3(( = 1nStatet10r systenm,childl,fan_childld®] - | i
File ¥Wiew FSM Tools Window Help File View FSM T Wi Hi File View F3M Taools Window Help
QAR Y| @ +|e o[BS 2 QAP @ «|e o] B 2 QAR B «|e o[ B2
2 F &
e

) N
@l Zaio —= One

®| ET_Zumi Seamch: Done Zearch: Done (‘9| ST C-=5T_DO Search: Dons

i
[
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nState — State Animation 1

® | oad simulation results.
® Enable FSM - State Animation.

® Use Previous State / Next State tool bar icons to step through the
states.

® Use FSM - Edit Search Sequence to create a sequence of states to
search on.
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nState — State Animation 2

=8 inTracetaingly th CPUsystem.i_Blkernsl Blkernel (Blkernel.wd - .f'hume.f"...."'ue|!.-.-' a b =, i_Blkernel,Elkernel (B13 :FS = ”%*"“]ﬁj‘
File Exploration View Source Trace Toals Window Help | F|Ie View FSM Tools Wmdow Help
B
ﬂ| ‘ ®| T T ey 43:‘ =] >v>|55;amd;¢an Q& 1%0‘ @| -l .,E| e @| By & 2
By_r—l ++|9'30 x1n= | Ei
A BT 0K = L°b0; ‘1
EI{m_ltb CF'Usystem o]
Blkernel wernel) 97 Fail = 17b0¢
e El._lsource iEl._Isource 9a o
B ] i_CPUsystern (CP L=y
i_CPU(CPLY 59
|l ] i_ALUB (ALLIB)
|1 CeU(CCU) &9
£ i_PCLU{PCLY) 101
L] i_pram (pram)
L2 | 102
e
|
E 1> th_CPlUsystem,i_Blkernel,statel2:01 /% results of trace driver #/
#<I> Blkernel,wiBB}: state = next_state:
state[Z2:0] Mimnus 10
=
e
[ | 2 T | & Compare 16 - MomCard Ssarch: Done
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nState — Analysis Report

® Use FSM - Analysis Report to display analysis report.

® Details of FSM interpretation. = PY P —— 0
. State Coverage report Source Cnde] State] Transitinn]
L. _1“: It°ll detect which fransifions are
® Transition coverage report. ~  novvsted
. . Transition Report
® Save to File command provided. | |
F¥ ««Format:>
=] Analysis Report i i (from_state -»to_state): cycle_
(Bust ->S5tart): 1
Source Code] State] Transition] (Comparel6 -:CompareZl): 10
) (Comparelt -:MoreCard): Z1
_1\ It'll detect which states are {Compare2l -»Bust): 1
i, a0 not wisited. (CompareZl -:Hold): 8
_ (Compare2l -:Minosl0): 1
State Report = (Evaluate -:Comparelf): 30
Vi <eFormmtrs T (Hold -»>Start). B
A state_name: cycle_count (Mirmsl0 -:Comparelf): 1
(Trap State): 1 (Mirmsl0 -:Start): 0
E‘;:\;;rils: a1 (MoreCard -»Evaluate): 31 _
CompareZl: 10 (Start -»MoreCard): 9
Ewaluate: 31
Hold: &
Minusl0: 1 S ESSSssssssssssssssssssssssssssssssss
gzgiigrg: 31 | = Warning ! ! Untested Transition Dete ]
""""""""""""""""""" 7| =] i p=
=] i =
Save to File.. Close Save to File.., Close
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nState — Miscellaneous

T

Saurce Code] Wal.reforrn] Schernatics] FSI"."I] Men‘nory] Simulation] Editor] General] ALt Source]

Color] View Options] Heusner]

3o

Init. State B

Reset State

Trap State Width: 1

State Action ]

Junction

Cannection

Fort Text

Transition mEE

Trans. Condition mEEN

Trans. Action |- :::

Selected Set mEn

Stllck}TSet :::

Highlight Set mmn Default |
¥

OK | Cancell

® Use File = Print to print multi-page state diagrams.
® Use Help - Command Reference for additional information.
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nState — Summary

-~

® At this time you should
® Understand the nState functionality.
® Be able to open a FSM and enable different display options
® Know how to enable state animation and view analysis reports.

® Be able to access and change the preferences.
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nSchema — Wrap-up

o

® Questions?

® Take 20 minutes to complete
the nSchema and nState LAB

D> |
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Training Course
o

Verdi 5.4 Basic Training -02/22/05 MVAS

nWave — View Simulation Results in Waveforms



nWave - View Design Behavi%Using Wavefo'ﬁ‘ns ' *"" B

-~ -

® Overview ® Focus Debug Effort
® FSDB File ® Search Value and Search
Constraint
® Linking Overview ® Markers
® System Tasks ® Zero Time Glitch and Event
o Sequence
® FSDB Utilities _ _
® Logical Operations
® Invoke nWave ® Complex Event
® Open Simulation Results ® Waveform Comparisons
® Display and Organize Signals ® Analog v.s. Digital
® Adding Signals / Get Signals ® Aliasing
Form ® Comments
® Group/Bus Operations ® Save / Restore Signals

® Display Options and Preference @ |ab
Verdi 5.4 Basic Training -02/22/05 MVAS



nWave Overview

Pl

® A complete waveform analysis environment.
® Supports FSDB format (through PLI) or VCD file format.
® Flexible signal group management.
® Fully integrated and synchronized with other verdi views.
® Interactive visual comparison of waveforms.
® Built-in logic analyzer and event searching.
® Capable of displaying analog waveforms.
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nWave — Fast Signal Databasi(FSDB) File ¥

Pl -

® Compact binary file format which contains the simulation signal data.

® Captured during simulation using PLI system tasks for both VHDL and
VERILOG.

® Advantages:
® Smaller in size than VCD.

® [ oads faster than VCD.

® Open file format so other vendor tools can dump data, Verisity,
Vera, Ikos, etc.
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nWave — Brief Overview of O_l‘oiect File Linkin?

Pl -

® In general, use LD_LIBRARY_PATH to point to pre-compiled PLI
shared object files, but simulator and platform dependent.

® All pre-compiled PLI shared object files are found in the software release
tree

® $verdi HOME/share/PLI/<simulator>/<platform>
® Nearly all simulators supported, MTI, NC, VCS, etc.

® Standard PLI source files also available for further customization.
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nWave — System Tasks to Dtgp VHDL to FSDB File.

&

—_..--

=

fsdbDumpfile - Specify FSDB file name.

fsdbDumpvars - Dump the specified instances and nets.
fsdbDumpvarsToFile - Dump scope/depth from a designated file.
fsdbDumpon - Turn on FSDB dumping.

fsdbDumpoff - Turn off FSDB dumping.

fsdbSwitchDumpFile - Switch dumping to another FSDB file.

fsdbAutoSwitchDumpfile - Limit FSDB file size and switch dumping to new
FSDB file automatically.

fsdbDumpMem - Dump the contents of specified memories.

ote:  You must link your VHDL simulator before you can use the
above system tasks. See Command Reference.
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nWave — System Tasks to Dump Verilog to FSDB F-ile:"'

o

$fsdbDumpvars - Dump the specified instances and nets.
$fsdbDumpfile - Specify FSDB file name.

$fsdbDumpon - Turn on FSDB dumping.

$fsdbDumpoff - Turn off FSDB dumping.
$fsdbSwitchDumpFile - Switch dumping to another FSDB file.

$fsdbAutoSwitchDumpfile - Limit FSDB file size and switch dumping to new
FSDB file automatically.

$fsdbDumpflush - Force to dump result to FSDB file.
$fsdbDumpMem - Dump the contents of specified memories.

$fsdbDumpStrength - Dump the strength of signals.

$fsdbDumpvarsToFile - Dump scope/depth from a designated file.

Note: You must link your Verilog simulator before you can use the
above system tasks. See Command Reference.
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nWave — FSDB Utilities

® vfast

® Command line conversion of VCD files.

® fsdbextract

® Extract signals, scopes, time periods from existing fsdb files
without re-simulating.

® fsdbmerge
® Merge several fsdb files into one.

® fsdbreport

® Generates a report of value changes for specified signals.

Note: Use <utility> -h for a list of all options or see the Command
Reference for more information.
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nWave — Invoke nhWave and Load FSDB Filg

—_..--

=

® To open nWave from nTrace, click on the New Waveform icon Eil
or Tools - New Waveform.

® Use File = Open or toolbar icon 2| 1o open simulation results file.
® On the verdi command line use the option

-ssf <filename>.fsdb

® Load VCD files generated by $dumpvars.

® VCD files are automatically converted to FSDB at load time.
® Open several files in the same window.

® Use File - Set Active... to specify which file is active.
® Open several files in different nWave windows.

® Use Window -> Change to Primary to specify which window is active.

Verdi 5.4 Basic Training -02/22/05 MVAS



nWave — Adding Signals

-~

® Recommended method:
® Drag & Drop signals/instances from other windows to nWave.
® All instance 1/0.
® Selected signal(s).
® Signals in text region.
® Schematic hierarchical blocks or logic gates
® Other methods: _
® Use Signal - Get Signals... or toolbar icon E'
® Select signals and use RMB Add Signal(s) to Wave in nTrace.
® Select objects and use RMB Add Select Set To Wave in nSchema.

® After executing a trace command in nSchema, use Trace - Add
Result to Wave.
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nWave — Get Signals Form

® Directly Form Bus based on user-defined rules. Sub-block information of selected
block in hierarchy browser

® Option to Find Signals in full scope.

Cet Signals —|

® Option to display signals ; : -
. . cope: |fsystemfi_ch§ gna nnn ...
in order of selection not . =il ...

alphabetical.

i_alub i_ccu i peu

Ba[“_‘|| _ccu(ccu)
[ peu(pey)

. Slgnal type fllter. éDl_pramZ(pramZ) q

(] pram0O{pram0)

L Adaces :
— Options / n "ac 7.0
|_I Find Signals ——= Match Case | - .?::

_| Find Signals ——= Search Full Scope

n_tdh0[7:0]

W

reset

VIa
LOGIC_LOW
LOGIC_HIGH

q i rag Selection Follow Column ; r: H n:mux_se -
4 Eis[?l:y lDe;igan-ii!rar;yl Box . i “—PCD[?:;?[Q Use Wlldcard _*’? to get
W Display Subscope Box a.” matChed Slg naIS

Signal T -
#‘ = T — ¥
Al | Input _| Output _| Inout _| Met _|Register _| Buffer _| Linkage | | [ o | T = | [ |
o

~——
Close | Advanced... J4| Hﬂﬂﬂﬂ rm Bus Rule: F _| Apply QK. Cancel |
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nWave — Group Operations .

® Use RMB menu in signal window to:
® Add Group
® Rename Group name

® View - Go To Group... or RMB Go to Group <Select Group name> jumps to
specified group.

Rename

® Expand / collapse group member by double clicking. ' e
: - Set Signal Cursar

!Eile Exploration Signal Wiew Waweform Analeg Toole Window Help
0 1} | Q @l 1%0| By: J o+ » Inzert Subgroup

o8 Gollapss Grou

Add Group

Go Ta: G3

Dirag

Crop

Cut

— e
1 Ll &
|| S | - [

Copy

Paste

———
] z

Caopy Signal's Full Path

it
] 3 2 5
.. Create Bus

b
Ele HPS AR RS

Add Comment
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nWave — Hierarchical Grouz

- —
--'5- - =

® Invoke RMB = Insert Subgroup to create sub-groups of selected groups
® Each group/sub-group can be renamed with RMB = Rename

® |nvoke View - Group Manager... to open the Group Manager form

® Select a group in Group Manager form and click New Subgroup to add a new
group under the selected group.

. File Exploration Signal View Wawvelorm Analog Toolz Window Help
® Click the Move To button to T T - SECCEE
move the selected group/signals T

in NWave into the selected group
in the Group Manager

® Delete the selected group and
subgroups
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nWave — Aliasing

® Use —autoalias command line option for automatic mnemonic recognition for

‘defines and parameters. =)
. Alias Tables: 1 Slice Tables: 0 Append... | Save As.. |
® Use Waveform - Signal ]
Value Radix - Browse Alias B e ooueied =
to create an alias file and S|
apply tO a S|gnal. ”\Tlii Delete Alias Table |
® Apply color to alias o Delste Alzs |
® Create a copy of a signal and = HiTh
use RMB in value column Lo Hi
. LDX/ EE
to Remove Local Alias. o
]-‘ llll |
le Explaration Signal Wiew Waveform nalog Taals Window Help ..
@§|Q&g| b b D |Q®\1Q‘P|Byzg++>2|>3
|||||||||| —

......
Z0 il ] 20 5}
| —] | E— |- ] | S S
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nWave — Add Comment '

-~

Use Signal = Comment or RMB menu in signal window to insert a comment
field at cursor position.

Four comment box types provided: box, attached box, period and arrow period.

|~ _ollave:Zs ‘home/, . /denos/mixed/mixed, fsdb
File Exploration Signal Wiew Waweform Analog Tools Window Help

loaoios m@| e 1450 sz | Q& P/ Ey £ o« xins |GeTo

- o, N L e

= EEETE

ik O O G O O O

. EW

i s e’ N1 - e———
.. Amata[7:0] . : )—qcm [

Verdi 5.4 Basic Training -02/22/05




nWave — Bus Operations ;

= Edit Bus
® [nvoke Signal > Edit Bus or RMB menu in signal e
window to edit selected bus. s Fange
. Start Bit: IT_ End Bit: IU— Reversel
® Create bus from selected signals. —

® Invoke Signal > Create Bus or RMB menu
in signal window. ~Bus Name Fus Farge

® Add Logic 0 or Logic 1 as place holders. = il il B

o

—Analog to Digital Threshold

® Set radix and signal value notation. G I o
® Waveform > Signal Value Radix > 7 Wﬂm B e
Binary, Octal, Hexadecimal, Decimal, R _ MoweUp |

§ system/i_cpu/cs |
I e MMeove Down
ASCI I y A I as LT CAHLC Delate |

® Waveform > Signal Value Notation > _I
Unsigned, Sighed 2's Complement, [asa toge o[

. Adg Logic Low|[ 1
Signed 1's Complement H addsdeced |

® Expand / Collapse bus by double clicking. 1 Dol Selected Sgnals
oK | Gancel
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nWave — Display Options *

...-l""_

——

® View - Hierarchical Name to display hierarchy
before signals

Toalbar._.

® View - Values at Cursor/Marker to display e T
cursor and marker values simultaneously. Values at CursorMarker

Leading Zeras
Dizplay Glitch G

® View - Leading Zeros to display leading zeroS  ; pense siock brawing

m

® View - Grid ... to display grid lines on Grid on Rsing Edoe
Grid an Falling Edge

rising/falling edges and a grid count. i Gosls Tt

Grid Count

Femove Grid

Zoam
Pan

Last View

Signal Event Repart...

Graup Manager...
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nWave — Preferences

®Use Tools -> Preferences... to customize waveform display.
(Settings saved in novas.rc)

® General: Display input/output signals e

in different CO|OrS, Source Code | Waveform] Schematics | FSM | Mermory| Simulation| Editor| General| Auto Source |

SynChronlze flle browser’ etC General] WView Options] WValue System] Colon’Font-‘F'attern] Default‘u’alue] Extended VCD] Reusner]
® View OptionS: Enable hlgh'lght DisplaySignaI] CQnuersionAnributes] Miacellaneous]
signal, radix display, value Left/Right Arrow Key Scroll @ % Waveform Initial Zoom Patio: [1d | %
and signal alignment. Wavstorm Window Drag Zoom Tolsranc: [
® Value System: Change appearance Sepits che [T ) | el
based on values and Signal Grouping P File: | Browse.. |
strengths. GetSignals Form
’;' Ask If Signals Over W _| Search Signals Dynamically
® Color/Font/ Pattern: Change
appearance of windows and signal
types.

oK | Cancell

® Default Value: Change signal height
and spacing. Change default time unit.

® Extended VCD: Change appearance

based on values and strengths.
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nWave — Search Value

® Use Waveform = Set Search Value...

to search signal values.

® Search value accepts mnemonics, wild cards and transitions

= Search Value
Signal Value: |2z Alias... | Signal Yalue: | LD
I Case Sensitive I Case Sensitive

Search Walue

= Search Value

Allas... |

1 | Cancell

2k | Cancell

Signal Value: | ADDA-=55 Alias.., |
I Case Sensitive
2K | Cancel |

® Use Waveform = Set Search Constraint... to constrain search to a duration
of time or nth occurrence of a condition.

Current Ocour I G

th

‘alue of <Search By= is stable for »=

Set Search Constraint

—'||5':' ¥ 1ns
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nWave — Markers

® Use Waveform - Marker to name and place markers.

® Multiple markers supported.

® Use distinct labels to differentiate markers Jump to markers
from tool bar

=]
Tao /ﬁl: \

z500 1.Read LDK:211
2 First write : 14

1 P e

ST
an

i

Anslog Tools Window Help

b -2100 | =, @& 1

By £ -+ xins |Go
Joo

Z0oo
E E-ar;l_LD}L
1

.o O e O 0 s O
e -8 | N ] g o 7

e e |

1
1
55 % Lo =i S T T
=1} —— ToY |LO*p—F LOX oo INCs 5T
Nams Tima Delta to Gumar  |Dslta to Marksr & dd
2100 a 2100

N
First_write 1450 —E50 1450 Delete

g

lame: I Read_LD){ Time: |21 oo == T & T %y T & 1 § T &8 1 T A 1T A=A

Update

i

Jump

-_—
.
| L]

Nowus

Labels always visible at
lhe top of waveform windo
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® Use Signal - Logical Operation... to create a new signal from other signals.

|

Logical Operation

MName: Expression
I access “fsystemdi_cpufclock” & “fsystemd_cpulidbaat | “systemdfi_cpudR_wW"
~ I~
Operators: Expression;
~: B-negation Al access = “fsystemdi_cpusclock” & “rsystemd_cpufvhas” | rsystemd_cpus/B_W"
& : B-and, R-and
~& : R-nand

~| : R=nar

. B-or, R-ar

~: B-=or, R-=or

~"  B-wnor, B-=nor
+ : addition

- : subtraction

<= : |eft shift

== fight shift
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nWave — Complex Event

AN i
® Use Signal »> Event to define and name events.
® Events are signal value combinations or complex sequences of single events.

® Double clicking on Event Name or Expression will invoke edit mode.

Event ] Complex Event

R ] SeHplox Bl eventd = "WMA' ==="b1 &5& "R_W"' ==="b1 Start Session. . |
s

event]l = posedge "clock”

Definition:

ELSE gotolevel 0 I: |_ LN AR BT
Insert |
LEVEL 1 {
fimert: STOP fimer2: STOP Complex Event MName: ) A Level0 Delete |
IF {eventt OCCURS 2) THEN trigger
ELSE gotolevel 1 — Edit Delete All
} —I
} Timer: STOP 1| Timer2: STOP e WMore o
| it.. |
= = sventd —| OCCURS — || 1 Times  THEN goto level 1
From: I o Ta: I 15000 Curs | Hier Mame

_| One-shot I Also Capture Timer And

Ve, .. |Restore...| Close |

Search by Event Q— ELSE F

goto level O
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FI|E Explaration Signal View Waveform Analog TOD|5 Wlndow Help

@§|Q e E| 5700 b —5700 |&@l1':":'|5y_f ++>}|}}

El

o i
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nWave — Split Window

-

iy
&

C (10 9 c J 9 J 0[0
C (10 O J 0O (JO Dac
5 32
‘ el 4§qul I | ool i 1Eli.;';-:)"'-':Ir‘i:l'r L | L Eg‘ﬁi‘u1 i | 10 | 5'-':Iml:"-j'l i I. E— 2l Jj.Ftl'i:ll 1 : L1 I.- ‘I
e I #] 1 L T LIl rriT 1 i e
reset 1 : I
0 | | | S
1 | | [ 1
22 I e e
L addr[7:0] - shd 95 0 X ¢ I3 ) 3@ ) 8B | ¥y Ol 2 OL L 0T 38 | & vt
- hbus mode[2:0] * 5 5 :|: B :|: T :|: 3 :|: z :|: T :|: = :,: 3| x* .l_:
- cAarty mode 0 | | ] | | ! |
- elock 41 1 + L 4 b F 4 4 B 3 4 b 3 4 L6 3 F L
- reset 1 1 :
g Y B, i 1 T
o ALIT[T:0] 0 aby )t L@ L LF )N @20 F &l 0 A3 o &b p L& ) B | .
¥ M g g R g e g g ]
T ; A5 ! — . : ;
0 4 B g -0 '

n

N
A
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nWave — Print

® File - Print... command to print out what you see in the window with a
PostScript printer.

® Select to print to file or to printer.

Support print selected signals or displayed signals.

nwlave Print niwave Print
Basic] n'Wave Options] Signature] Elasic] n'ave Options] Signature]
—Paper — Time Range
Copies: ’1— Start Time: n.oon

End Time: 1500.000
Crientation: Landscape = |
Time Unit Per Page: | 1500.000

W Get Values From Displayed

Paper Size: A4 - 210x287 (mm)  — |

_| Colar _| Black Background

— Options
_| Print Signal Value
_| Print Signal’s Line Style

_J Print Page: S ’1—1—0: ’1— _| Increment Line Yidth by One StretCh Slg nals to

_| Stretch Signal Printing<

—Page Range
@ Print All Pages

—Destination i
_| Print Highlight Selected Signals fl | I Wh 0 I e pa‘g e "
@ To Printer; |maya ~|  Cptions |
T Fil: | - Print:  Displayed Signals  — |

| By Bamer Laod

Preview... | K | Cancel | Preview... | QK Cancel
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® Use File > Save Signals to save all waveform objects including:

® Signals
Comments
Color settings

Events

Created Buses

® Restore the signals saved
in a previous session

® In nWave, use File = Restore Signals
® On the command line, use —sswr <file>.rc

Note:

Markers and labels
Logical operations

Tio —RC Attribute Types ...
|r— Window Layout

I Hometbeckyidemosiverilogit!

8] ‘heme/becky/demos/verilog/rl

®(_] bugleg

& (] debussyl og
B (] n¥favelog
8] verdiLog

/"

7 i -

| Sevs Selested Srousis) only

R Atrributes

7 Cursar
7 Marker

7 Save Alias Table: By Alias Content —

7 User—defined Marker

7 Digital Logical Operations Signals
7 Analog Logical Operations Signals
7 Events

7 Greated buses

7 Digital to Analog Signals

7 Analog to Digital Signals

7 Renamed Signals

7 Comments

[T Get Signals Form with Scope Hierarchies
7 FSDB File Information

Select All |

7 Absolute Path

OK

Cancel

overwrite the loaded simulation results.

Verdi 5.4 Basic Training -02/22/05

If there is a file open in nWave, the Restore Signals command will not

Nows




nWave — Additional Commaﬁjs
r 4 —

® |ogical Operations
® Signal - Logical Operation...

® Logic analyzer functions (Complex Events)
® Signhal - Event

® Shift the time of selected signals.

® Waveform = Waveform Time = Shift Individual Signal
Time...

® Create independently scrollable signal frames.
® \Window -> Horizontal Split
® Aliasing
® \Waveform - Signal Value Radix = Browse Alias
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nWave — Summary

Pl

® At this time you should

Understand the nWave functionality.

Be able to open an FSDB file and add signals to the waveform display.
Know how to create buses and search for a particular value.

Be able to add markers, comments, aliases and logical operations.
Know how to compare simulation results.

Know how to view the analog waveform

Be able to access and change the preferences.

Verdi 5.4 Basic Training -02/22/05 MOVAS



nWave — Wrap-up

-~

® Questions?

® Take 20 minutes to complete
the nWave LAB

D> |
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Training Course

-~

Debugging with Verdi
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Debugging With Verdi

o

® Alternate Ways to View Simulation Data
® Active Annotation
® State Annotation
® Complex Signal Browser
® \Watch, Memory or MDA Windows
® |solate Logic Relevant to a Specific Simulation Time
® Active Trace
® Trace X
® Post Process Simulation Data
® List X
Save Debug Environment
Lab
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Active Annotation

® Display simulation results on source or schematic.

® Source = Active Annotation in nTrace B e e e e
File Edit View Schematic Trace Tools Window Help

o) L

® Schematic - Active Annotation in nSchema. | g @ @ e

D k| B -

I Selected: }v)

® Signal values / transitions are
synchronized with cursor time.

[~ iniTraceliain:l> susten,i_opu.i_f
|| File Exploration Wiew Source Trace Tools Window Help
A EODE o/ t.vE® 4 ¥ B A& B2
By; I_I ++|7150 kins
AT 4 ¥0 = PC: ;
[|=ystemniblk) a 1a
|- 7 child ifem_child1} 90 51 ‘\:JU = Iz}ij_th:
1. child2 (fam_child2) . " -
|71 childs {fsm_child3) = S e
|- FBMs_COMB 92 defaults: ‘\;0 = 8°ho:
P
| Mﬁﬁ Rals=EQ 93 endcase
g&.j _cpu [CPLY
E 94
PR 3 primitives I
] : R 5] aszign net_1 = {IR[O] == 03 ? zero_flag ! carry_flagd I 3
| b i_alu arithlogiciarithle a a 0 o i ®| Command Done
e L GOLUIGGLY 96| assian I_ = “THLOD | ¢CHLL] & CIRCL] * net_133s . -
LS PCU {peulpeu)) k3 1 o 0
|5 i_pram (pram2ipram))
o il 7|
—- Loading package body phkg. E
]
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Active Annotation — Stepping;hrough Time

=

® Select signal(s) in the source or schematic window and go to next or

previous transitions |....| »|

® The transition is selectable between: Any Change g Rising i or

Falling _"..

® In nTrace, search for the previous/next transition for all signals in the

selected statement.

® The above commands will move the cursor time in all windows.

‘+I+I| G5

Verdi 5.4 Basic Training -02/22/05 MVAS




Complex Signal Browser

® Dedicated browser for visualizing complex signals

® \What are complex signals?
® SystemVerilog struct
® MDAS
® VHDL record type signals
® [nvoke the browser from nTrace, nSchema, or nWave
® Tools - Browse Structure Signal...

® RMB - Browse Structure Signal... (nTrace only)
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Complex Signal Browser

Hierarchy Signal Tree Window
A

Value Annotation

topd mypipe. =
=5z = — Fy typedef struct { ::
fn) Eroot L .8k logic
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typeder struct {

. 0-31 logic :
H |e rarC h‘/ Scope Tree B ops[7:0] {one_op) 0, Bzz, 0,0, {0, 0}, ff=, 11 {30, 0 ;jf?ﬁ? e
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N rpdst (0] LEERCH
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W Show Source Definition and Declaration
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Complex Signal Browser

® General
® Multiple Complex Signal Browser windows can be invoked.

® D&D is supported between Complex Signal Browser and other
windows.

® Hierarchical Scope Window

® Same as nTrace but without package nodes

® Signal List Window
® Supports regular expression in search window
® Complex signals will be shown with Red color
® Signals are sorted alphabetically

® Two options Match Case and Show Structure Signal Only in Option
form will be applied to this window.
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Complex Signal Browser

® Hierarchical Signal Tree Window

® The signal tree will be built when selecting a signal in Signal List
Window

® Settings for Source = Signal Value Radix and Source - Signal
Value Notation in nTrace will be applied to this window.

® |[f an FSDB is loaded, the annotation value will be shown for all leaf
nodes.

® The Value Annotation Window will be closed if Show Annotation Value
option is turned off in the Option form.

® The annotated value will change according to current time point.

® Source Code Window

® Enabled/disabled with the Show Source Definition and Declaration
option in the Option form.
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Watch Signal

® From nTrace, use Tools - Watch Signal to view the value of selected
signals in a table.

Watch

crul aLu] ccul
Marne | Walug

L]

Delete

systemn._cpu.clock|0-:1

system._cpureset[l | Delete Al

systen.i_cpuvMAN
system.i_cpu R_W(1 Move Up
system.i_cpu.data[7:0]| 22 -:28
system._cpu.addr[7:0]|3 MMove Down
system._cpu.i_ALUE IR :0](0
— : Load ..
systemi_cpui_ALUE IDE[F:0](3
system.i_cpu.i_ALUEB FC[F:0](3
mrsmd -} -rmaa n AL LIF S1LIFA.MT S E SaIIlIIE LR}

Fl ]

' Show Hierarchy Mame By: §f — | 1200
| Option.., I Close |
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Active Trace from Wavefor

- —
--'5- - =

® Double clicking on a signal transition in the waveform window will identify
ONLY the active driving statements(s) in nTrace causing that transition.

File Exploration

racetainils s

{ 5 cpu,i_ALUB ALUB {uwerilog/ALUB,
iew Source Trace

ools Window Help

=*‘he active driving statemen

~F

= Bt 3@® oyt v 3 BL & R sk oo
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¥Total
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1 driveris?
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Active Trace in Source

® Used to identify the active driver for the selected signal.
® Requires design and simulation results.
® Select signal in nTrace.
® Invoke RMB menu and select Active Trace.

® Ctrl-t also performs an Active Trace.

® Use Tools = Preferences, Source Code tab, Miscellaneous tab, to enable Double
Click do Active Trace.

ref | File Exploration View Source Trace Tools
Source Code | Waveform| Schematics | FSM | Memany = = = .
Vrorn] sl el o] | T S [ 8 A @ B 2 L A ¥
Co\or] Design Tres] Imparting Des\gn] View Options
Hey £ +»[= 5 1
[T Search Match Case
||_ R T Trace| ch?|d1 tfsrn_ch!ldﬂ 74| always @(I??us_mode ar IOHR_tmp ar %CC_tmp ar F_'It_}cér* I‘ID—B=2)
child (fem_childa) 75| caze (hus_moded
child3 {fam_child3} Frfue
- =4 FBM3_COMB 76 01 AU = THR_tmps
L FaM3_SEQ PRI
r o i 1: A= ACC_tmp:
; i_cpu IGPL o Th . d o o
B0 _ALUE (ALUE] q 78 % e 44— e active rrving statement
1-=2
rtfle i S
i i_CCU {CCL 80 defaults %0 = IDB:
L% PCU {peulpeul) F2l 12
T (TT : e |
E B> system.i_cpu.i ALUB,i_alu,al7:0] /4 results of trace driver #/
#<I> werilog/ALUB, wi783: 2 Ho = PC:
#zystem, i_cpu,i_ALUB ¢ 1 driveriz:
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Trace X

® Display logic cone relevant to the unknown.
® In nWave, select a signal.

® Place a cursor at the transition to X.

File Edit Wiew Schematic Trace Tools Window Help

Q&P i B e ol o]ee Foe [ xine

Selected: (0)

® Invoke Tools = Trace X.

® Generates a flattened
schematic that shows
the X propagation path
back to first storage
element or primary
input.

® |n resulting nSchema,
Trace = Trace X.

® Repeat as needed.

| Command Done
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® Two common causes of X's:

® Timing violations
® Un-initialized storage elements
verdi can help to isolate storage elements and tri-state devices with unknowns.

® In nWave or nTrace, use Tools = List X.

® Build: parses fsdb file to find storage elements and tri-state devices which have
value X.

® A batch build executable called xloc is supported.

® Play: to list storage elements and tri-state devices which have value X at selected
time.

® Double click on a signal in the list or press Trace X icon to generate a
flattened schematic (Trace X functionality).
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List X/ Trace X Example

Specify time range
to locate X’s L

FSDE File: pma’ |

GHh - — S
File Edit View Schematic Trace Tools Window Help
Xloc File: fhomk/. . fverilog/ge/gate fsdb xloc e = — -
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]

to invoke Trace X
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Start Interactive Mode

® Confirm the PLI/FLI shared object files provided by verdi are linked with your

simulator.
® Choose the simulator under Tools = Preferences = Simulation tab.

® Be sure to select stop at time 0.

Source Code] Waveform] Schamatlcs] FSM] Mamory] S\mulatlon] Ed\tor] General] Auto Source]

® To enable interactive mode select
. Simulator MNC-Verilog (Verilog) ﬂ
Tools - Interactive Mode. NEHOL (VHDL) =
Executable MNC-SIM {WYHDL or mixed-HDL) _I
. Verilog—XL {Yerileg)
. ThIS adds a neW tOOIbar and Options : YCS (Werilog) B 1 Ne Append Option
. . YCS M)USCI.I’OCCO MK {WHDL) .
Simulation and Debug menu 2 X (minaaHDL e o s st
. o Frem LIOFAR pade|Sim (Verilog)
Opt|0ns to nTrace o Usergmzd;s:; (vzr[';ﬁgor mixed—HDL) — _l
' SPEEDSIM (Yerilog)
- Aus
_| Stop At Tir SureFire
Yoyager
I Remember B:reagkpomts For Mext Simulatior
Interactive

TOOIbar OK | Cancell

yd
ﬂ‘%* \EJE}++£_|_13||EI jﬁ'ﬂ|5&lected:

Simulator: Stopped LIy 3 Time: I 26 = 1ns | By § - IEE % 1ns
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Interactive Simulator Control..

2

—

Pl

® Click the Run/Continue icon I to start simulator.
® Click the Stop icon to stop simulator.

® Run the simulator to specified time by entering a value in the
Time text field.

® Use Simulation = Reset to reset simulator.
® Use Simulation = Finish to finish simulation.

® Use Simulation = Kill Simulator Process to kill the simulator
process.
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® Execute Verilog or VHDL step by step. ¥ o

® Enable Active Annotation for real time updates.

® Use Debug - Breakpoints to set and control breakpoints.

® Double click on the line number in source window to set/clear a breakpoint.

® Use Debug > Set Focus to focus on a scope(s).

® |f a focus is set, the source window will only step through the source code that is
in the focus modules.

Command Buttons:

® Use Debug > User-Defined Commands Dump Al Signa'lsl |
. . Mext 1000 Time| Mext ? Time
to bring up the user-defined commands et Evortl Noxt 2 v
WindOW for frequently used Commands- Showe "\.-"ariahlesl Force ‘-.-"ariahlel

Felease Variahlel

Deposit Variahlel Set FDE:LISI

Delete Focusl Dump OnI

Durmp OEI

Edit...I Clnsel
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Save/Restore Debug Enviro&ment

-~

—

® Save the debugging status to a session file
® In nTrace, File > Save Session...

® [nformation saved:
® Displayed waveforms and settings.

® All the windows, locations and content.

® Recover the previous debugging status from a session file.
® |nh nTrace, File > Restore Session...

® On the command line, use —ssr <file>.ses
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Summary

-~

® At this time you should

® Be able to enable active annotation and debug a simulation
problem with active trace.

® Apply the simulation result to nState

® Know how to load an SDF file, annotate values and calculate
longest/shortest paths.

® Be able to use different techniques to isolate logic for active fan-
Ins, bus contention and X detection.

® Know how to save a debug session for future use.
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® Questions?

® Take 20 minutes to complete the Debug with
Verdi LAB

D> |
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If you have problems...

-~

® Contact support with the following information

® Complete description of the problem and what you were doing
verdi or nLint version

Platform and OS version

Simulator and version (if simulation problem)

Core stack (if applicable)

verdiLog directory (at a minimum the verdi.cmd)

Support contact:
® <name>
® <email>

® <phone>
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