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第一章 User Interface 
 

本章的主要內容介紹 allegro 操作介面，透過本章學習可以對 Allegro 的工作介面有了大致的瞭解，同時也能體

驗出 Allegro PCB Layout 時的強大功能。 

 

A. 程式的啟動 

 
 
點選                   

  

 

 

 

除了以上 Allegro 主程式，我們還會常用到以下幾個常用工具： 

 

 

 

 

 

• Padstack Designer  

(Padstack Editor)  

 

• DB doctor  
Padstack Designer 的作用是建立和修改 Pad，具體會在下面章節中講到。 

 

DB doctor 的作用有三個：1.板子 Data-base 的檢查 

                        2.板子 Data-base 的修復 

                        3.更新板子上的 DRC 

 

支援的檔案種類為： .brd  .mcm  .mdd  .psm   .dra  .pad  and . sav databases. 
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B. Cadence SPB Tools 
      

PCB Designer 在 V16.5分成2個基本等級，用戶可以根據自己的需求購買不同等級的Tool及搭配的option (Only 

for Allegro)，主要功能差別見下表： 

 

•Allegro PCB Designer 進階的版本，可以搭配高速信號或是 HDI 設計…等 Options 使用 

•OrCAD PCB Designer 最基本等級的產品，擁有基本的高速信號線特性設定 

 

在開啟 Allegro 時，系統會先跳出如下圖的對話框，讓您選取要使用的軟體等級 

視窗中所列出的軟體項目是依據系統所能選取的 License 功能來決定 

 

 
 

以下也列出幾個常用的 Option 來介紹： 

 PCB High-Speed option：針對高速設計能提供更多的功能 

 Miniaturization option：針對 HDI 設計能提供更多的功能 

 

如果在使用過程中想更改產品，可以在點選下拉式功能表 File 項目下面的 Change Edit，就會出現如上圖所示的

對話框時，選擇所需產品。 
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C. Allegro 常用檔類型的介紹 

 
Allegro 根據不同性質功能的檔類型儲存不同的副檔名，主要的類型可以參照下表： 

 

Extension File Type 

.brd  Board/Substrate file that represents the drawing database  

.dra  Drawing file. You must create one of these before you create a symbol file. Later,

this file is compiled into a binary symbol file.  

.pad  Padstack file  

.osm  Library file that stores format symbols  

.psm   Library file that stores package/part symbols  

.bsm  Library file that stores drawing or board/substrate symbols  

.fsm  Library file that stores flash symbols  

.ssm   Library file that stores shape symbols  

.mdd  Library file that stores module definitions  

.drl  Output text files that contain NC drill data  

.txt  Text file, such as that used for parameters  

.scr  Script and macro files  

.log  Log file that contains data on processes  

.art  Artwork files  

.dat  Data files  

.jrl  A journal file which contains a record of events -- menu picks, keyboard activity, and 

so on -- which are recorded for each session in Allegro/APD. You can share this 

data with Cadence Usability staff to help us learn how you use the product, which

will assist us in our efforts to improve the user interface.  
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D. Allegro 的目錄結構 

 

Allegro 的檔案目錄可以分為三部分：安裝路徑、工作路徑和使用者環境路徑 

 

安裝路徑：系統預設的安裝路徑為：C:\Cadence\SPB_16.6，在安裝時使用者可以根據自己隨意更改安裝路徑 

工作路徑：系統預設的工作路徑為：C:\SPB_DATA，在安裝時建議用戶把工作路徑設在非系統碟上， 

如：D:\WORK 之類的 

環境路徑：儲存著使用者個人設定、記憶工作更改的工作介面環境 

* Win XP 用戶會在系統碟的\Documents and Settings 下產生資料夾。 

 

 

E. 設定與更改工作路徑 

 
因為 Allegro 在開啟檔案時有一個“工作目錄”，它做的所有動作都會以當前工作目錄為基準，如儲存當前檔案、

輸出產生的各類檔案…，所以我們在新建檔案或者打開檔案時就要將 Change Directory 勾選，這樣在存檔或輸

出時才會存在正確的路徑上，而且能夠在下次開啟程式時就能直接開啟最後編輯的檔案。 
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F. 開檔的預覽功能 

 
Allegro 有工作檔預覽功能，在打開對話方塊的右下角有兩個按鈕 

   

 

預覽工作檔的大概架構 預覽工作檔的一些參數 
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G. Allegro 的工作介面 

 
下圖描述的 Allegro 的工作介面，從圖中就可以瞭解 Allegro 的整個工作介面和環境。 

 

                         標題列 

      

                                               

 

                                                                      

                           

 

 

 

 

 

 

 

 

 

 

 

 

 

標題列：顯示當前 Allegro 版本和工作路徑 

工作選單：Allegro 的功能命令都可以在功能表裏找到 

工具列：如下圖所示，可以分為圖中的幾個區塊 

  

 

 

 

 

 

 

#使用者可以根據自己需要自行定義工具功能表，可在功能表執行 View > Customazation > Toolbar  

工作區 

控制列 

狀態區 

工具列 

工作選單 

命令列 
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使用者可以選擇需要的工具區塊， 

如：勾選 File 左邊的方框就能在 

工具列出現 File 工具按鈕，如下圖： 

 

 

取消勾選 File，工具列就在工具欄消失。 

其他的設置方式也是相同的 

 

 

 

 

 

如果使用者還需要定義工具按鈕，可以直接從工作介面的工具欄中把不需要的工具圖案拉出工具欄就可以了； 

 

 

 

 

 

  

   

如果需要增加的話，只要在右邊 

表單的 Commands 下面的 Buttons 

的工具圖示往工具欄上拉就可以。 

 

 

 

#使用者也可以透過  新建自己的工具列，然後透過上面的拖拉方式把自己想要的拉到工具列當中就

可以了。                                 
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H. 控制欄和狀態欄 

 
• Options Folder Tab 

根據 command 不同而顯示不同細節設定 

 

• Find Folder Tab (Find Filter) 

尋找或者選擇的物件 

 

• Visibility Folder Tab 

層面開關控制  

 

• World View Window 

做圖畫面的範圍將滑鼠置於 #World View Window 按滑鼠右鍵才

可以彈出下面功能表 

 

• Move Display  

的功能就是移動當左圖中前顯示視窗在整個工作區域的位子 

                        

• Resize Display 是修改當左圖中前顯示視的大小 

 

• Find Next 下個畫面 

 

• Find Previous 前一個畫面 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

XY：指定需要選取的座標 

Snap to current grid：是否捕捉格點 

Relative (from last pick):是否參考最後一點的座標 

A：是指絕對座標 

R：是指相對座標 

板子外框 

工作區顯示大小 
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CMD 有三種狀態: 

 

1. 綠色：動作正常狀態                       

2. 紅色：命令執行狀態，不可中斷 

3. 黃色：命令執行狀態，但可以透過點選下面的 Stop 或 Esc 退出 

  

 

控制台可以透過功能表命令: 

 

View > Windows 

設定 Control Panel 的狀態 
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I. Options Window 
 
Options window 會根據當前執行的是什麼命令，表單內就顯示當前命令的一些細節設定，下面圖標示了幾個常

用功能的 Options 表單，具體每個功能的使用可以參考目錄。 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Copy Add Connect 

Z-Copy Add Text 
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J. Find   

 

Find 也是 Allegro 功能強大的地方，透過 Find 可以更容易選中你想要選擇的東西，整個 Find 表單可以分為上下

兩部分，上面是一個 Filter（濾鏡），作用是在點選板子上的 Element（板子上的所有成份物件）時，可以過濾你

不想要的類型使更容易選中想要的 Element；下面可按照 Element 名稱搜尋，如下為詳細介紹。 

 

 Design Object Find Filter  

     上面的 All On  是選中所有選取方塊 

All Off  是取消所有選擇 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

搜尋類型 

依 Name 搜尋或是以列表檔案方式搜尋 

新增可支援物件類型 
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K. Visibility 
 
                                 

 

 

 

 

 

 

 

 

 

 

 

 Views：快速切換層面，透過下拉功能表可以快速切換想要打開或關閉的層面，下拉功能表可分為三部分 

1. Last View – Show 最後一次執行的層面 

2. Film：... – Show Artwork 

3. File：… – Show 自己儲存的 color 檔 

操作步驟：首先透過點選 自己選擇要打開的層面，然後執行功能表 View > Color View Save 

出現左邊的表單在 Save view 右邊對話框中輸入儲存的檔案名， 

在下面選擇 Complete 點選 save 就可以了 

（所存檔案為*.color，目錄為當前工作目錄） 

 

在 Views 的下拉選單裏就多了個「route」以後就可以直接點選 route 快速切換了 
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L. 滑鼠按鈕 

 
滑鼠按鍵的主要功能可以見下表： 

兩鍵滑鼠 三鍵滑鼠 按鍵功能 

左鍵（LMB） 左鍵（LMB） 選取命令或區域 

右鍵（RMB） 右鍵（RMB） 下拉目前命令的 Pop-Up Menu 或者執行 stork 動作 

Shift＋右鍵（Shift+RMB） 中鍵（CMB） 移動和縮放畫面 

 滾輪鍵(middle mouse wheel) 縮放畫面 

#建議大家使用三鍵的滑鼠。 

 

M. 控制畫面的縮放 

 
# 功能表 View>Zoom   … 也可以直接點選上面的工具欄 

 Zoom In—放大 

 Zoom Out—縮小 

 Zoom by Points—放大兩點之間的工作區 

 Zoom Fit—以 board outline 為主，放大於整個工作區但不大於工作區 

 Zoom World—以 Drawing Extents 的 size 置於工作區內 

 Zoom Center—螢幕依一個 x,y 值置於中央 

 Zoom Previous—跳回螢幕之前的大小 

 Refresh—螢幕畫面從新整理 
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  按住中鍵不放然後移動滑鼠可以移動畫面 

 

點選中鍵有兩類功能： 

第一種：是預設狀態的中鍵功能，先點選中鍵然後再按下圖的方向移動滑鼠可以產生圖中例舉的功能。 

 

 

 

 

  

    

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

縮小比例大 縮小比例小 

Zoom Prev
Zoom by Points 

Zoom Cancel 

Zoom Out 

Zoom Out

Zoom Out

Zoom Fit

Zoom by Points
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第二種：執行功能表 Setup > User Preferences 出現下面表單，點選左邊 Categories 下面的 Input，在右邊最下

面的 no_dynamic_zoom 的選取方塊勾選，點選 OK，返回主表單點選中鍵就有新的功能了，點選中鍵的功能是

Zoom In 或 Zoom Out，具體 Zoom In 還是 Zoom Out 是依據最近執行的是哪個就執行那個。 
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N. 定義快捷鍵 

 
為了使用軟體更為方便快捷，可以自行設定快捷鍵，下面將介紹怎麼去設定快捷鍵以及列出預設的快捷方式。 

 

系統預設的快捷方式見下表： 

 

Key Command Key Command 

F1 Help   

F2 Zoom Fit SF2 Property Edit (available) 

F3 Add Connect SF3 Slide 

F4 Show Element SF4 Show Measure (available) 

F5 Redisplay SF5 Copy 

F6 Done SF6 Move 

F7 Next SF7 Dehilight All 

F8 Oop SF8 Hilight Pick 

F9 Cancel SF9 Edit Vertex 

F10 Grid SF10 Save_as temp (available) 

F11  Zoom In SF11  Zoom Previous (available) 

F12 Zoom Out SF12 Zoom World (available) 

注：SF2 為 Shift＋F2，其他類推 

 

 

如何定義： 

 

在命令欄裡鍵入：“alias”然後空格，然後按你想定義的快捷鍵或 直接輸入，

然後輸入你定義的功能的，如右圖定義 F2 為 Add connect 命令的快捷鍵。 

 

快捷鍵定義可以分為右圖 a、b、c 三部分 

 

a. 為命令 alias  

b. 為系統預設的快捷鍵（建議大家直接使用） 

c. 為功能定義 
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能定義快捷鍵的功能鍵為： 

 

F2～F12、鍵盤右邊的上、下、左、右、Insert、Home、Page Up、Delete、End、Page Down 

 

 

還有這些功能加上 Ctrl、Alt、Shift、Ctrl＋Alt、Ctrl＋Shift、Shift＋Alt、Ctrl＋Alt＋Shift 切換鍵的單獨和共同的

七種組合；還有 Ctrl＋鍵盤上的任何鍵，除功能鍵外，其他按鍵都能設定快捷鍵。 

   

定義快捷鍵 b 部分的具體寫法見下表： 

 F2～F12 Insert Delete Home End Page up Page Down 
    

 F* Insert Delete Home End Pgup Pgdown Up Down Left Right 

Ctrl CF* CInsert CDelete CHome CEnd CPgup CPgdown CUp CDown CLeft CRight 

Alt AF* AInsert ADelete AHome AEnd APgup APgdown AUp ADown ALeft ARight 

Shift SF* SInsert SDelete SHome SEnd SPgup SPgdown SUp SDown SLeft SRight 

Ctrl+ Alt CAF* CAInsert CADelete CAHome CAEnd CAPgup CAPgdown CAUp CADown CALeft CARight

Ctrl+ Shift  CSF* CSInsert CSDelete CSHome CSEnd CSPgup CSPgdown CSUp CSDown CSLeft CSRight

Shift+ Alt ASF* ASInsert ASDelete ASHome ASEnd ASPgup ASPgdown ASUp ASDown ASLeft ASRight 

Ctrl+ 

Alt+Shift 
CASF* CASInsert CASDelete CASHome CASEnd CASPgup CASPgdown CASUp CASDown CASLeft CASRight

注意：F1 為系統預設 Help 功能，不能定義其他功能字母大小寫  
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O. 使用 Strokes 

 
Strokes 功能是透過滑動滑鼠來產生功能，省去了選取功能表或點選工具欄命令的時間，使 Layout 更快捷。 

 

使用方法： 

按住 Ctrl 鍵然後按住滑鼠右鍵在工作區域內滑動，透過劃不

同軌跡就可以產生右邊表格中的幾個不同功能。 

 

技巧： 

按住 Ctrl 再去按右鍵滑動滑鼠會顯得很麻煩，可以在 User 

Preferences 下設定後直接按右鍵劃滑鼠就可以，具體操作

如下： 

 

執行功能表 Setup > User Preferences 出現選單，在左邊的 Categories 中選擇 Input，然後勾選 no_dragpopup

右邊的方框，點選 OK 完成。 

 

Stroke 功能 快捷鍵 

Copy Ctrl+C 

Move Shift+F6 

 Zoom In F11 

Opps (Undo) F8 

Zoom World Shift+F12 

Delete － 
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P. Application Mode 
 
執行 Setup/Application Mode,可分為 General,Placement,   

Etch,Flow Planning,Siginal Interity,None 六個模式 

 

 

 

# General Edit Mode 點選物件後對應之快速鍵及其功能 

 

                                            

 

 
General Edit Application Mode 

Element Type DRAG Shift Drag Ctrl Drag 

    

Group Move Move Copy 

Symbol Move Spin Copy 

Via Slide Move Copy 

Cline Move Move Copy 

Line Move Move Copy 

Shape Move Move Copy 

Cline Segment Slide   

Figure Move Move Copy 

Text Move Move Copy 

Rat Tee Slide Move  

Pin In discussion    
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# Etch Edit Mode 點選物件後對應之快速鍵及其功能 

 

                                          

 

 
 
Etch Edit Application Mode 

Element Type Drag Shift Drag Ctrl Drag Single Click 

     

Group Move Move Copy  

Symbol Move Spin Copy  

Pin Move   Add connect 

Via Slide Move Copy Add connect 

Cline     

Shape Move Move Copy  

Cline Seg Slide  Delay tune Add connect 

Rat    Add connect 

Rat Tee Slide Move    

 
 
 
# Placement Edit Mode 點選物件後對應之快速鍵及其功能 

                                   

PLC          
 
 
(1) Automatic Execution of Commands 

Placement Edit Application Mode 

Element Type Drag Shift Drag Ctrl Drag Single Click 

     

Group Move Spin Copy Move 

Symbol Move Spin Copy Move 

Text  Move Spin Copy Move 

RatT Slide    
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(2) Graphical User Interface 

在Placement Edit 的模式下，系統會自動將未擺放的元件列在右方的Options 欄位下： 

可以透過 Place By refdes:可輸入 U*或 R*來快速篩選。 

 
(3) Context-Sensitive Editing 

在 Placement Edit MODE 下對元件點選滑鼠右鍵，就會出現與之相關的命令。 
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Q. Color 
 
Color 對話框包含 Layers 和 Nets 兩大部分，分別支援以 Layer 和以 Net 單位的顏色管理視窗。 
 

1. 以 Layer 單位的顏色管理視窗，將我們的 class 和 subclass 分屬不同的 folder，透過樹狀圖來一級一級管理

我們的 Color 與 Stipple patterns。 
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2. 以 Net 單位的顏色管理視窗 

全新的”表單式”的色彩設定，可以提供對NET 上的“pins, vias, clines, shapes, and ratsnests”等等的顏色顯

示設定，並支援分類過濾”bus, diff pair, Xnet and net objects”,執行Display/Color/Vibilitily 即可出現控制視窗 

 
(1) 我們可以分別給與 net 相關的物件指定不同的 color，比如給 Addr_bus 的 Rats 著淺藍色 ,給 Clk_Out

著深藍色,給 A1~A7 的 Rats 著綠色等,如上圖: 

 

(2) 如果我們要將 Clk_Out 做 highlight 或是 Dehighlight，只要做如下處理: 

 
 
 
 

 Dehighlight Highlight 
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(3) 可以透過 Type 與 Filter 來控制讓哪種類型的 net 顯示在 net color 視窗中 

                       All:所有的 net 都會顯示在 net color 視窗中 

                       Net:只有 net 會顯示在 net color 視窗中 

                       Bus:只有 Bus 會顯示在 net color 視窗中 

                       Xnet:只有 Xnet 會顯示在 net color 視窗中 

                       Diffpair:只有 Diffpair 會顯示在 net color 視窗中 

 

(4) 可以透過 Show only nets with color override 來控制只讓指定 color 的 net 顯示還是讓所有的 net 都顯示: 

   勾選此項 - 只會將指定 color 的 net 顯示在 net color 視窗中。 

   不勾選此項 - 所有的 net 不管有沒有指定 color 都會顯示在 net color 視窗中。 

 

(5) 可以透過 sort 來控制 net 在 net color 視窗中的 list 順序: 

                         Ascending:以字母的順序按昇冪來排列 

                         Descending: 以字母的順序按降冪來排列 

                         Overrides on top:將指定 color 的 net 排在前面 

                         Overrides on bottom:將指定 color 的 net 排在後面 

 

(6) 可以透過 Disable custom colors 來控制我們在 net color 視窗中指定的 color 是否能運用到檔案中去: 

● 勾選此項，則我們在 net color 中對 net 的相關物件指定的 color 不會運用到我們的檔案中去.我們的 color

以 layer 中的設定來顯示。 

● 不勾選此項，則我們在 net color 中對 net 的相關物件指定的 color 就會運用到我們的檔案中去。 

 

(7) 可以透過 clear all nets 來清除我們對 net 的相關物件指定的 color 
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3. 可控制 color palette 的顯示與否 

color palette 的顯示與否變成可控制的 

(1) 只要點一下 Color Dialog box 中的 hide palette 按鈕就可以關掉 color palette。 

 
 

(2) 如果希望將 color palette 顯示出來，我們只要點一下 show palette 就可以了。 
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4. Color Dialog 中可以為某個層面增加 stipple pattern 資訊，可以與 color 顯示互相搭配。 

 

(1) 在 color Dialog 中的 layer 管理視窗裡設定好 stack-up 層中 top 的 stipple pattern。 

 
 

(2) 在 allegro 中 Etch 層的 top 內所有的物件都顯示為設定好的 stipple pattern 
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R. 3-D Viewer 
   
3-D Viewer，可以直接在 allegro 中看到 board file 的 3-D 顯示效果。3-D Viewer 對於 PCB Editor Products，只

有環境變數中的 OpenGL 顯示功能開啟後才有效，而對於 APD/SiP 是無效的。 

 
1. 打開 3-D viewer 功能，只要在 menu 中執行 View—3D view 或是 Icon 中選擇  

 
 

2. 3-D viewer 是在一個獨立的視窗中打開的。3-D environment 環境支援多種顯示內容的過濾，取景視角和顯示

效果的選項，透過遊標可以直接控制放大，移動，翻轉等操作。 
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3. 在 pre-selection 模式下也可以支援 3-D 顯示，這樣就可以直接顯示 HDI via 的結構和電路板的隔離域

（ isolated sections ）。使用上下文相關的命令選項可以打開多個 3D 顯示視窗。 

 
 

4. 新的 3D 顯示中支援層面資料動態變更，可以即時的透過 3D 顯示立即的變化，預設此選項是開啟的。 
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S. Flip Design 
 
Flip design 可以將設計沿 Y 軸進行翻轉，站在底部的角度顯示設計，方便 PCB 的測試。 

 

1. Flip design 只有環境變數中的 OpenGL 顯示功能開啟後才有效，並且此功能對於 Viewer 也是有效的。 

 

 

2. 打開 Flip Design 功能，只要在 menu 中執行 View—Flip Design 或是在 Icon 中選擇 
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T. Script 
 

Script 只紀錄當時的狀況，它是一個文字檔可以用一般的文字編輯加以編輯，可利用於一些重覆性的工作，可節

省重覆操作相同指令的時間，執行步驟為: 

1. 選擇 File—Script 

2. 給正確的路徑和 File Name 

3. Record 

4. 做你想要的動作 

5. Stop 

 

最後會存成的副檔名為 *.scr,若要驗證動作可於 command 執行 Replay 如:Replay top.scr 
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U. Embedded Net name 
 
在電氣物件Cline, Pins, Shapes 上會顯示出此物件的網路名稱，方便佈線工作進行。 

要確保此功能可用，首先Open GL必須開啟，另外Setup – Design Parameters –Display form.中相關參數必

須勾上。 

 
 

 

 

  

可以根據需要設定哪些

物件上顯示 net name 

在 shape 和 Cline 上顯示 net name 在 pad 上顯示 net name 
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V. Env 
 
ENV 為 Allegro 的環境設定檔，當 Allegro 開啟時會載入一些設定檔 Env 主要功能為 Set Command ，記錄 User 

Preference 的設定。 

 

在 allegro 中 env file 分兩個地方儲存 

1. <home>:\pcbenv\env file 

2. Cadence\spb_16.6\share\pcb\text\env file (env_local.txt) 

而一般所更動的環境設定則屬於第一項。 

   
 
 
 
 
 
 
 
 
 
 
 

 

# Home 之路徑可從我的電腦進行設定 
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W. Skill File 
 
#載入 Skill File 

Skill file 為 Cadence 或 Cadence 客戶將所發展的 Skill files 放在 http://sourcelink.cadence.com/ ，提供給有 

maintenance 客戶的程式，但是 Cadence 不保證服務，Skill 的副檔名為 .il (xxx.il) ，大部份是文字檔，可用文

字編輯器打開來看其內容，載入 Skill file 的方式為在 <home-dir>\pcbenv\ 置入 allegro.ilinit ，其作用為設定 skill 

file 的路徑及自動載入 skill file 的程式，其內容及語法如下 ; 

 

setSkillPath(buildString(append1(getSkillPath() "D:/skill"))) 

; 

load("xxx.il") 

; 

D:/skill : 是放置 skill file 的路徑，可在 D 碟下開一目錄名為 skill ，所有的 skill files 都可放在此目錄下 

load :  宣告 Allegro 載入的 skill file . 

 

#執行 skill command : 

多數的 skill file 內都有說明如何在 Allegro 執行 command .或檢查 skill file 裡的 axlCMDRegister(“XXX” 

‘…) ，其中 XXX 是可以在 Allegro 執行的 command . 

 

 

X. Getting Help 
 
在使用 Allegro 如果遇到問題可以有以下幾個方式得到幫助： 

 

# WinHelp—使用過程中按 F1 or  

 

# 訪問我們的網頁  http://www.graser.com.tw 

                  http://www.graser.com.cn 

  

# 電話諮詢    (CRC):0800-241-256 

 

# Online service   http://support.cadence.com 

                    http://www.cadence.com 
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第二章 Padstacks 
 

在這章內容裏將會介紹如何利用 Allegro 的 Padstack Designer（Padstack Editor）進行建 Pad，介紹 Pad 相關

內容及層面。 

 

A. Anatomy of a Padstack 
 

 

整個 Pad 層面可分為 Mask Layer, Signal Layer, Plane Layer。 

 

Mask Layer：包括了 Soldermask(防焊層) ,Pastemask，(鋼板層)，Filmmask(輔助層面,一般用於標注測點的安

全範圍)。這些層面統稱為 Non-etch 層。 

Signal Layers：就是 ETCH 層即走線層。 

Plane Layers：就是內層的電源 VCC 層和 Gnd 層。（一般建議使用負片，因為在 Allegro 中 shape 的資料量很

大，而電源層肯定是 shape，所以如果使用正片，那整個系統的計算速度就會變慢。 

 

Signal Layers 和 Plane Layers 兩層統稱為 Etch 層，即有電氣特性的層面。 

Signal Layers 在 padstack 是用於 Regular pad，正片處理；Plane Layers 用 Thermal Relief pad（flash symbol）

進行連接，用 Anti-pad 作隔離處理。 
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B. Pad 的種類 

 
Pad 種類 用途 在底片中的表示圖形 

Regular pad 

用於正片 

用於一般的走線層  

 

 

 

 

Thermal Relief pad 

用到 flash symbol 

 

用於和 plane 的導通。 

Thermal Relief pad 和 plane 的導通又有兩種方

法。 

 

一種是屬於負片的底片形式，其中黑色的部分

是和 plane 的連接處，白色則是隔離的部分。 

 
 

另一種是屬於正片的底片形式，其中白色的部

分是和 plane 的連接處，黑色則是隔離的部分。

 

 

 

Anti-pad 

 

用於和 plane 的隔離。 

當一個 pad 的屬性不同於 plane 時就會這種類

型的 pad 進行和 plane 的隔離。 

 

 

Shape-pad 

 

 

用於一些特殊零件的建立，需要用到一些特殊

的零件外形，如金手指等 
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C. Pad 的建立 

 
當大家瞭解了 Pad 的一些相關內容後，開始進入建立 Pad 的部分。 

在建 Pad 以前需要先介紹兩個與建 Pad 相關的零件 shape symbol 及 flash symbol 的概念及建立。 

 

 

D. Shape Symbol 
 
為什麼要使用 shape symbol 呢？ 

原因是在於建 pad 時有可能要建一些形狀比較特殊的 Pad(例如一些金手指 pad 的外形)，它又不能用單純的方

形，圓形，橢圓等標示，那沒有其他辦法的時候，就可以利用建一個特殊形狀的 shape symbol 來描繪它的外形。 

 

如何建立一個 shape symbol？ 

 

步驟： 

a. 設定作圖的參數，這是一個在新建一個物件時都需要進行設定的一個步驟。 

點選 Setup>Drawing Size 就會出現下列對話方塊進行參數設定 

 

 

單位的確定，一般在 PCB 板上所用到的單

位是 mil 精確度的選擇，單位如果選擇 mil，

那精確度會選擇 2 即小數點後兩位。 

  

工作區的原點參考座標 

 

工作區的範圍大小 

 

Move Origin：如果我們要移動工作區原點

時，可以在這裡輸入要移動的 X 軸的範圍和

Y 軸的範圍來改變原點的現有座標，它是一

個相對原點的座標。 

 

                                                

新建物件類型的選擇，建立 shape symbol 

則 type 欄需要選擇 shape                           
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Size 一欄是指工作區大小的選擇。在裏面有四個固定的範圍的選擇，還有 Other 這一項是用戶自行定義的，

可以在 Width 和 Height 中直接鍵入需求的大小。（其中英制的四個固定範圍的序號是 A，B，C，D；範圍大

小是逐步增加的。其中公制的四個固定範圍的序號是 A1，A2，A3，A4；範圍大小是逐步增加的。）一般情

況是跟據客戶自行定義的。 

 

設定完成後，點選 OK 鍵，關閉對話方塊。 

 
b.  點選 File>New 後就會彈出下面的對話方塊，進行建立零件類型的選擇。 

 

 

 

 

 

 

 

 

 

 

在 Drawing Type 下面選擇 Shape symbol 

 

c. 在 Drawing Name 中寫入新建 shape symbol 的名稱 

 

d. 按 OK 就進入新建 Shape symbol 的模式 

e. 點選圖示  , 在右邊的 control panel 中 Option 欄進行層面的設定,  

並編輯一個特殊 Shape Symbol 的外形 

 

f. 使用 move 指令抓取外形的 Body Center,將其指定在 0,0 的原點. 

 

g. 點選 File>save 存檔成*.dra 檔 ，僅供對零件的編輯的圖形檔，不能直接使用 
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h. 點選 File>Create symbol 存檔成 *.ssm 檔，是一個實際的零件實體，用於 PCB 板上，這裡要注意這個動作

可以省略，但我們要對系統的變數做設定，在 Allegro 的功能表中選擇 Setup/User Preference 然後在彈出的

對話方塊中做如下設定 

 

 

 

Note:建完零件必須存成兩個檔案，一個為*.dra 檔,一個為*.ssm 檔 

 

透過以上步驟一個特殊形狀的 Shape Symbol 的零件就完成了，就可以用於建立 Pad 中。其中產生*.*SM 的方法

同樣適用在創建其他的 Symbol 中。 

 
 

此參數主要控制在保存 dra 檔的時候是否

一同產生元件的二進制檔，不勾選表示一

同 產 生 ， 勾 選 表 示 不 產 生 ， 需 要 使 用

File/Create Symbol 產生 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 2  -  6

 
E. Parameterized Rectangular shapes 
 

在添加矩形 shape 時新增相關參數設定，可以控制 shape 的生成型態，可以對 shape 的 corner 進行導角處理，

也能夠根據需求設定 corner 的尺寸。 

 
1  shape 的生成方式： 

 

2  corner 的處理： 

 

 

3 執行 shapeRectangular，設定好參數。生成 shape 如下圖： 

 

透過繪圖的方式來實現。 

透過設定矩形的長，寬值的方式來界定。

Orthogonal：轉角為 90 度角。 

Chamfer：轉角為 45 度角。 

Round：轉角為圓弧角。 

透過短邊的百分比來控制角長或

半徑。

透過具體的長度值來控制角長或

半徑。
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F. Shape Expand/Contract 

 
在 General Edit 工作模式下可以直接對 shape 進行外擴或內縮處理。只要將游標懸浮於 shape 上，點選右鍵執

行 Expand/Contract 即可透過 Option panel 進行操作。 
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G. Flash Symbol 
 
Flash symbol 主要用於和內層同訊號之負片的連接面。 

 

Flash Symbol 的編輯模式 

 

步驟 

a. 在 Setup>Drawing Size 下設定參數 

 

b. 點選 File>New 後就彈出下面的對話方塊進行物件類型的選擇 

 

 

 

 

 

 

 

 

 

 

c. 在 Drawing Type 下面選擇 Flash Symbol 

 

d. 在 Drawing Name 中寫入新建 shape symbol 的名稱，形式如：tr 外徑 x 內徑 x 開口寬度 x 開口角度 

 

e. 按 OK 就進入新建 Shape symbol 的模式 

 

f. 在右邊的 control panel 中 Option 欄進行層面的設定 

 

g. 點選 Add>Flash 彈出對話方塊，進行 Flash 參數的設定 

 

h. 設定完畢後，點選 ok 鍵，一顆 Flash symbol 的零件就完成了 

 

i. 點選 File>save 存檔成*.dra 檔 ，僅供對零件的編輯的圖形檔，         不能直接使用，可以透過剛才介紹

的保存 dra 同時產生二進位檔的方法省略第 i 步（見 Shape Symbol 的創建） 
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j. 點選 File>Create symbol 存檔為*.ssm 檔，是一個實際的零件實體，用於 PCB 板上， 

 

實例操作說明： 

以建立一個名稱為 TR60x44x10x45 的 Flash Symbol 的為例。 

 Thermal 的外徑 = 60 mils 

   內徑 = 44 mils 

   開口寬度 = 10 mils 

   開口角度 = 45 ﾟ 

 

a. 設定板子參數 

 

b. 點選 File>New 後就彈出下面的對話方塊進行物件類型的選擇 

 

 

 

 

 

 

 

 

 

 

c. 在 Drawing Type 下面選擇 Flash Symbol 

 

d. 在 Drawing Name 欄位輸入 TR60x44x10x45 為檔名 

 

e. 按 OK 就進入了新建 Shape symbol 的模式 

 

f. 在右邊的 control panel 中 Option 欄進行層面的設定 
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g. 點選 Add>Flash 彈出下面的對話方塊，進行 Flash 零件參數的設定 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

h. 設定完成後點選 ok 鍵，完成 flash 零件外形的建立，如下圖介紹：  

  

 

i.  點選 File>save 存檔成*.dra 檔 ，僅供對零件的編輯的圖形檔，不能直接使用 

 

j.  點選 File>Create symbol 存檔成*.fsm 檔，是一個實際的零件實體，用於 PCB 板上透過以上步驟一個特殊形

狀的 Flash Symbol 的零件就完成了，就可以用於建立 Pad 中。 

內徑 

外徑 

開口寬度 

花瓣數量 

開口角度 
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H. 銲點建立 

介紹完上面兩種特殊的 Symbol，開始正式進入 Pad 的建立。 

 

透過以下路徑  

           

 

 

 

 

                                               

 

點選 Allegro 的 Pad 編輯器                彈出下面的對話方塊，進行 Pad 參數的設定 
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確定 Pad 參數： 

(1) 對 Pad 的總體描述  

                      

Type：pad 的類型 

                           Etch layers：電氣層的層數 

                           Mask layers：非電氣層的層數 

                           Single Mode：是否是單面孔 

 

 

(2) 與 Pad 相關的其他設定 

 

 

 

 

 

Microvia 選項: 

勾選 Microvia, 表明 create 的 via 為 microvia; 若不勾選，則表明 create 的 via 為一般通用型態 

 

Allow suppression of unconnected internal pads 選項: 

若勾選此項，會在轉出 Artwork 時，除去內層未連接的 pad 

若不勾選此項，會在轉出 Artwork 時，會保留內層未連接的 Pad 

 

Enable Antipads as Route Keepouts(ARK)選項: 

若勾選此項,則對於 Mechanical Pin, 會以 antipads 大小作為 route keepout 

若不勾選此項,則對於 Mechanical Pin,不會以 antipads 大小作為 route keepout 

                                

(3) 確定單位及精確度                                            建議使用單位為 mil 

精確度為 2，即小數點後 2 位 
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(4) 確定貫孔個數， 

Enabled：不勾選，代表這個 Pad 的 drill 個數為 1 

勾選，那下面的 Rows 和 Columns 會變成黑色。 

可在 Rows 和 Columns 輸入橫向和縱向 drill 孔的個數，如在下面分別輸入 2，在

TOP View 欄顯示的 Pad 的效果如圖： 

 

 

 

 

 

 

 

Clearance：是確定 Drill 和 Drill 的間距 

 

(5) 選擇 Drill 的尺寸及類型 

#Hole type: 鑽孔形狀 

1.Circle drill: 一般圓形鑽孔  

2.Oval slot: 橢圓形之槽孔 

3.Rectangle slot: 矩形之槽孔 

 

#Plating: 

1.Plated:Drill hole 孔壁需要鍍銅 

2.Non-Plated:Drill hole 孔壁不需要鍍銅 

3.Size:Drill hole 的尺寸大小 

 

 

 

 

 

 

 

 

 

    Circle drill                         Oval slot                     Rectangle slot  
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 (6) NC Drill 檔符號參數的設定 

 

figure: 符號外形 

      Character: 符號內的文字 

       Width/Height: 符號的大小 

 

 

 

確定 Pad 的層面 

 

 

(1) 用 Single layer mode 開關來控制 pad type 

勾選 Single layer mode,則 pad 為單面孔，比如 SMD 

不勾選 Single layer mode,則 pad 為通孔，比如:via  
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(2) 用滑鼠左鍵點選 BEGIN LAYER 彈出下面 3 個欄位 

Regular, Thermal Relief, Anti Pad；Regular 用於正片，Thermal Relief 用於負片連接，Anti Pad 用於負片隔

離。 

 

在 Geometry 欄位選擇外形，有以下幾 種選擇 

                     Circle: 圓形 

                     Square: 正 方 形                   

                     Oblong: 橢 圓 形 

                     Rectangle: 長 方形 

                     Octagon: 八 角形 

                     Shape: 特 殊 的 Shape 外形 

   

 

(3) 在 Width 和 Height 欄位輸入 Pad 的尺寸，這個尺寸是根據公司規範，不同公司的規格可能有所不同。 

 

 

(4) 在 Thermal Relief 欄選擇好外形， 

 按     選擇 Flash symbol 

  如:TR_80_60 ，所以前提需要先建立一個 flash－ symbol，然後直接套用 fsm 名稱 

 

(5) 同樣如前兩列一樣輸入有關內容這樣 Pad 的 Top 層面的設定就完成了。 

 

 

(6) 如果需要增加一些層面資訊， 將滑鼠移到      選右鍵彈出             ，選擇               則會在 

 

 

 

layer 編輯區域多出一組層面的設定，就可以在其中來編輯要加的層面資料 

 

 

 

 

(7) 如果其他層面的設定和 top 相同或者類似，可用 copy 的形式進行複製，來提高工作的效率。 
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(8) 滑鼠移到      選右鍵彈出選單             ，選擇 copy to all 彈出下面的對話框進行複製層面的選擇。 

 

 

 

比如 Soldermask 所要填入的參數和 Top 層面相同，那只需要在 

Soldermask 前面打勾，就完成了它的設定，避免了一些重複的動作。 

 

 

 

 

 

 

 

 

 

 

(9) 所有的層面設定完成後，如下圖： 

 

 

(10) 執行 File>save 或者 save as 存檔成*.pad，完成 Pad 的建立。 
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I. Padstack 的修改 

 
修改的方法有兩種： 

(1) 針對 Design 修改： 

直接在 Layout 的過程中選擇 Tools/Padstacks/Modify Design Padstack 

 

 

 

 

然後在控制台的 Options Tab 中（見右圖） 

選擇需要修改的 Padstack，雙擊滑鼠左鍵，彈出了 Padstack 的編輯對話方塊對 Pad 進行編輯，然後在

Padstack 的對話方塊中選擇 

 

(2) 針對 Padstack 檔案進行修改： 

在 Allegro 程式外直接啟動 Padstack Editor（啟動方法在建立 Padstack 的時候已經有介紹），在彈出的對話

方塊中選擇 File/Open 打開想要編輯的 Padstack 進行編輯。 
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第三章 Component Symbols 
 

在這章內容裏將會介紹如何利用 Allegro 建立零件及其零件之分類及結構 

 

A. 零件的分類 

     

種  類 注  釋 

Package Symbol（*.psm） 就是在板子裏面有 footprint 的零件。 

（如，dip14，soic14，R0603，C0805 等等。） 

Mechanical Symbol（*.bsm） 就是在板子裏面的機構類型的零件。 

（如，outline 裝機螺孔，等等。） 

Format Symbol（*.osm） 就是關於板子的 Logo，assembly…等等的注解。 

Shape Symbol（*.ssm） 是用來定義特殊形狀的 pad。 

Flash Symbol（*.fsm） 這個零件是用於 thermal relief 和內層負片的導接。 
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B. 零件的建立(使用零件精靈) 

 

以下針對一般的 Package symbol 為例進行講解。 

自動建零件：利用建零件的導引精靈進行建立  

Example：建 Dip16 包裝的零件（用 Package Symbol Wizard） 

 

步驟：  

a. 進行建立零件的參數設定，如 Pad 的參數設定相同，這裏不做詳細介紹。 

 

b. 在 Allegro 的主工作介面點選 File>New，彈出下面的對話方塊，進行先建內容的選擇。 

 

 

 

 

 

 

 

 

 

 

 

c. 在 Drawing Type 中選擇 Package Symbol Wizard。 

 

d. 在 Drawing Name 這一欄裏寫入欲建立的零件名稱，例如 Dip16 點擊 OK 按鈕後結束對話方塊，自動進 

入 Package Symbol Wizard 的工作環境。 

 

e. 導引精靈回彈出如下圖的的導引對話方塊進行零件包裝的選擇，有以下幾種類型如 dip，smd，soic 等， 

這裏選擇 Dip（外掛程式）的外包裝，選擇完畢後點擊 Next，進行下個參數的設定。 
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f. 這裏是進行零件範本的選擇，                              選擇 Cadence 提供的預設範本，           

                   用戶自定義的範本，一般建議就使用 Cadence 的預設範本即可。 

然後按 Load Template 這個按鈕（這是必須的）。按 Next 進入下一步。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

g. 在這個對話方塊裏設定一些關於 Wizard 和建立零件的單位元和精確度，這些資料請參考零件製造廠商所提供

的 Datasheet 來設定。 

在本範例中，單位使用為 mil，精確度為 2 位。Package symbol 的單位也為 mil，精確度為 2,確定零件的

Reference 的首碼，如 U*，R*，C*…等，這裏選擇 U*按 Next 進入下一步。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

h. 在這個對話方塊裏需要進行零件的物理參數的設定，如 Pin 腳個數，間距等。 

Number of pins：零件腳的個數的設定（Dip16 零件的 Pin 腳個數為 16）。 
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Lead pitch：設定兩個零件腳之間的間距如 e 表示，根據各公司的不同要求進行選擇，這裏選擇 100mil 

Terminal row spacing：設定兩排 pin 腳的間距如 e1 表示。 

Package width：設定零件的寬度如 E 表示。 

Package length：設定零件的長度如 D 表示。 

按 Next 進入下一步。 

 

 

 

 

 

 

 

 

 

 

 

 

 

i. 在下面的對話方塊中進行零件 Pad 選取。 

 

 

 

 

 

Default padstack to use for symbol pins：點擊      進入 padstack 的資料庫抓取一般零件腳的 Pad，如 

                                       Dip16 的一般 Pin 腳為圓形，選擇 Pad60cir36d。 
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Padstack to use for pins 1：為了便於知道零件的 Pin1，及零件方向，需要設定一個與默認零件 Pin 不同的 

                          pin 腳，通常是第一個 Pin，Dip16 需要一個方形的 Pad 做 Pin1，點    進入 

                          padstack 的資料庫抓取零件第一腳的 pad，如 Pad60sq36D（如果不需要標示 

                          Pin1 與其他 Pin 腳不同，跟著一般 pin 選同樣的 Pad）按 Next 進入下一步。 
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j.  對話方塊裏需要設定 symbol 的 origin 及是否需要輸出*.psm 檔，需要就會導出*.dra 和*.psm 檔，不需要那就 

只產生*.dra 檔 

 

 

 

 

 

 

 

 

 

 

 

 

確定零件的參考點， 

1. Center of symbol origin：以零件的中心為 origin。 

2. Pin 1of symbol：以第一 pin 為 origin。 

 

Create a compiled symbol：精靈會把零件存檔成*.dra 和*.psm 兩種檔案 

Do not create a compiled symbol：精靈只把零件存檔成*.dra，而*.psm 要自行在 File>Create symbol 產生。 

點擊 Next 進入下一步。 

 

k. 在這個對話方塊裏，提示精靈將轉出的那些檔案。(*.dra,*.psm)按 Finish 就完成建立 Dip16 的零件了。注意， 

這裏是建立了一個零件的初始狀態，還需要透過手動幫它加上 Component outline，Labels，限高區等。這些 

內容在下面講到手動建立零件時一起講述。 
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l. 最後執行 File/Create Device，來產生該元件的 Device 檔，這個檔在使用舊轉法進行網路表導入(Netin)的時候

需要用到。 

 

到此為止，一顆基本的零件資料就完成了。接下來將介紹以手動形式進行零件的建立。 

 

 

C. 手動形式進行零件的建立 

 

Example：建 soic14 的零件（package symbol）。 

建一個零件包含之物件為： 

(1) 銲點型態(Padstack)。 

(2) 零件的外框（Assembly outline ，Silkscreen outline）。 

(3) Labels（包含 Device ，RefDes，Value，Tolerance，Part Number）。 

(4) 限制區的加入（可依需求加入 Package Boundary，Via keepout 等等）。 

 

步驟： 

(1) Padstack（零件腳） 

a. 在 Allegro 的工作介面內點選 File>New，然後出現一個 New Drawing 的對話方塊，如下圖 

 

 

 

 

 

 

 

b. 在 Drawing Type 中選擇 Package 

Symbol。 

 

c. 在 Drawing Name 這一欄填入零件名稱如：soic14。 

 

d. OK 的按鈕後結束對話方塊，然後就進入 Package Symbol 的工作環境。 

 

e. 設定作圖的參數，點選 Setup/Drawing Size 進行參數設定，以前詳細敍述過，這裏不再介紹。 
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f. 點選 Layout>Pin 或 Add Pin 的快捷方式     ，在右邊的控制欄，進行 Pin 腳的添加。 

 

在 Control Panel 中 Options 欄位需要以下的設定。 

 

Connect：這是加一般零件 pad 的模式。 

Mechanical：這是加 Mechanical pad 的模式。 

一般根據實際需要進行選擇； 

以 soic14 為例，選擇 Connect 就可以了。 

Padstack：透過點選     進入 Pad 庫進行零件所要 Pad 

的選擇，這裏可以分兩次選擇，Pin1 選一次， 

作為與其他 Pin 腳不同的選擇。 

第 2 次進行一般 Pin 腳的選擇 Pin1 和其他 Pin 腳 

可以相同。  

Copy mode：選擇 Padstack 擺放的模式。 

 

 

一種是 Rectangular（一般的矩形擺法），一種是 Polar（放射狀的複製擺法） 

 

 

 

 

 

 

 

 

 

在建一般零件時就用 Rectangular 的模式。 

這裏建立 soic14 就只要選擇這種模式，而 Polar 的模式是在建螺絲孔等零件的時候需要用到。 

對於很多 Pin 腳的零件，如果一個一個添加很慢，且不容易控制 Pin 腳與 Pin 腳之間的間距，那 Allegro 對 Pin

腳的添加提供了這樣一個複製功能 

#Qty:複製 pin 腳數。 

#Spacing:複製 pin 之間距。 

#Order:順序。 

 

如：Soic14 需要 14 個 Pin 腳，在 X 欄下的 Qty 輸入 7，然後確定 Pin 和 Pin 間距 100mil，確定複製方向從左往 

右或從右往左，然後在工作區內放入 Pin 腳，就完成了 7 個 Pin 腳的放置。 
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Rotation：旋轉角度，一般在建零件的時候是不需要進行旋轉的，即角度為 0。 

 

這裏確定 Pin 腳標示文字的有關內容。 

Pin＃表示 Pin 腳標示，從多少開始，一般是從 1 開始， 

Inc 是表示 Pin 腳編號的遞增數，一般都是遞增 1。 

 

如果是 1， 

 

如果是 2， 

 

這裏表示所用字體的大小，如 1 號，2 號等。 

 

 設定 Pin number 放在 Pin 腳的什麼地方。 

 

如果為（0，0）表示放在 Pin 腳的參考點  

 

（－100，0）表示偏左 Pin 腳參考點 100mil  

 

那對於建立一般的 soic14 的零件，需要選擇以下的一些設定， 

 

Rectangular 的模式 

參數設定完畢後點選一個 pad 就可以很快把 14 個 Pin 腳進行添加完畢。 
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(2) 零件的外框（Assembly outline ，Silkscreen outline） 

a. 點選功能表 Add 下相關命令或者點擊           進行零件外框的加入。 

在 Control Panel 裏進行層面的選擇 

 

或者  

 

 
Add 下面提供了一些添加 Line 及 Arc 的功能。 

Line：加一條沒有電器特性的線。 

Arc w/Radius：加一個圓弧，是以滑鼠所點的兩點長度為半徑。 

3pt Arc：加一個圓弧。是以滑鼠所點的兩點為圓弧的開口。 

Circle：加個圓。 

# 零件的外形如果是方形，用 Line 即可，如果是圓弧，則要選擇 Arc 

 

Add>Line 

Add>3pt arc 

 

 

 

 

 

 

 

 

(3) 限制區的加入（Package Boundary，Via keepout 等等） 

a. 添加 Package Boundary 

選擇功能表中 Setup>Areas>Package Boundary，然後根據零件的外框（PACKAGE GEOMETRY 下的

ASSEMBLY_TOP）的大小 copy 一個 Package Boundary，如此就完成一個封閉且實心的 shape。 

 

 

  Package Boundary 
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1. 點選 Setup>Areas>Package height ,點擊 shape，在右邊的 Options 欄就會出現零件高度的設定選項 

 

Min height：輸入零件最小高度。 

Max height：輸入零件最大高度。 

或直接輸入零件高度於 Max height。 

透過這種方法可以完成零件高度的設定。 

 

 

 

 

 

 

 

 

 

 

 

2. 還可以透過 Edit>property 點選 shape 

彈出下面的對話方塊，進行高度的設定 
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兩者設定的效果相同，用於提示零件高度。 

當需要顯示零件的高度，可以透過  show shape  

顯示內容中就會彈出有關高度設定如右：             

 

 

 

 

 

 

 

(4) 添加 Labels（包含 Device ，Refdes，Value，Tolerance，Part Number） 

a. 點選選單裏的 Layout>Labels>RefDes（        ）把 RefDes 加到 REFDES 下的 ASSEMBLY_TOP。 

通常在建零件的時候會以基本的標示名稱，如：U*，R*等。 

b. 點選選單裏的 Layout>Labels>Device，把 Device 加到 Device 下的 ASSEMBLY_TOP。 

c. 點選選單裏的 Layout>Labels>Value，把 Value 加到 Value 下的 ASSEMBLY_TOP。 

d. 點選選單裏的 Layout>Labels>Tolerance，把 Tolerance 加到 Tolerance 下的 ASSEMBLY_TOP。 

e. 點選選單裏的 Layout>Labels>Part Number，把 Part Number 加到 Part Number 下的 ASSEMBLY_TOP。 

 

 

 

 

 

 

 

 

 

 

 

 

Note: 文字不是每個都需要加，可以根據自己的需要，把相關的內容添加，但是 RefDes 名稱是建立每顆零件所

必須要有的。 

 

 

 

 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

3  -  13 

 

(5) 所有設定完成後，需要存檔。 

 

Note: 需要 save 成一個*.dra 檔供以後零件的編輯，為一個可編輯檔，如：soic14.dra。 

Create symbol 一個 *.psm 的文檔供零件的調用，是實際零件,如：soic14.psm。 

這裏仍然有個環境變數 no_symbol_onsave 是可以設定在產生 dra 檔的同時產生 psm 檔，這個變數可以

在 Setup/User Preference 中的 Drawing 種類中進行設定（詳細設置請參考前一章節的 Shape Symbol 的

建立） 

 

(6) 執行 File/Create Device 產生載入網路表需要的 Device 檔案 

當三個檔案完成後，一個零件的建立就完成了。 

 

 

D. Jumpers 
 
在單面板設計中經常用到跳線功能。在 allegro 中使用此功能，要先建立 jumper 的封裝，然後 

在 board file 中調用我們建好的 jumper。 

 

1. 建立 jumper 的封裝 

(1) 在 allegro 中執行 FileNew，然後在彈出的對話框中選擇 Drawing Type 為 Package symbol 並輸

入 jumper 的名字：jumper。 
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(2) 執行 Set upDesign Parameters,在彈出的對話框中選擇 Design 欄。設定好相關的參數，並且將

Jumper 選項做勾選。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(3) 執行 Add Connect 命令，例如建一個 100 mils 長的 Jumper , 則分別在（0,0）和（100,0）處加

上兩個 via。 
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(4) 給 jumper 添加文字面，執行 Add 3pt Arc 指令，在 Package Geometry 下的 Silkscreen_Top 層

加上一個圓弧形的文字面。 

  

 

(5) 給 jumper 添加 place boundary。用畫 shape 的方式在 Package Geometry 下的 Place_Bound_Top

層加上一個圓弧形的 place boundary。 

 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

3  -  16 

 

(6) 給 jumper 添加 label。執行 LayoutLabelsRefDes，在 RefDes 下的 Silkscreen_Top 層添加

label:jumper*。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(7) 執行 FileSave，儲存 jumper 封裝。 
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2. 在 board file 中選用已建好的 jumper。 

(1) 在 board file 中增加一個 drawing level 的屬性：JUMPER_LIST，此屬性的值為 jumper 的 footprint。 

(2) 有多個 jumper 時，用冒號將它們的 footprint 隔開。 

  

 

(3) 執行 Route-Connect,選好 jumper 的起始位置。 
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(4) 點選右鍵，執行 Add jumper。在 jumper 列表中，選擇合適的 jumper。有效的 jumper，它的 footprint 

name 為正常的。無效的 jumper，它的 footprint name 為灰色的顯示。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(5) 將 jumper 的第一 pin 放置到最初選好的位置。可以對 jumper 進行 mirror rotate，擺放好 jumper

在 board file 中的位置。 
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(6) 完成走線動作。 
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E. Import/Export csv file 
 
在建封裝時支援 csv 格式檔的導入與匯出，大大提高了建立複雜且不規則型 Pin 腳擺放的封裝元件的的便利。 

 
1. 當我們拿到 csv 格式檔，在 allegro 中只要執行 FileImportCSV Pin File 操作，就可以快速建立出零件的 

封裝。 
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2. 當我們要對零件進行快速編輯時（已經有零件的 CSV pin file），也只要將 CSVpin file 導入即可。在導入時我

們還可以選擇是否要把已經存在的 pin 進行刪除處理。 

 
 

 
 

3. 如果想匯出已經建好封裝的 csv pin file，只要在 symbol editor 中執行 FileExportCSV Pin File 即可。 
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F. Auto Re-pinning 
 
對於現有的封裝可以快速進行零件 pin 腳的編號處理。 

 

1. 在 symbol editor 中，執行 LayoutRenumber Pins。 

 

 

 

 

 

 

 

 

 

2. 設定 renumber 的相關參數，就可以按設定好的參數對零件 pin 進行 renumber 處理。 
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第四章  Importing Logic 
 

本章的主要內容介紹 allegro 如何載入 Netlist，透過本章學習可以對 Allegro 和 Capture 之間的互動關係，同時

也能體驗出 Allegro 和 Capture 同步變更屬性的強大功能。 

 

A. 基本概念 

 
Netlist 是連接線路圖和 Allegro Layout 圖檔的橋樑。 

在這裏所介紹的 Netlist 的轉入只是針對從 Capture（線路圖部分）產生的 Netlist 轉入 Allegro（Layout 部分）。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. 在 Orcad Capture 中設計好線路圖。 

 

2. 然後由 OrCAD Capture 產生 Netlist。 

 

3. 把產生的 Netlist 轉入 Allegro PCB Designer（layout 工作系統）。 

 

4. 在 Allegro 中進行 PCB 的 layout。 

 

5. 把在 Allegro 中產生的 back annotate（Logic）轉出（在實際 layout 時可能對原有的 Logic 有改動過），並轉 

入 OrCAD Capture 裏進行回編。 
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Netin 的兩種常用的方式： 

 

第一種(新轉法)：在 Capture 裏輸 netlist 時選 PCB Editor 的方式；Allegro 中轉入的時候選 DesignEntry 

CIS(Capture)。 

第二種(舊轉法)：在 Capture 裏輸出 netlist 時選 Other，再選 Allegro.dll 的方式；Allegro 中轉入的時候選 Other； 

                ( 此轉換功能所需的介面已經在 10.5 版就已經廢止，因此軟體安裝完後是找不到 Allegro.dll 

這個介面資料，若要提供此介面必須要到更早已前的版本中將 Allegro.dll 複製過來用 ) ，另

外使用舊轉法…內容會需要用到 Device File，下面先對 Device File 介紹一下： 

 

Device 是一個文字檔案，內容是描述零件以及 Pin 腳功能及群組關係屬性。 

包含的內容參考下面： 

 

PACKAGE 零件包裝，PSM 的檔案名（PCB Footprint） (如 DIP14,SO8, C0402) 

CLASS 零件類型  (for example, IC, discrete) 

PINCOUNT 零件的 Pin 腳數 

PINORDER 結合下面幾個功能 

PINUSE Pin 的作用 (for example, INPUT,OUTPUT) 

PINSWAP 定義可 Swap 的 Pin 

FUNCTION 定義 Swap FUNCTION 

POWER 電源 Pin 

GROUND 接地 Pin 

NC 未連接 Pin 

PACKAGEPROP TOL 誤差值 

PACKAGEPROP VALUE 數值 

END 結束標記 

 

可選（推薦） 

可選項目 

必備項目 

必備項目 
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(Device file for 7400) 

PACKAGE DIP14              Package name (PCB Footprint) 

CLASS IC                 Placement class 

PINCOUNT 14            Total number of pins in device 

PINORDER 7400 I0 I1 O      Defines pin names for a section 

PINUSE 7400 IN IN OUT      Specifies pin functions (relates to PINORDER) 

PINSWAP 7400 I0 I1       Specifies swappable pins 

FUNCTION G1 7400 1 2 3      Defines a section (relates to PINORDER) 

FUNCTION G2 7400 4 5 6      Ditto 

FUNCTION G3 7400 9 10 8  Ditto 

FUNCTION G4 7400 12 13 11  Ditto 

POWER VCC ; 14           Specifies power pins 

GROUND GND ; 7           Ditto 

END 
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B. Capture 中的電路圖整理 

 
在 Capture 中可以加入一些對以後 layout 有幫助的定義，在下面會介紹這些定義。 

 

零件的定義 

在零件的定義中和 layout 最有關的是定義零件中可以 pin 和 Functions 的 swap 功能。 

以下就該功能及定義方式進行介紹。 

 

(1) 在線路圖部分的定義 

如果用第一種方法轉出 Netlist 的話，就要在建立線路圖所使用的 Symbol 時就進行定義。 

 

Swap Pin 的定義 

1. 用滑鼠點選想定義的零件。 

2. 點選選單中 Edit>Part。 

3. 點選選單中 View>Package。 

4. 點選功能表中 Edit>Properties，出現下面表單： 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

定義 Swap Pin 功能就在 PinGroup 這一列，把可以相互 swap 的 Pin 在 PinGroup 內填入一個相同的序號進

行組別的分類。 
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例：如果 Pin1，2，3 為一組，則需於 PinGroup 欄位填入 1，Pin4，5，6 為另一組，並於 PinGroup 欄位填

入 2；這樣 Pin1，2，3 就可以互相 swap，Pin4，5，6 也可以互相 swap。 

 

Swap Functions 

 

在線路圖部分要定義零件的 Functions（Gate）能被進行就一定要在建立零件庫時進行定義。 

 

1. 點選功能表 New>Library 新建一個零件庫。 

 

 

 

 

 

 

 

 

 

 

 

2. 用滑鼠先點選好那個新建的 Library，再點選選單，Design>New Part，進入 Edit Part Properties 的對話方塊。 

只有 Homogeneous 類型零件才可已有 Swap Function 的能力。 
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3. 在對話方塊中的 Parts properties 中定義零件有幾個 Functions。 

這樣就把 7400_0 定義為有四個 Gate 了，在 layout 時就可以根據實際需要進行 Swap Functions 了。 

 

在 Device File 中進行定義 

 

但是用第二種方式轉入 Netlist 時，因為 netlist 中是沒有零件的相關屬性定義資料，所以就要藉助零件的 Device 

File 來補充定義。 

其中：PACKAGE、CLASS、PINCOUNT，END 是一定要有的 

 

以 DDR184 為例  

“定義接點可以進行 PINSWAP 的互換，邏輯閘可以進 FUNCTION Gate 的互換” 

 

Device File 

 

定義每一組 Function Gate 

之間 D0~D7 的八個 Pin 

能進行 PinSwap。 

 

定義每組 Function Gate 中所 

對應的 Pin 腳。 

這樣就可以把這八組 

Gate 根據實際的 layout 進行互換調整。 

 

 

 

 

 

 

 

透過以上對 Device File 的定義，就可以在 layout 時進行必要的 Swap 了。 
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(2) PIN 的定義 

如果用第一種方式產生 Netlist 的話，就要對於一些 Power pin 加以定義。 

1. 滑鼠點選想定義的零件。 

2. 點選選單中 Edit>Part。 

3. 用滑鼠點選想定義的 Pin 腳。 

4. 點選功能表中 Edit>Properties，透過這些步驟就看到了下面的這個對話方塊了。 

 

 

 

 

 

 

 

 

 

 

 

在這裏主要是把 Type 欄位的選項確定為 Power 的類型，因為在用 Allegro PCB Editor 的介面轉出 netlist 時，

有相同 Pin Name 時就不能把 netlist 順利的轉出，除非它的 Type 是 Power 類型的，因此就要在這裏定義為

Power Pin。 

 

一些附加限制的加入（Add Property） 

 

(3) 在 Capture 中可以先加入一些關於 Constraints 的初步設定，  

1. 標點選想定義的零件。 

2. 點選功能表中 Edit>Properties，透過這些步驟就看到了下面的這個對話方塊了。 
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而在這裏強調的是要定義各個零件的 Footprint（就是在這要用的實體零件的名稱如 soic16，一定要和 Allegro 的

零件庫的命名要相同，否則會找不到對應的零件），還有就是 Reference 和 Value 的加入。 

其他的 Property 的設定在後面的章節會進行詳細的介紹。 

 

 

 

C. 產生 Netlist 

(1) 在 Capture 裏輸出 netlist 時選 PCB Editor 方式。 

1. 用滑鼠點選要產生 Netlist 的線路圖的圖檔。 

 

 

 

 

 

 

 

 

 

 

2. 點選功能表中的 Tool>Create Netlist 後就進入 Create Netlist 的對話方塊,並在對話方塊中選擇 PCB 

Editor 的產生方式。 
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這個對話方塊分為兩部分。 

第一部分是 Create PCB Editor Netlist：選擇 Netlist 產生之路徑,並產生 netlist 檔。 

       

 

 

 

 

 

 

 

 

 

 

 

第二部分是 Create or Update PCB Editor Board：不只是產生 netlist 的檔還可以直接進入預先設定好的

板子中並且打開。（netlist 要完整無誤）。 

 

Note：對話方塊中參數設定的介紹。 

 

Allow etch removal during Eco：再次 netlist 時，是否允許把原來沒用的 ETCH 資料刪除。 

 

Place changed：是針對第二次轉入 netlist 時，零件放置參數設定。 

 

Always：全部放置在原先的位置上。 

 

If same symbol：當新舊零件包裝相同時可以做替換，而且位置相同。 

 

Never：把原來放置的零件全部拿掉，netlist 後重新擺放零件。 

 

Board Launching Option：在這裏選擇使用那個 layout 軟體開啟 PCB Design。 

（選擇 None 的話就只是產生 netlist，而不會直接進入 layout 軟體的工作介面。一般是在 Allegro 的介面

打開）。 
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(2) 在 Capture 裏輸出 netlist 時選 Other 

 

1. 點選功能表中的 Tool>Create Netlist 後就進入 Create Netlist 的對話方塊了。 

 

2. 在對話方塊中選擇 Other 的產生方式。就看到了下面的對話方塊了。 

  
在用這中方法（other）導 netlist 時要注意的是： 

在 OrCAD 9.2 以後的版本中的 ALLEGRO.DLL 已經被取消了，所以在用這種方法轉出 netlist 時必須在

OrCAD 9.2 以 前 版 本 中 ALLEGRO.DLL 的 複 製 過 來 ， 並 且 把 它 放 置 在

C:\Cadence\SPB_16.6\tools\capture\netforms 

 

用 {Value}＋!{PCB Footprint}方式所產生之 Netlist 中，會帶有三個值，其格式為！Device！【Value】；

Reference 其中｛｝中的是變數，輸出 netlist 會把該元件的相應值帶出。 

在填寫 PCB Footprint 時一定要在 { 前面一定要加一個！ 。 
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Allegro 載入 netlist 的欄位完整格式: 

 

（其中【】中的內容是可以省略） 

【PCB Footprint】！Device！  【Value】！ 【 Tolerance】；Reference 

 

！Device   ；Reference 

因為在用第二種的方法轉 Netlist 時，需要 Device 這個檔。 

 

一般我們的 PCB Footprint，和 Device 是使用相同名稱，故 Pcb footprint，Device 只要留一個即可。所以

通常會將可被忽略的 PCB Footprint 前加個！的用意是代表,前面的【PCB Footprint】是被省略的。其輸出

格式則簡化為 

 ！Device！  【Value】！Reference,輸出內容如下， 

 

！Device！  【Value】！Reference, 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

4  -  12 

 

D. 將 Netlist 轉入 Allegro 

第一種方式轉入 netlist 

1. 執行 Allegro 程式。 

2. 打開一塊準備要轉入 Netlist 的新母板。（File>Open） 

3. 點選 File>Import>Logic（進入 Netlist 轉入的準備介面。） 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. 選擇 Cadence netlist 參數設定介面。 

5. 在 Import directory 的欄位中選好 netlist 的文件。（可以透過點選        進行瀏覽和選擇。） 

6. 執行 Import Cadence 的即可轉入 Netlist 的檔。 

 

Note： 

# Import logic type：其中，Design Entry HDL ，Design Entry HDL CIS(Capture)，SCALD 是三種畫線路圖的

軟體，其選擇方式是看我們的 netlist file 是從那種軟體轉出的，就選擇那種。 

# Place changed component：是針對第二次轉入 netlist 時，零件放置參數設定。 

# Always : 全部放置在原先的位置上。 

# Never：把原來放置的零件全部拿掉，netlist 後重新再擺放一次零件。 

# If same symbol : 當新舊零件包裝相同時可以做替換，而且位置相同。 
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# HDL Constraint Manager Enabled How options：在這裏設定要怎樣把在線路圖中設定的 Constraint 帶入

Allegro。（只針對 Cadence 自帶的 HDL 線路圖設計軟

體。） 

 

# Import Changes Only：系統會保留板子中現有的 constraints，然後再帶入在線路圖中被修改的 constraints。 

# Overwrite current constraints：系統會刪除板子中現有的 constraints，然後再帶入線路圖中所有的

constraints。 

 

# Allow etch removal during ECO: 再次 netlist 轉入時，是否允許把原來沒用的 ETCH 刪掉。 

# Ignore FIXED property: 當有 Fixed 這個 Property，是否可以直接 Pass，打勾表示 fixed 可以動 

# Create user-defined properties : 勾選表示允許帶入 Netlist 自行定義的屬性 

# Create PCB XML from input data:為當前的板子建立一個線路圖的 XML 檔，名字為 boardname_sch.xml. 可

以在啟動 Design Compare 工具的時候看到 

# Design compare : 啟動該工具後，Allegro 可以把線路圖的 Netlist（XML 格式）放在視窗的左邊，board 的

Netlist（XML）放在視窗的右邊進行比較。 

 

第二種方法的 netlist 轉入 

Other（如果從 Capture 中 Other 的方法轉出的 Netlist 話，在這裏也要用 other 的規範轉入。） 

1. 直行 Allegro 這個程式。 

2. 打開一塊準備要轉入 Netlist 的新母板。（File>Open） 

3. 點選 File>Import>Logic（進入 Netlist 轉入的準備介面。） 

4. 選擇 Other netlist 參數設定介面。 

 

 

 

 

 

 

 

 

 

 

 

 

在 Import netlist 的欄位中選好 netlist 的文件。（可以透過點選     進行檔案瀏覽和選擇。） 

按 Import Other 的即可轉入 Netlist 的檔。 
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Note： 

在 netlist 轉入新板時下列選項是不用夠選的（第一次 Netlist 轉入），在 netlist 轉入已有 netlist 的板子（第一次

以後 Netlist 轉入）時你可以在這裏設定一些你想要的參數。 

# Syntax check only : 只檢查 Netlist 的語法，而不進行 Netlist 的轉入。 

# Supersede all logical data : 取代舊 Netlist。 

# Append device file log：把新 Device Log 的資料直接加入舊的 Log 

# Allow etch removal during Eco：再次 netlist 時，是否允許把原來沒用的 ETCH 刪掉。 

# Ignore FIXED property : 當有 Fixed 這個 Property，是否可以直接 Pass，打勾表示在 Netin 時,fixed 會被忽

略。 

# Place changed component：是針對第二次轉入 netlist 時，零件放置參數設定。 

# Always : 全部放置在原先的位置上。 

# Never：把原來放置的零件全部拿掉，netlist 後重新再擺放一次零件。 

# If same symbol : 當新舊零件包裝相同時可以做替換，而且位置相同。 
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第五章  Creating Board 
 
使用 Allegro 軟體進行 PCB Layout 最基本的是要建立一塊空板，然後定義板子外框以及添加層面等一些動作，

Allegro 為使用方便，提供精靈引導的模式或是一般模式，本章將有具體例子介紹。 

 

A. 精靈引導模式（Board Wizard） 

 
步驟： 

 

進入建立工作檔的模式 

 

1. 點選 File>New 就會出現下面表單。 

 
 

2. 在 Drawing Name 這一欄裏寫入：檔案名（例:card）。 

 

3. 在 Drawing Type 中選擇 Board(Wizard)。 

 

4. 按 OK 的按鈕後結束對話方塊，然後就進入 Board(Wizard)的工作環境。 
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在 Board Wizard 模式中的設定 

 

1. 這裏介紹了此模式能幫助使用者定義的參數。按 Next 進入下一步。 

   - 板子的單位，工作區域的大小，原點座標 

- 板子的外框 

- 格點之間的間距 

- 板子電氣層

面的設定 

- 基本的設計

規則設定 

 

 

 

 

 

 

 

 

 

 

2. 在這裏提示使用者是否有建好的板子範本需要載入做利用，如果有範本的話選 Yes 然後點選右邊按鈕尋找應

用範本。按 Next 進入下一步。 
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3. 在這裏，提示使用者是否要導入既有的 tech file 及 Parameter。這些檔案的內容包括了板子的層面和相關限

制設定的參數。設定後按 Next 進入下一步。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. 在這裏類似前面，提示使用者是否要選擇一個既有的 board symbol 載入進來。所謂的 board symbol 是包括

板框和其他一些有關板子資訊的參數模組。設定完成後按 Next 進入下一步。 
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5. 設定製圖所使用的單位，製圖區的大小及系統原點的所在位置設定。 

 

  
 

選擇工作的單位（Units）而它的精度會隨之改變；選擇工作區的範圍大小（沒有自行定義的 Other 選項可選

擇）。這兩項的設定有點類似前幾章說的工作區參數設定。 

 

Specify The location of the origin for this drawing： 這一段為設定工作區的原點位置。 

 

- At the lower left corner of the drawing：點選這裏就是把原點定義在工作區的左下角。 

  

- At the center of the drawing：點選這裏就是把原點定義在工作區的正中心。 

 

按 Next 進入下一步。 
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6. 設定輔助作圖的格點設定及電氣層面的數量。 

 
 

Grid spacing： 

在這裏寫入作圖時格點大小。（這裏的格點設定是包括電氣和非電氣的格點，作圖時有其他格點要求的話可以

在功能表裏的 Setup>Grid 進行改變。） 

 

Etch layer count： 

在這裏可以設定板子的電氣層面的數量。 

（包括 Power 層，如果要有 Top, Bot, Gnd, Pow 這些層面的話，就先在這裏設定為 4，這樣就代表有四層電

氣資料層要加入。） 

 

Do you want the default definitions of artwork films for these layers to be generated? 

在這裏是選擇是否要把 Etch layer count 中設定的層數加在底片中。 

 

- Generate default artwork films：點選此處，在出底片時系統會把這幾個層面資料自動加入。 

 

- Don’t generate artwork films：點選此處，在出底片時需要自行把要出的底片層面加入。 

 

設定完成後，按 Next 進入下一步。 
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7. 在這裏是定義層面的名稱和其他條件。 

 

 
Layer name：在這裏可以透過用滑鼠點選想改名的層面，來為它取名。 

（Top 和 Bottom 為系統預設，這兩層是不能改變的。） 

 

Layer type：這一列是定義層面為一般走線層還是電源層（包括接地層）。 

            同樣這裏也可以透過用滑鼠點選自行定義的層面，來為它定義是 Routing layer 還是 Power 

plane。 

 

Generate negative layers for Power planes： 

勾選本選項後，系統就會自動把定義的 Power plane layer 視為負片資料。 

不勾選,系統則視為正片資料。 

 

按 Next 進入下一步。 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

5  -  7 

 

8. 在這個對話方塊中是設定在板中的一些預設走線的線寬及線距的限制和預設貫孔所使用的 Padstack。 

 

 

Minimum Line width：在此設定設計中系統能允許的最小走線寬度。 

 

Minimum Line to Line spacing：在此設定設計中系統能允許的走線與走線的間距最小值。 

 

Minimum Line to Pad spacing：在此設定設計中系統能允許的走線與 Padstack 間距的最小值。 

 

Minimum Pad to Pad spacing：在此設定設計中系統能允許的 Padstack 與 Padstack 間距的最小值。 

 

Default via padstack：在此設定設計中系統預設的貫孔資料。 

 

按 Next 進入下一步。
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9. 在這裏定義板框的外形。 

 

Circular board：圓形板框 

Rectangular board：方形板框 

在 Wizard 的環境中是不支援特殊外型板框的，只能透過自己去建立，或者先做個 Mechanical Symbol，再從

先前的第四步先把它放進來。Mechanical Symbol 的建立稍後會介紹。 

 

按 Next 進入下一步。 

 

10_1. 如果在前面選了 Circular board 這一選項後就會進入下面這個對話方塊。 
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10_2. 如果在前面選了 Rectangular board 這一項後就會進入下面這個對話方塊。 

 

 
 

Width 和 Height：確定板框的長和寬的，也就是板子的大小。 

Cut length：寫入要挖掉板子四角的長度（因為挖掉的是個正方形，所以只要填入一邊的長度就好了）。 

( 要啟動這一項就要先勾選 Corner cutoff，否則剛才的設定是不會生效的。) 

Route keepin distance：電氣走線資料的操作範圍（就是銅箔資料相對於板外框的內縮距離）。 

Package keepin distance：允許零件擺放的範圍（就是離開板外框的內縮距離）。 

 

Note： 

Route keepin：限制區的設定，就是走線一定要在這個區域內，否則系統會認定這是個錯誤。 

Package keepin：也是限制區的設定，就是在擺放的零件只能在這個區域內，否則系統會認定這是個錯

誤。 

 

按 Next 進入下一步。 
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11. 到這一步我們精靈嚮導模式（Board Wizard）建框就完成了。 

 

 
 

按 Finish 就可以看到我們剛才設定過後建立的板子了。 
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B. 普通模式建立工作檔 

 
步驟： 

進入建立工作檔的模式 

1. 點選 File>New 就會出現一個對話方塊。 

 

2. 在 Drawing Name 這一欄裏輸入：板名 

（根據需要輸入，如上例之 test）。 

 

3. 在 Drawing Type 中選擇 Board。 

 

4. 按 OK 的按鈕後結束對話方塊，然後就進入建 Board 的工作環境。 

 

設定作圖的參數 

Drawing Size 的一些詳細設定在前面已經詳細敍述過，在此就不再介紹了。 

 

層面的設定 

首先點選 Setup> Cross-section 或點它的功能鍵  

後就進入層面設定的那對話方塊了。在這個對話方塊中可以設定有關板子的層面數，層面的材質，層面名，DRC

檢查底片的形式，等等。 
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Total Thickness：板子厚度的顯示。 

 

增減層面資料： 

用滑鼠右鍵點選層面的數字後就會出現一個小的對話方塊  

其中 Add Layer Above：往上新增一個層面。 

     Add Layer Below：往下新增一個層面。 

     Remove： 刪除當前點選的那個層面。 

 

Material： 

層面的材料選擇。用滑鼠點選  後，就可以在裏面選擇想要的層面材料。 

（其中 FR-4 是常用的絕緣材料，Copper 是銅箔） 

 

Layer Type： 

選擇層面的類型。用滑鼠點選  後，就可以在裏面選擇想要的那個層面的類型了。 

Subclass Name： 

層面的名稱輸入。可以在它下面的方框中寫入想要的名字。 

 

Negative Artwork： 

定義層面是否以負片形式產生底片。 

 

格點的設定： 

首先點選 Setup>Grid      進入格點設定的對話方塊。 

 

Grid on：是控制格點是否要顯示。或是點選快捷圖示來控制格

點是否顯示。 

 

Non-Etch：定義非電氣特性的格點。（如移動零件時的格點規格

設定） 

 

Offset：格點與座標（0,0）點的偏移 

 

All etch ：定義所有電氣層面（包括電源層和接地層）的格點 TOP，VCC，……GND，BOTTOM：是對每個電

氣層面格點的單獨定義。 
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C. 板框（Outline）建立 

 
因為建立一塊板子一定要確定它的範圍的大小，所以給它加個板外框。 

以加一個 10000×12000 的板框為例。 

1. 點選 Add>Line 

2. 在右面的 Control Panel 的 Options 裏確定是加在 Class 的 Board Geometry 

   Sub-class 的 Outline 層面上。 

3. 畫板子外框的外形，由於手動畫很難做到很精確，所以需要用座標定位， 

在命令區（Command 區）鍵入： 

X 0 0（確定板框的一點 x＝0，y＝0）； 

X 10000 0（確定板框的另一點 x＝10000，y＝0）； 

X 10000 12000（確定板框的第三點 x＝10000，y＝12000）； 

X 0 12000（確定板框的第三點 x＝0，y＝12000）； 

X 0 0（回到起點）。 

透過這五步我們就建好了一個 10000×12000 的板子外框了。 

複雜的板框也是這樣在命令區裏一一輸入它的頂點座標。 

 

Note：我們還可以透過兩個命令把板框的頂角轉成任意角度或弧度。 

點選 Manufacture > Dimension/Draft > Chamfer，它可以將兩條相交或將要相交的直線改成斜角相連。 

 

 

 

 

 

 

First:第一選的線的折角。 

Second:第二選的線的折角。 

Chamfer angle:折角的度數。(可以輸入任意值。) 

 

點選 Manufacture > Dimension/Draft> Fillet 可以將兩條相交或將要相交的直線改成圓弧相連。 

    Radius：圓弧的半徑值。                                     
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4. 若是利用 Dxf 載入，發現線段為不連續的多個線段，而非完整的 shape 時，可使用 Shape/Compose 將其認

成一個 Shape 資料 
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D. 板子限制區的設定（Route keepin，Package keepin） 

 
1． 點選 Setup>Areas> Route keeping。（Package keepin） 

2． 也和畫 Outline 一樣的步驟來完成 Route keepin。（Package keepin） 

如果也這樣畫是很麻煩的，而且畫的不一定正確（因為它們都要比 outline 框的範圍要小，如果設計一樣大

時，在製程時容易使走線和零件有損傷的風險）。 

 

簡便方法： 

 

1．點選 Edit>Z-copy 

2．在 Control>Option 的設定 

 

Options Form 的說明如下： 

在 Copy to Class/Subclass 下面欄位中選擇要複製到的層面選擇（Package 

Keepin>All 或 Route keepin>All） 

 

Shape Options： 

- Copy：Voids 和 Netname 是選擇是不是要複製原來 shape 的 Voids 和

Netname，這主要是針對 Etch 層的 shape 而言。  

 

- Size：Contract（縮小）和 Expand（擴大）是選擇複製後的 shape 是縮小還是擴大。（在 Offset 中輸入要縮小

或擴大的數值。0 是不變。） 

 

現在要的 Route keepin，Package keepin 是要比 outline 要小，所以選擇 Contract 這一項，在 Offset 中輸入要

縮小的距離。作好了這些設定後只要用滑鼠去點選 outline，然後就會馬上出現想要的 Route keepin，Package 

keepin ，在它所圈定的範圍了。 

 

Note： 

執行 Z-Copy 動作時，如果先前畫的 Outline 是個封閉的 shape 時，那一定要在 Control>Find 中勾選 Shape 這

一項，否則系統是不會幫你完成這個動作的；如果先前畫的 Outline 是用 Line 組合而成的話，那一定要在

Control>Find 中勾選 Line 這一項，否則系統也不會幫你完成這個動作的。 
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E. Mechanical Symbol 的建立 

 
建一個 Mechanical Symbol 在零件庫，可以避免去重複的建立相同的板子外框和固定的機構螺絲孔等動作，進

而節省工作時間來提高工作效率 

 

建立步驟： 

1． 點選 File>New，然後會出現一個 New Drawing 的對話方塊。 

2． 在 Drawing Name 這一欄裏寫入：Test（零件的名字） 

3． 在 Drawing Type 中選擇 Mechanical Symbol。 

 

 

 

 

 

 

 

 

 

     

 

4． 按 OK 的按鈕後結束對話方塊，然後就進入建 Mechanical Symbol 的工作環境。 

 

設定作圖的參數 

Drawing Size 的一些詳細設定與我們在前面的動作是相同的。 

板框的建立和板子限制區的加入 

它的建立和上面的 Outline 建立和板子限制區加入的步驟是相同的。 
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F. Associative Dimensioning 
 
Allegro 對 dimension 功能做了增強。當對某個對象執行了 dimension 操作時，內部會自動將 dimension 與這個

對象建立了關聯。如果之後對這個對象執行編輯操作，如移動，工具會自動更新與之關聯的 dimension 資訊。 

 

1. 透過以下方式啓用這個功能: 

選擇 Manufacturing - Dimension Environment 

執行 Dimension Edit command 

使用工具欄  

 

 

 

2. 如果在 16.5 中升級一個之前版本的設計，舊有的 dimension 資料不會變成有關聯的。之前版本中添加的

dimension 仍然保持非關聯狀態，是不能移動和編輯的。設計者可以選擇刪掉並重新標出 dimension，以實現

dimension 的關聯功能。 

 當 16.5 的設計降爲低版本時，dimension 資訊仍在，但已經不是關聯的。 

 

3. delete dimensions 可以用來刪除關聯的 dimension。 

刪除一個對象，與之關聯的 dimension 資訊也會刪除。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

      

Delete J64
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4. 使用 move text 或 edit leader 命令，去編輯 dimension 標註線和文字。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. 在沿 Y 方向移動一個元件後，dimension 文字不會保持原來的 Y 位置。如果想保持，使用 Lock dimensions

命令，用來在移動之前鎖定文字。 

 

6. 在標注尺寸資訊時，可以透過 text 文字方塊將設計所用的單位，或是一些文字資訊等等給標注出來。 

 

 

 

 

 

 

Move text   

%v：表示用測量的資料來替代。 

%u：表示用 MM 或 In 來替代。 

？：點選問號可以進入輔助說明文件。 
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7. 對於已經標注完成的資訊，可以透過 change text 進行編輯處理添加想要的一些文字資訊。 
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8. Z-move 命令用在移動 dimension 文字到其他的子層，但是有一些限制。可用的子層有： 

－Board Geometry 

   Dimension 

   Assembly Notes 

   Any user defined subclass 

－Drawing Format 

   Any user defined subclass 

－Manufacturing 

   Any user defined subclass 

  
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9. 參數表中，藍顔色代表： 

   參數表 — 只對後來增加的 dimension 起作用，對已經存在的沒有作用。 

 

實例參數表 – 只對選擇的 dimension 起作用。 

             

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

6  -  1 

第六章 Placement 

 
當把 Netlist File 正確的導入後，就要進行零件的擺放。Allegro提供了兩種對於零件的擺放模式：手動放置零件

與自動放置零件。 

 

A. 擺放前格點的設定 

 
要注意的是在擺放零件時要把格點設的大一點，這樣擺放的零件可以比較整齊，一般設定格點間距為 50mils。 

 

如何設定格點？ 

點選選單 Setup >Grids…彈出下面的對話方塊 

 
Placement 時所需要的格點是不需要電氣特性的，所

以在 Non－Etch 欄位的 Spacing 裏輸入所要的大小，

如：50 

 

 

 

B. 手動 Placement 步驟： 

 

點選選單 Place>manually…或者點選           彈出

下面的對話方塊： 
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Placement List 下面是提供 netlist 帶入的零件名稱，點選後可以直接放置在 PCB 板上，根據具體架構，及擺放

規則放置零件。 

 

 

這裏是針對所有零件擺放前可以進行篩選，如按字母或者按零件的類型進行篩選，然

後勾選零件就可以擺放在 

PCB 板上。 

 

 

下圖是針對所選取的零件的提供一個預覽視窗，您可看到該零件的外形。 

   

點選 Graphics 可以看到零件的外形，點選 Text

可以瞭解零件的大概定義。 

 

 

 

 

Note： 

List 出來的 4 個檔案夾代表 4 種類型的零件，其中 Components by Refdes 所有的零件是 netlist 本身所需要的零

件，在 database 中存放。Mechanical symbol 和 Format symbol 是存放在 Library 中的，供使用者調用。  
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C. 快速 Placement 步驟： 

 
1. 點選功能表Place>Quickplace命令，彈出以下的對話方塊，進行參數選擇，把

PCB 板上的所有或部分零件快速擺放到板框四周，相對於把零件一個一個抓

出來，這樣可以節省很多時間加快了Placement的速度。 

 

 

對使用者來說一般需要做的動作就是在 Edge 裏面選擇快速放置零件的位置： 

勾選選擇放在板外框的左邊還是右邊，還是放在 Top 層還是 Bottom 層。 

 

 

 

 

 

 

 

 

 

 

2. 在設定完畢後，一定要點選 Place，才能把零件叫出來，如果點選 OK 鍵，相當於把這個視窗關閉，沒有執行

這個命令。 

 

 

 

這樣執行完畢後，在工作區內就可以看到如圖所示的情況，把 netlist 內的零件

全部調出到 outline 的四周。 

然後按線路圖將零件放到 PCB 板中。 
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3. 若要依 RefDes 移動零件,，可在執行 Move 後，點選 Find。 

在 Find by Name 輸入要移動的 RefDes 即可立即找到此零件，並抓選

出來。 

 

                                                                                           

 

 

 

 

 

 

 

 

 

 

 
4. 當零件數量很多，板框周邊空間有限時，就會出現無法對零件進行快速擺放的動作。現在我們可以通過 

Quickplace Overlap controls 功能，將同類零件進行重疊處理來實現 quickplace。 
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D. Align Components 功能： 

 
在 Placement Application mode 下支援 align components（零件對齊）功能。對齊方式有兩種：一是以某一顆

零件為基準點對齊，會將其它零件的中心與這顆零件的中心來對齊；一是以板中的任意點為基準點對齊，會將要

進行對齊動作的零件中心與選擇的位置來對齊，步驟如下： 

 

1. 設置 application mode 為 Placement Edit。 

 
                                                                             

 

2. 使用滑鼠左鍵來框選元件或配合 Shift or Ctrl 來選取多個元件。 

 

3. 保持選取狀態，以某元件為基準點，或在任意區域設置基準點按SHIFT， 右鍵選Align component。 

                                                   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Or   

以一顆零件為基準

點來對齊            

對齊前   

對齊後   
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Note: 當多個元件不確定軸向時，如下圖所示：執行對齊時系統會顯示對齊軸向的選單。 

           

 

 

 

 

 

 

 

 

 

對齊前   

對齊後   

以 任 意 點 為

基準點對齊  
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另外進行對齊處理時也可選擇以哪個邊緣為基準線進行對齊，並且可以調控物件之間的間距。 

1. 選擇以哪個邊緣為基準進行對齊 

        當要實現水準方向對齊時，可以選擇以上緣或是下緣進行對齊處理。 

    

 

 

 

 

 

 

 

 

 

 

 

 

 

    

        

 

 

 

   當要實現垂直方向對齊時，可以選擇以左邊沿或是右邊沿進行對齊處理。 
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2. 可以控制對齊的物件之間的間距 

可以保留當前的間距進行對齊。 
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可以設定間距為依照DFA Constraint中設定的距離條件作為距離調整值。 

 

 

 

 

 

 

                                             

 

 

 

 

 

 

 

 

 

可以設定為等間距，即以當前選物件的總距離進行等分。如果需要改變間距大小，可以配合增加或減

少按鈕來進行等間距的調整。 
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E. Snap to Object 功能： 

在很多情況下會希望對物件做精確定位:比如將零件的第一pin與mechanical drawing十字交叉處對齊或者將 

Testpoint 與 Figure 對位。如果是要精確對位時就必須利用坐標的方式會比較麻煩，現在則可用Snap來將物件

做自動精確定位。 在走線，擺放元件，MOVE，COPY 等等功能狀態下點選右鍵就會有Snap pick to 的選項： 

   

 

在slide作業模式下向右移動，系統會自動找到最近的物件進行對位，如下圖所示： 

  

在move指令下,將零件的第一pin與mechanical drawing對齊: 

                                                                                                        

 

 

 

 

 

 

 

Snap to Figure 

Snap to Arc    
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F. Placement Replication 功能： 

當設計中存在幾個完全相同會類似的功能模塊時，沒有必要對每一個模組都一一重新佈局，只要做好一個

placement，然後利用Placement Replication功能來套用已經做好的placement，這樣就可快速實現相同功能模

組的佈局，使用Placement Replication功能的前提條件是當前的模式為Placement Edit Mode，大致步驟如下: 

 

1. 建立“ Module ”，選擇Placement好的元件後，滑鼠

右鍵選Place replicate create 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

2. 選擇參考點或以人工點滑鼠右鍵去抓取某

點或物體做為參考點。完成後會彈出已儲存

範本的名稱,可以給範本取名比如Graser。 

Module Definition File (.mdd) 
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3. 套用範本到未佈局的元件上。選取需要套用的元件，點選滑鼠右鍵，選擇 Place replicate apply 中選SAVE 

過的範本如：Graser 

 

 

4. 找到合適的元件，會自動跑到游標上。直接擺放即可。 
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G. Component Placement Applications 
 
1. Placement Replication enhanced to support Interconnects 

Placement replication支援etch資料的複製。Placement replication的操作步驟如下： 

 

(1) 將Allegro的工作模式切換到Placement Edit Mode 

   

(2) 在所想要建成 Module 中的任一顆零件上，按滑鼠右鍵執行Place Replicate Create. 

( Placement Mode 的指令必須游標在零件上才會有作用 ) 

 

 
 

(3) 框選High light要建成 Module 中所有的物件包含Etch資料後,再按滑鼠右鍵，在右鍵選單中點選Done。 

 

(4) 選擇 Module 的參考點。可以在 Module 上任意選一點左擊作為參考點，也可以右鍵去選取某物件做為

參考點。 

 

(5) 將Module存為範本，在彈出的對話方塊中輸入Module的名稱。 
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(6) 框選要被用來套用的元件，點選滑鼠右鍵，選擇 Place replicate apply 中選 SAVE 過的範本如：CHANNEL 

 

 

(7)  對於存在可替換的零件，我們可以在彈出的對話方塊中做設定。 
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(8)  找到到合適的元件，會自動整理排好並帶到游標上，直接點擊擺放即可。 

被套出來的模組電路稱為 Replicated Circuits。 

 

 

2. Moving Replicated Circuits as a Group 

(1) 在移動時，可以將 Replicated Circuits 作為一個 group 來移動。 

 

(2) 可以透過以下兩種方式中的任一種來整體移動 Replicated Circuits。 

– 點右鍵將Super Filter設為Module，在Replicated Circuits上方右擊執行Move指令。 

– 在Move指令狀態下，控制台中Find Filter勾選group，然後點選要移動的Replicated Circuits 

 

3. Locking the Circuits 

(1) 可以將 Circuits 鎖定，防止移動時單獨移動某個零件。當 Circuits 被鎖定後，在移動時就是將整個 Circuits

作為一個 group 來移動。 

 

(2) 透過給 group 加一個 locked 屬性來鎖定它。 
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4. Aligning Modules and Replicated Circuits 

增強的對齊功能，不僅支援零件的對齊，還支持Modules和Replicated Circuits的對齊處理。 

Modules 和 Replicated Circuits 對齊方法如下： 

 

(1) 切到 Placement Edit Mode 操作模式 

 

(2) 框選要做對齊動作的 Modules  

(Replicated Circuits)  

 

 

 

 

 

 

 

 

(3) 在作為參考點的 Modules 或 Replicated Circuits 上方點右鍵，執行 Align modules. 
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5. Update Replicated Circuits 

 

(1) 當 Replicated Circuits 的 layout 狀況發生變更（包括走線的變化，零件的移動等等）時，可以利用 Update。

Replicated Circuits 一次性將所有的 Replicated Circuits 更新。 

 

(2) Update Replicated Circuits 的操作方式為： 

- 在 Fine filter 中僅勾選 Group  

- 在已經變更好的Replicated Circuits上方點右鍵，執行Update Replicated Circuits。 

- 點右鍵選擇 Done，將變更後的Replicated Circuits存為一個範本，在彈出的對話方塊中輸入此範本

的名稱。 

- 範本存檔的同時，所有的Replicated Circuits都會透過 Module 資料的更新而自動修正。 

 

6. ECO Changes to Circuits 

對於發生logic上的工程變更，如果變化多就只能重新建 Replicated Circuits，然後再透過Place replicate 

apply來完成placement。 

 

7. Disband Replicated Circuits 

 

(1) Disband Group可以將database中作為一個整體的group/module 狀態解除。 

 

(2) 解除Replicated Circuits方法。 

       - 將super Filter設為module，在要被解除的 replicated circuit 上方點選滑鼠右鍵。 

       - 執行Disband Group即可。 
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8. Move Components one grid unit with Arrow Keys 

 

(1) 增加了零件location微調的功能，能實現在小範圍內移動零件。 

(2) 零件location微調的功能正常使用，必須滿足下面條件： 

        - update env file，確保env file中包含如下內容 

 

- Allegro的工作模式要切到Pre-selection下，對於None模式下是不支援此功能的。 

 

(3) 零件location微調的操作： 

- 切換allegro的工作模式置Pre-selection中的任意一個，選擇要微調的零件。 

- 按住Shift，根據零件要移動的方向選擇Arrow keys中合適的一個按下。這樣零件就在Arrow key所指

的方向上，以grid的長度為單位移動。 
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9. Change pick point during Move operation 

 

(1) 在move過程中，可以改變pick point的選擇： 

(2) 改變pick point的兩個選項： 

- User pick方式下的改變：當Rotation Point設定為User pick時，右鍵選擇Change user pick。此時就

可以更改零件move的pick point了。 

- Symbol Pin方式下的改變：點選右鍵執行Options — Rotation Point — Symbol Pin — New，在彈出

的Enter New Value對話方塊輸入新的值。 

 

 

10.  Create/Disband Groups in Pre-Selection mode 

 

(1) 在General Edit and Placement Edit模式下，支援新建或刪除group. 

(2) 在General Edit and Placement Edit模式下，新建group. 

- 選擇組成group的物件，點選右鍵執行Add to group. 
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- 在彈出的對話方塊中，給group取一個名稱：graser。然後，點選OK即可。 

 

 

(3) 在General Edit and Placement Edit模式下，刪除group。 

- 選擇要做disband動作的group，點選右鍵執行Disband group。 

 
 

11.  Move command update 

 在Move指令下，點選右鍵執行mirror就可以對零件( 僅可以 )做mirror動作。 
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第七章  Constraints 
 

Allegro 提供強大完善的設計規範設定，本章節則介紹 Design Check Rule 之設定，並可依不同的需求可針對

Spacing，Physical 定義為不同的群組作規劃及設定，或是針對忽略之檢查可設為 Waive DRCs 等功能作介紹。 

 

Constraints Manager 

 
在這裏設計規範是包括：安全間距的設定，走線寬度和貫孔的特殊設定，特殊區塊的設定，其他方面約束的設定

和物件特性控制的設定,其執行方式及主要工作區塊如下: 

Setup > Constraint Manager  

Setup > Constraint Manager > Physical 

Setup > Constraint Manager > Spacing 

Setup> Constraint Manager > Same Net Spacing 

 

 

 

 

Worksheet  

Status Window  

Work Area  
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Constraint Manager Left Pane 

 

  

Constraint Manager Work Area 
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A. Physical rules 設定： 

 
主要為設定如線寬、Via 大小等物件的大小等相關尺寸設定，其設定步驟如下: 

 
1. Setting the Default Physical Rules     

點選 Physical Constraint Set 即可出現 Default 的 Physical 相關設定值，如 Line Width、Neck width…等 

      

    

 

 

 

 

2. Defining the Special Physical Rules 

點選任一個 Constraints Set 或 Dsn 按滑鼠右鍵，執行 Create Physical CSet 加入新的規則 

 

 

 

 

 

 

 

3. Assigning the Net Class 

點選 Referenced Physical CSet 欄位，將規則指定到該特定群組 
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B. Spacing rule set 
 

主要進行走線安全間距的一些相關設定，其設定步驟如下: 

  

1. Setting the Default Spacing Rules     

點選 Spacing Constraint Set 即可對 Default 安全間距進行相關的設定 

 

 

 

 

 

2. Defining the Special Spacing Rules    

點選 Default 按滑鼠右鍵，執行 Create Spacing CSet 加入新的規則 

 

 

 

 

 

 

3. Assigning a Net Class 

點選 Referenced Physical CSet 欄位，將規則指定到該特定群組 

 

 

 

 

 

 

 

 

 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

7  -  5 

  

4. Setting Class-Class Rules 

若針對不同的訊號群組有不同的間距規則，則需設定 Class-Class 

選到 Net Class-Class 後，點選該群組後，按右鍵選擇 Create Net class-Class 

 

    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

執行完後，即可看到各群組之間的間距規範 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

7  -  6 

 
C. Same Net Spacing Rule Set 
 
主要進屬於同一個網絡邏輯的走線及 via 安全間距的一些相關設定，其設定步驟如下: 

 
1. Setting the Default Spacing Rules     

點選 Spacing Constraint Set 即可對 Default 安全間距進行相關的設定, 

 
 
 
 
 
 

 

2. Defining the Special Spacing Rules    

點選 Default 按滑鼠右鍵，執行 Create Spacing CSet 加入新的規則. 

 

 
 
 
 
 

 

3. Assigning a Net Class 

點選 Referenced Same Net CSet 欄位，將規則指定到該特定群組 
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D. HDI Constraint Driven Flow 
 

1. Via List Viewer 

(1) Access from Constraint Manager 

– Physical domain 

– Via List cell 

 
 

(2) 圖形化的介面，能夠清楚的顯示出各種類型的 via 在板中的堆疊狀況。 
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(3) 可以通過 draw option 自訂 via 在 viewer 中的顯示狀況，如 color，layer visibility，tool tips 等。 

 
 

2. Via List DRC 

(1) Via List 可以控制基於網路物件（如 Net Classes, Buses, Differential Pairs, Xnets , Nets）可以使用何

種類型的 via. Via List 也可和 Region object 物件綁定，控制這個區域內只允許使用某些 via。Via List

劃分在 Constraint Manager 的 Physical 域內，通常可作為 Physical Cset 約束的一部分。這種 PCset

約束可以施加在 Net objects 上，也可以直接施加在每一個成員之上，單獨施加在每一個成員上的約

束會超載施加在本類對象上的約束。 
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(2) Via List DRC 開關的設定： 

– 執行命令 Setup - Constraint – Modes - Physical Modes。   

– 在彈出的對話方塊中切到 physical mode，將 Via list DRC 開關由 off 置到 on。 

– 點擊對話方塊下方的 ok 或 apply。 

    

   

   

   

   

   

   

   

   

   

   

   

   

   

   

   

   

   

 

(3) Via List DRC 在 allegro 中標識為 V-N 
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3. Exclusive Microvia Stacking (XL) 

(1) 此功能用來控制 via 之間的堆疊，只允許 microvia 與 microvia 之間的堆疊。 

 
(2) 為了只允許 microvia 與 microvia 之間的堆疊，在 constraint 中 pad-pad connect 的下拉欄加了兩個專

用的選項： 

 

 

– Microvia_Microvia_Only: 只允許 microvia 和 microvia 之間的堆疊; 過孔的中心可以略微有一些

偏移，只要其中的一個過孔的中心在另外一個過孔的邊界範圍內。 

– Microvia_Microvia_Coincident_Only: 只允許 microvia 和 microvia 之間的堆疊;兩個過孔的中心

必須是一致的 (即相同的 x.y 座標位置)。 
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4. Elimination of Unused Stacked Vias (XL) 

(1) 此功能可以刪除因工程變更而產生的沒有用的 stacked vias,以減少 stub 對信號的影響。 

 

 

(2) Elimination of Unused Stacked Vias 的使用如下： 

– 執行命令 Route — Gloss — Parameters.  

– 在 Glossing Controller 對話方塊中點先 

– Via eliminate 左手邊按鈕. 

– 在彈出的 Via eliminate 對話方塊中勾選上 

– Eliminate unused stacked vias. 

– 點擊 ok 
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E. Design Constraints 
    

1. 執行 Analyze/Analysis Modes，則可使用 Design Constraints，對 Negative plane，Soldermask 進行檢查。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

 

 

 

Negative plane islands：檢查負片中 Flash 零件間隔的距離（大於下面的 Oversize 就不會有 DRC 的警告 

Soldermask alignment：設定防焊層和 Pad 誤差的 DRC 顯示模式 

Soldermask to soldermask：選擇是否要顯示防焊層之間的資料若小於規定的間距就產生 DRC 

Soldermask to pad or cline spacing：選擇是否要顯示防焊層與銲點及走線若小於規定的距離就產生 DRC 

Soldermask to shape spacing：選擇是否要顯示防焊層與銅箔小於規定的距離就產生 DRC 

Testpoint pad to component：測試點邊緣與零件的間距 

Testpoint location to component：測試點中心與零件的間距 

Mechanical pin to mechanical pin：機構孔的銲點與機構孔銲點的間距 

Mechanical pin to conductor spacing：機構孔的銲點與銅箔導體之間的間距 
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2. 執行 Analyze/Analysis Modes，可對 Physical Modes, Spacing Modes 及 Same Net Spacing Modes 設定檢

查的模式的開啟與否 
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F. Region 
  

若對某特定區域有不同的規範設定，可使用 Region 功能，使用步驟如下, 

 

1. Defining Constraint Regions     

執行 Shape> Polygon/Rectangular/Circular 設定範圍 

     

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Define and Apply the New Rule Set 

  到 Constraint Manager 內設定 Rule 以及對應到 Constraint Region 
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3. Creating a Region-Class Rule 

若針對區域內的特殊訊號群組，要設定不同的規範，則需在 Region 加一個 NetClass 
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G. Electrical Constraints (performance option) 
 

這裏是電氣特性方面的設定，如常用的 differential Pair 的設定 

 

 

DiffPair 之設定: 

 

Calculator – 可由 User 設定的 Impedance 計算線寬，線距.., 存在於 setup > constraints> Ecsets > diff pair 

values 中 

Primary Gap – 兩條線主要的間距 

Line Width – 兩條線主要的線寬 

Neck Gap/Width – 兩條線次要的線寬與線距 

Coupled Tolerance +/- --兩條線的線距誤差值 

Min Line Spacing – 兩條線的最小間距 

Gather Control – 設定是否要把 Gather 走線納入 Uncoupled Length 計算 

Max Uncoupled Length – 當兩條對線無法進行伴隨走線時,最大可允許非 

伴隨走線的線長 

Phase Tolerance – 兩條訊號線可允許的誤差值 

專有名詞的用法請參考左圖: 

 

Pseudo Segment – Uncoupled Length 的線段用該層的 DRC 顏色表示 

出來,如下圖: 
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H. Property 設定 

 
 物件特性控制 

在這一部分將介紹關於 Net 和零件一些常用的 Property 的設定。（部分） 

(1) 零件部分 

 FIXED：可以將該零件固定（不因其他編輯指令而移動改變位置）。 

 HARD_LOCATION：在執行 Auto Rename 的動作時，系統不會將該零件的 

RefDes Rename 掉。 

 NCPIN_TESTED：是設定該零件所有的 NC Pin 都必須有測試點。 

 

(2) Net 部分 

 FIXED：可以將該 Net 固定（不被加以其他動作）。 

 NO_RAT：不顯示該 Net 的鼠線。 

 BUS_NAME：給該 Net 線組賦予一個匯流排組名。 

 TESTPIN_COUNT：設定該 Net 測點的個數。 

 MIN_LINE_WIDTH：設定該 Net 的最小線寬。 

 NET_PHYSICAL_TYPE：設定 Net 的線寬和使用的 Via 的分組名稱。 

  

當 MIN_LINE_WIDTH 的設定於 NET_PHYSICAL_TYPE 的設定有衝突時，系統會應用 MIN_LINE_WIDTH 的

設定。 

 DIFFERENTIAL_PAIR：定義差動訊號對名稱。 

 MAX_VIA_COUNT：設定該 Net 最多可以使用的 Via 數量。 

 VIA_LIST：設定該 Net 可以使用 Via 的類型的名稱列表，並以“，”來分隔。 

           如：VIA_LIST＝via30，via40，via50 

 

 IMPEDANCE_RULE：設定走線的特性阻抗值。 

語法說明： 

IMPEDANCE_RULE＝A：B：C：D 

A：起點 Pin。 

B：終點 Pin。 

如果是整條 Net 話，在 A 和 B 處寫入 ALL 就好了。 

C：阻抗的數值大小。 

D：阻抗的誤差大小。（可以用絕對數值表示，也可以用百分比表示。） 
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例： 

1．IMPEDANCE_RULE＝ALL：ALL：50ohm：10ohm 

（設定走線的阻抗是 50ohm，誤差值是正負 10ohm） 

2．IMPEDANCE_RULE＝ALL：ALL：50ohm：10％ 

（設定走線的阻抗是 50ohm，誤差值是正負 10％） 

3．IMPEDANCE_RULE＝U1.1：R1.1：50ohm：10ohm 

（設定走線在 U1.1 到 R1.1 之間的阻抗是 50ohm，誤差值是正負 10ohm） 

4．IMPEDANCE_RULE＝U1.1：R1.1：50ohm：20％ 

（設定走線在 U1.1 到 R1.1 之間的阻抗是 50ohm，誤差值是正負 20％） 

 

PROPAGATION_DELAY：設定走線的長度範圍。 

語法說明： 

PROPAGATION_DELAY＝A：B：C：D 

A：起點 Pin。 

B：終點 Pin。 

如果是整條 Net 只有 2 個 Pin 時，在 A 處寫入 L，在 B 處寫入 S。 

C：最小線長。 

D：最多線長。 

 

例： 

一， 

PROPAGATION_DELAY＝U1.4：U2.8：1000mil：1500mil 

（設定 U1.4 到 U2.8 的走線長度為 1000mil 至 1500mil 之間。） 

PROPAGATION_DELAY＝U1.4：U2.8：1000mil： 

（設定 U1.4 到 U2.8 的走線長度大於 1000mil。） 

PROPAGATION_DELAY＝U1.4：U2.8：：1500 

（設定 U1.4 到 U2.8 的走線長度小於 1500mil。） 

二， 

PROPAGATION_DELAY＝L：S：1000mil：1500mil 

（設定整條 Net 的走線長度為 1000mil 至 1500mil 之間。） 

PROPAGATION_DELAY＝L：S：1000mil： 

（設定整條 Net 的走線長度大於 1000mil。） 

PROPAGATION_DELAY＝L：S：：1500mil 

（設定整條 Net 的走線長度小於 1500mil 之間。） 
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RELATIVE_PROPAGATION_DELAY：是設定等長的走線組。 

 

語法說明： 

RELATIVE_PROPAGATION_DELAY＝A：B：C：D：E：F 

A：組名。不要和 BUS_NAME 名相同，所在設定 MATCH_GROUP 是要注意到這一點。 

如：BUS_NAME 是 AGP，那 MATCH_GROUP 就不能起 AGP，可以設為 R_AGP。 

否則可能引起不能修改。 

B：是 GLOBAL 或 LOCAL，在 B 欄位寫入 G 或  L 即可。 

C：起點 Pin。 

D：終點 Pin。 

如果是整條 Net 只有 2 個 Pin 時，在 C 處寫入 L，在 D 處寫入 S。 

E：在這裏寫入要比參照線（Target）長或短的數值。 

F：長度的誤差值。（可以用絕對數值表示，也可以用百分比表示。） 

 

例一： 

RELATIVE_PROPAGATION_DELAY＝R_AGP：G：U4.23：U5.34：0mil：25mil 

（設定 U4.23 到 U5.34 為 R_AGP 組的等長線段，其誤差是 25mil。） 

RELATIVE_PROPAGATION_DELAY＝R_AGP：G：U4.23：U5.34：0mil：10％ 

（設定 U4.23 到 U5.34 為 R_AGP 組的等長線段，其誤差是 10％。） 

RELATIVE_PROPAGATION_DELAY＝R_AGP：G：U4.23：U5.34：： 

（設定 U4.23 到 U5.34 為 R_AGP 組的等長線段組中的參照線（Target）。） 

RELATIVE_PROPAGATION_DELAY＝R_AGP：G：U4.23：U5.34：15mil：25mil 

（設定 U4.23 到 U5.34 為 R_AGP 組的等長線段，其長度比同組的 Target 線段長 15mil，然後長度的誤

差是 25mil。） 

RELATIVE_PROPAGATION_DELAY＝R_AGP：G：U4.23：U5.34：－15mil：25mil 

（設定 U4.23 到 U5.34 為 R_AGP 組的等長線段，其長度比同組的 Target 線段短 15mil，然後長度的誤

差是 25mil。） 
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例二： 

RELATIVE_PROPAGATION_DELAY＝R_AGP：G：L：S：0mil：25mil 

（設定整段 Net 是 R_AGP 組的等長線段，其誤差是 25mil。） 

這裏的設法與有 Pin 號的設法基本相同，只要把起點和終點的 Pin 號改成 L 和 S 就好了。 

 

Note： 

1． 若 Net 的連接只有 2 個 Pin 時，起點和終點的 Pin 可以用 L：S 來表示。 

2． 若 Net 的連接超過 2 個 Pin 時，起點和終點的 Pin 就要用具體的 Pin 來表示。 

3． 等長的組名（Match Group）一定要和 Bus Name 的命名不同，否則會造成在 Cmgr 中無法修改該組等

長的值。 

 

 

 

I. Waive DRCs 
 
執行 Display/Waive DRCs，此功能可隱藏特定的 DRC 檢查錯誤，並可自行加上註解. 

執行方式如下: 

1. AGND 與 DGND 連接地方產生 DRC 
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2. 使用 Display/Waive DRCs/Waive ，將其 DRC 標上其註解. 

 

 

 

 

 

 

 

 

 

 

 

3. 被 Waive 處理過的 DRC 會以旋轉 90 度方式呈現像沙漏狀，並可看到其註解。 
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4. 使用 Display/Waive DRCs/Blank，將其 DRC 忽略且隱藏，但仍可從 Drawing Options，看到其 Waive DRCs

之數量 

 

 

 

 

 

 

 

 

 

 

 

 

若日後要打開檢視，可使用 Display/Waive DRCs/Show 開啟。 

若要回復 DRC 檢查，可使用 Display/Waive DRCs/Show/Restore 或 DRCs/Show/Restore all。 
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J. Display Constraint 
 
想要快速找到物件所設的 Constraint，可執行 Display /Constraint，可針對單一或兩個相對物件點選後，即可快

速得知設定資料。 
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第八章 Routing and Glossing 
   

本章主要介紹佈線設定和修線的功能，及其相關之應用 

 

A. 格點的設定 

 
執行功能表 Setup>Grids…出現下面表單 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Spacing  

x y 是水準和垂直的間距 

 

Offset 

x y 是原點(0,0)的偏移 

 

 

 

 

 

 

 

格點顯示開關 

非 Etch 層面資

料 參 考 格點設

置 

所有 Etch 層面 

單獨各 Etch 層

面 參 考 格點設

置 
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B. Adding Signal Connections and Inserting Vias 
 

這是 Allegro Layout 時最常用的一個功能，點選功能鍵，或點選功能表   Route>Connect  

Act：現階段操作層面 

Alt：相對調換的層面 

Via：換層的所要使用的 Via Padstack 

WL：依照滑鼠右鍵的 working layer 選單來切換操作操作層面 

Line lock：拉線型態，可選擇直線或圓弧 

後面爲角度 45：45 度 

90：90 度 

Off：任意角度 

Miter：拐角的長度，可用線寬倍數或長度定義 

Min：最小值 Fixed：固定值 

Line width：設定佈線線寬 

Default：恢復到原始設定線寬 

 

 

 

 

 

Bubble：走線模式 

 

 

 

 

 

 

           

 

 

Shove vias：推擠 vias 

Gridless：控制是否移動在格點上 

Clip dangling clines：推擠小段走線效果 

Smooth：平滑程度 

Snap to connect point：自動吸附上接點 

Off： 

普通模式 

Hug preferred： 

最佳化避讓模式 

Shove preferred： 

推擠模式 

Hug Only： 

純避讓模式 
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Replace etch：自動消除舊的走線迴路，避免形成 Loop Net 

直接在 Pin / Via 或 Cline 上點選滑鼠左鍵就可以在所需層面上添加走線 

 

 

如果在走線過程中需要換層的話就直接雙擊滑鼠左鍵就可以産生貫孔，這裏應該注意以下： 

1. 要在 constraints 的 Physical 設定加好要用到的 vias 
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2. 操作層面的指定與自動切換作業層面 

 

 

Act：當前的操作層面 

Alt：與操作層互調的層面 

Via：選擇所使用的貫孔 

 

 

完成添加貫孔和換層 

Bubble：自動推擠功能， 

  

 

 

 

 參考下圖效果 

       

 

 

 

Off Shove ＋ Minimal Shove ＋ Full 
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推擠 Via 的效果 

 
 

 
 

 

 

 
 

只有在 Add connect 時，選擇 Shove preferred 該功能才有效，效果如下圖： 

 

        

未打勾普通推擠 打勾切斷走線 

Off  

via 不推擠 

Minimal Shoving 

延著 Etch 推擠 

Full Shoving  

推著 Etch 走 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

8  -  6 

 

Option Form 

在 Add Connect 狀態下點選滑鼠右鍵出現下圖功能表 

 

 

功能表 功能 

Done 停止佈線指令操作,回到 Idle 狀態 

Oops 取消上一段走線的動作 

Cancel 取消當前指令 

Next 本條線的佈線動作暫停,改走其他線 

Reject 當有兩個物件重疊在一起時,放棄現在選取,可改選其他 

Add Via 添加貫孔 

Swap Layer 走線換層(Act 層換到 Alt 層) 游標須停在有含 Drill 的 Pin Pad or  Via 上 

Finish 以同層自動走完未佈線段 

Neck mode 窄線佈線,須依 Physical Rule Set 宣告 

Target 同訊號的設置主要包括以下三個方面 

New Target 改定同訊號的佈線終點 

No Target 尾段訊號不顯示 

Snap Rat T 移動訊號 T 點的位置 

Toggle 走線出 Pad 的角度切換(先直再斜或先斜再直) 
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在執行走線指令時，新增 Route offset 功能來協助設計若需以特殊角度走線的要求，如此可以幫助減少因

走線下方基板玻璃纖維編織問題而造成的阻抗不連續狀況。 

 

在 Option 面板中進行參數設定 

 
 

可以輕鬆實現特殊角度走線： 

 

走線時勾上 Route offset 項，就可以實現特殊

角度走線。 

在文字方塊中可以自訂走線的角度，它的範

圍是：4~18.5 度。 

定義多個走線角度後，可以通過下拉在不同

角度之間進行切換處理。 
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C. Moving Etch with the Slide Option 
 

Slide 這個功能是平行移動 Etch 而不改變原來的角度，點選功能鍵 或點選功能表 Route>Slide，下面表單

Options 是這功能的一些設定 

 

Active etch subclass：選擇要平移走線的層面，這裏不用設定，系統會自動把用戶所點選到的層面設爲 Active。 

 

Net name：所移走線的 net name 

 

Min Corner Size：在 45 度轉折角情況下，允許在 2 條非平行

線段之間的最小線寬值。 

 

Min Arc Radius：在弧線調整控制下，能夠設定兩 

相鄰線段間的弧線最小半徑。 

 

Vertex Action：除了移動節點之外，還增加了變換為直線以及

弧線轉角。 

 

Bubble：走線推擠模式 

 

Shove vias：推擠 vias  

 

Clip dangling clines：推擠 dangling clines  

 

Smooth：平滑程度 

 

Allow DRCs：允許 DRC 介入管理  

 

Gridless：允許不在格點上 

 

Auto Join：推線段時，透過此功能選項能將平行相接的線段一起加入推線。 

 

Extend Selection：透過此選項能夠令選擇的線段，與其左右相鄰線段固定轉折角度及長度進行調整。 
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這裏的幾個設置和前面的 Add connect 的效果是一樣的。 

如果想把下面左圖的走線修改成右圖的效果 

           

 

 

執行 Slide 點選滑鼠右鍵，出現右邊功能表選擇 Cut， 

在線段上選取兩點，然後移動滑鼠就可以達到效果了。 

 
 
 
在執行slide處理時支援offset走線的推擠處理： 

 

 
對vertex的處理： 

 

 

 

 

 

 

 

 

現在 slide 不會改變

offset 走線的角度。 

以前 slide 不會保留

offset 走線的角度。 
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Auto Join：推線段時，透過此功能選項能將平行 

相接的線段一起加入推線。 
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對於蛇行線快速進行長度調整 
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D. Enhanced Pad Entry 
 
此功能在互動式佈線時可以改善走線與銲點之間連接的過渡連線，同時也能避免產生一些尖角。 

1. Allegro在執行Add Connect 和Slide 命令時，默認開啟此特性，當然如果不需要，也可以手動關閉。 

  

 

2. 適用於圓形、方形和橢圓形銲點，保證直線與銲點連接時與銲點邊界保持垂直，或者以非銳角的方式連接。 

 

 

 

 

 

 

 

3. 當直線離開銲點時，拐點要受到直線與pin/via間約束的控制。 

 

 

 

 

 

 

 

 

 

關掉 Enhanced pad Entry 
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4. 本特性適用於任何角度放置的銲點，直線如何與銲點連接與line-lock值、滑鼠的位置以及滑鼠點擊點相對銲

點的位置都有關係。 
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E. Custom smooth 

自動平滑修線，點選功能鍵   或點選功能表 Route>Custom smooth 

 

Corner Type：轉角角度 

Restrict Seg Entry for Pads of Type：限制走線進入各形狀 Pads 

Minimum Pad Entry Length：進入 pad 的走線長度  

 

 
 

Max Iterations：重復的次數，如果有很多走線都要 smooth，就會一次一

次的迴圈執行 
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F. VERTEX ( 節點控制 ) 

若要針對走線刪增節點可執行 Edit/Vertex  or Edit/Delete Vertex 

   

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

8  -  16 

 

G. Rats（鼠線）的顯示控制 

功能表 Display>Show Rats 下面有 3 個功能 

1. All           顯示所以鼠線 

2. Component   顯示連接該零件的 Net 的鼠線 

3. Nets     顯示該 Net 的鼠線 

 

Display>Blank Rats 同上但為”不顯示” 

 

點選功能鍵   顯示所以鼠線，   關閉所以鼠線顯示 

 

Note： 

如果 Net 設定了 NO_RAT，該 net 的鼠線都不會顯示。 

另外也可執行 Display>Highlight or Display>Dehighlight 

針對不同訊號 Highlight 成不同的顏色,    關閉 Highlight 之效果 

 

 

為了降低工作區域內鼠線的顯示密度，新增了終端鼠線顯示方式。 

執行 DisplayShow RatsEnd In View Only。 

 

 

 

 

 

 

能夠對於工作視窗內的連接端點顯示鼠線，端點不在畫面當 

中的會自動被排除。 
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H. Deleting Etch and Via 
 

點選功能鍵    或點選功能表 Edit>Delete， 

Ripup etch：勾選了表示在刪除某個物件的 

時候連同和這個物件一起的 ETCH 也一起刪除。 

 

 

 

 

 

 

 

 

 

Delete Net Options： 

該選項只有當在 Find 表單中勾選了 Nets 才會起作用 

,然後選擇想要刪除的 Element 

 

 

 

 

 

 

 

 

 

 

刪除 net 中的一小段線段： 

Delete－在 Find 中選 Clines，點選右鍵出現左邊功能表，選擇 Cut， 

然後點選要 Cut 線段上的兩個地方，Done。 
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I. 使用 SPECCTRA 自動佈線 

點選功能表 Route>SPECCTRA>Route Automatic… 出現如下表單： 

 

Close：關閉表單推出自動佈線 

Route：開始自動佈線 

Undo：撤銷自動的佈線 

Results：察看結果 

Help：說明
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Router Setup Tab 

 Strategy 選擇自動佈線的參數設定 

 Specify Routing Passes：使用 Routing Passes 表格中的內容參數設定 

 Use Smart Route：使用 Smart Router 表格中的內容參數設定 

 Do File：使用已有的 do 文件命令來設定 

  

Options 

 Limit Via Creation ：儘量避免使用 Via 

 Enable Diagonal Routing：允許斜走線 

 Limit Wraparounds：限制走線包圍 Pin 

Protect existing routes：保護已經走好的線 

  

Wire Grid：走線的格點 

 X Grid：x 方向的格點間距 

 Y Grid：y 方向的格點間距  

X Offset：x 方向的格點偏移 

 Y Offset：y 方向的格點偏移 

  

Via Grids：Via 的格點 

 X Grid：x 方向的格點間距 

 Y Grid：y 方向的格點間距 

 X Offset：x 方向的格點偏移 

 Y Offset：y 方向的格點偏移 

 

 

 

 

 

 

 

 

 

 

走線的層面 走線方向 保護 選擇 
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Routing Passes Tab 

 

 

Pass Type： 

Fanout：從 pad 拉出走線打 Vias 

Route：走線 

Clean：清除多餘走線 

Passes：執行的次數 
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Smart Router Tab 

 

 Grid 

Minimum Via Grid：最小 via 格點 

Minimum Wire Grid：最小走線格點 

 

 Fanout 

Via Sharing：共用 via 

Pin Sharing：共用 Pin 

Generate Testpoints：加測點 

Off：關閉 

Top：加在 Top 層 

Bottom：加在 Bottom 層 

Both：兩面 

Use Grid：設定測點格點 

Miter After Route：在自動佈線完成之後自動把直角變成斜角 
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Selections Tab 
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選擇要 Router 的 Net 

若要應用在 BGA Fanout，也可使用 Route>Fanout By Pick 如下圖: 
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J. Gloss 
 
這個功能可以幫你自動作整塊板子走線的平滑和刪除殘餘線段 

                                                 

點選功能表 Route>Gloss> 出現右側表單 

 

Bubbles：(凸起的走線)  

 

 

Jogs：(小階梯) 

 

 

Dangling line： (單接點線) 

    

 

No-Net Dangling line:(無接點線) 

 

 

Line Segments 

Convert 90’s to 45’s：90o 轉角轉換爲 45o 轉角 

Extend 45’s：延長 45o 走線，紫色爲執行後的走線 

Maximum 45 Length：最大 45o 轉角長度，右圖 A 

如果要忽略的話就填：-1 

 

Length Limit：凸起走線的最大長度 

      大於這長度就不修線 

              右圖 B 所示 

              如果要忽略的話就填：-1 

 

Corner Type：轉角類型 

Number of Executions：執行的次數 

 

 

A 

B 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

9  -  1 

第九章 Copper 
 

本章節主要介紹鋪銅加在 routing 和 plane 層之應用，共分為 Positive（正片）和 Negative（負片）兩種。其中

通常負片 Shape 是應用在 Plane 層，正片 Shape 常用於走線層上及其他編輯及應用。 

 

A. 正負片的顯示 

 
shape 的正負片在 Allegro 和 Artwork 中的顯示效果如下圖:  

 

(1) 負片效果描述: 

 

白色的是走線或者導通的貫孔，與實際看到的圖形是相反的。 

 

優點: 1. 負片 shape 的資料量非常小。 

2. 對後段 PCB 生產端在進行 Gerber 資料處理上較為方便。 

 

缺點: 1. 必須為所有 thermal 孔建立 flash symbols 

2. 沒有辦法有太詳細的 DRC Check Rule 
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(2) 正片效果描述: 

黑色的是代表銅箔，走線或者導通的貫孔銲點。 

 

優點: 1. 在 Allegro 中顯示效果非常明顯，正片的顯示對 Thermal Relief 和 anti_pad 不需要特別的 flash symbols 

2. 有比較完整的 DRC Check，如:未接 pin 可以有鼠線顯示出來。 

 

缺點: 1. 正片 shape 的數據量遠大於負片 shape 

2. 在 Static solid 時，若有修改需手動重鋪 shape 

 

在此要強調一點，電源層通常為一整塊或多塊銅箔所構成，如果為正片，那麼在底片輸出 Gerber 資料時會產生

極大容量的資料，因此一般建議使用負片 shape 處理電源層，這樣所產生的 Gerber 資料檔案容量相對會小很多。 

 

B. 負片銅箔的建立 

(1) 直接添加銅箔 

   點選功能表上的 Shape 命令右邊彈出下面功能表，或以下工具列，對 shape 進行編輯 

        

 

 

 Polygon      Rectangular         Circular 
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a. 檢查 options 欄中的 Class(ETCH) 和 Subclass 是否為所要作業之層面 

 

 

 

 

b. 選擇鋪銅型態,一般在負片上建議選 Static solid 

  

 

 

 

 

 

c. 指定訊號名稱 

  

 

 
鋪完後如下圖，以當初銲點建立之 Thermal Relief 和 anti_pad 為套用資料  
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(2) 自動採用 SPLIT 進行鋪銅 

 

                           3v(ETCH/VCC) 

                                                     ANTIETCH/VCC 

效果:  

 

    

                                                            5v 

             +12v                                      

 

 

 

a. 點選 Toolbar 下面的 Add line         按鈕，選擇右邊 options 下面的 Active class and Subclass 的層

面選擇 ANTI ETCH 和 VCC 

 

 

 

 

 
b. 點選 Edit>Split plane>Parameters，彈出下面的對話方塊 , 對 shape 的填充形式進行選擇. 
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c. 點選 Edit>Split plane>Create，彈出下面的對話方塊，對層面及鋪銅型態進行選擇 

   

 

 

 

 

 

 

選擇訊號名稱 

   

 

 

 

 

 

 

 

 

 

 

 
通過以上步驟分割 Vcc 層面的 shape 就完成了 
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C. 建立正片銅箔 

 

(1) 直接添加銅箔 

 點選功能表上的 Shape 命令右邊彈出下面功能表，或以下工具列，對 shape 進行編輯在 Etch 層面上 

        

 

 

a. 檢查 options 欄中的 class(ETCH)和 subclass 是否為所要之層面 

 

 

 

 

b. 選擇鋪銅型態  

 Dynamic copper 動態鋪銅 

 Static solid 靜態鋪銅 

 Static Crosshatch 靜態網狀鋪銅 

 Unfilled 不填滿之鋪銅 

 Defer performing dynamic fill 在動態鋪銅時,待指令結束,才將銅箔鋪滿 

 

c. 指定訊號名稱 

   

 

 

d. Shape 外框轉角的角度 
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e. 多邊形銅箔繪製必須是在 route keeping 的範圍內才能作用 

D. 銅箔參數設定 

 
執行 Shape/Global shape parameters 

(1) Shape fill 鋪銅方式 

 

 

 

 

 

 

 

 

 

   

 

 

 

 

 

 

Dynamic fill: 

Smooth: 勾選後會自動 fill，void， DRC 及產生底片輸出效果的 shape 外形。 

Rough: 產生自動 void 的效果，但只是大體外型，無產生底片輸出效果。 

Disabled: 不執行 fill, void, DRC,特別在做大規模更動或 netin, gloss, testprep add/replace vias 等動作為

提高速度。 

Xhatch Style: 填充的效果。 

     

    Fill Style 共有下列八種填補形式     

 

Vertial                                Horizontal   

 

 

Diag_Pos                             Hort_Vert         
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Diag_Neg                             Diag_Both 

  

(2)  Void controls:挖銅的方式 

      

 

 Artwork format：底片格式 

 Minimum aperture for artwork fill：設定最小鏡頭大小. 

 Suppress shapes less than：當銅箔小於該值自動刪除 

 Create pin voids：一排 pin 或 via 一起時的 void 模式 

   

                        

 

 

 

 

 Distance between pins：當兩個 pin 的間距在多少之間使用 in-line 模式 
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 Snap voids to hatch grid：voids 在 hatch 的格點上 

 

 

 

 

 

 

 

選取 Snap voids 的效果    未選取 Snap voids 的效果 

 

(3)  Clearances: Void 的距離 

設定 Shape 於其他的 PIN、LINE、CLINE、TEXT、SHAPE、RECTANGLE 之間的安全間距，其間距可採

取下列幾種計算方式 

 

    

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 DRC Value：根據系統 setup>constrains…下面 spacing 中設定的 Shape 相關設定參數 

 Thermal / Antipad：根據 PADSTACK 的 Thermal / Antipad 的值 
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(4)  Thermal relief connects: Thermal 孔連接的效果 

 

設定 PIN 和 Via 的 Thermal 連接方式 

方式可分為以下幾種 

Orthogonal  Orthogonal ： “十” 字形連接 Shape 

Diagonal：斜角 45 度角連接 Shape 

Full Contact：完全連接 Shape  

8 Way Connect：“米” 字形 8 個連接點 

       

 Maximum Connects：設定 Thermal 最大連接線數，其值在 1-8 之間 

 Minimum connects：設定 Thermal 最小連接數. 

 use fixed thermal width of：使用固定寬度為 thermal width 

 Use thermal width oversize of：設定原本 thermal width 所要加大的寬度 

 

Note: 除了從以上的標準界面設定銅箔參數外，也可使用 Edit/Properties 去設定其參數 

DYN_XXXXXX_XXX 都是針對 Dynamic Shape 所使用之 Properties。 

如 DYN_CLEARANCE_OVERSIZE = 10 MIL，就是設定比原 Design Rule 的 clearance 加大 10mil 

避開間距。 
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E. 編修銅箔 

 
(1) 挖銅 

    執行 shape/Manual Void 

     

     

 

 

 

 

 

 

 

 

 

 

 

    #Polygon                #Rectangular          #Circular  

 

 Delete:刪除 Void 

 Element:以指定之物件依避開之規範避開 

 Move:移動 void 

 Copy:複製 void 

 

(2) 修改銅箔外形 

a. 執行 Shape/Edit Boundary 
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b. Select shape or void 

選擇要編修的 shape，會呈現 Highlight 的狀態，注意 shape 周圍會出端點(Vertex) ，可直接點選端點

做移動或點選在直線上增加 shape 範圍 
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(3) 刪除孤島 

執行 Shape /Delete Islands 

 

Delete all on layer:刪除此層面之所有 Island 

Current Island:用逐一尋找的方式，再由使用者手動刪除 Island 

 

 

 

 

 

 

 

 

 

 

 

 

(4) 若要改變銅箔形態，可使用 Shape/Change shape type 做變更 

      

 

 

 

 

 

 

 

 

    Dynamic Shape                                      Static Shape 
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(5) 多片 Shape 若要合併，可使用 Shape /Merge 

     

 

(6) 若想針對單一 Shape 檢查 Minimum Aperture 在出 Gerber 時，是否有問題,可執行 Shape/Check 做檢查。 

 

(7) Shape /Compos：可將線段組合成 Shape 

 

 

    

 

 

 

              

 

 

 

 

 

(8) Shape /Decompose:可將 Shape 解開為 line 
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第十章 Rename 
 
為使整塊板子上的零件序號更為順暢，本章節主要介紹如何重新命名零件序號，以及讓重編後的序號能夠和線路

圖進行資料的同步更新處理 

 
設定 Rename 範圍 

 

執行 Logic/Auto Rename Refdes  

 

 Design： 設定範圍為整塊板子 

 Room： 設定範圍為單一的 ROOM 

 Window： 設定以一個視窗為範圍 

 List： 以 List 檔案為範圍 

 

A. 自動排序零件編號 

 
點選 Logic>Auto Rename Refdes>Rename 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 User defined grid：自行定義在 Place_Grid_Top(Bottom)的格點( 一般鮮少人使用這種編排方式 ) 
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 Use default grid：使用系統標準的格點 

 Rename all components：針對所有零件做重編序號的動作 

 Attach property components… 

 AUTO_RENAME：對要 Rename 的零件,設定 Auto Rename 參數,以利執行 Rename. 

 

 

 

 

 

 

 

 

 

 

 More… ( Rename 規則細部設定)  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 Layer：選擇層面  
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 Starting layer：起始層面 

 

 

#Component Origin:選擇零件的參考點 

 

 

 

 Directions for Top Layer：定義由 Top 層開始進行排序方式 

 Directions for Bottom Layer：定義由 Bottom 層開始進行排序方式 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Reference Designator Format 

 

 

 

 

 

 

 

 

 

 

 RefDes Prefix：定義 Prefix 字元,”*”維持原字元 

 Top Layer Identifier： 設定 Top 層加的判別字元 

 Bottom Layer Identifier：設定 Bottom 層加的判別字元 
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 Skip Character(s)：設定略過不易判別的字元(如 I,O..等字元) 

 Renaming Method: 序號編排模式 

 Sequential:序號連續編排 

 

 

 

 

 

 

 

 

 

 

 Grid based: 

 配合 Grid Based Renaming 設定 

 

 

 

 

 

 

1st Direction Designation:第一段參考字元,往後遞增 

2nd Direction Designation:第二段參考字元,往後遞增 

 

Suffix:字尾參考字元 
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 Refdes Digits：使用保留字元數 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

Note：若不要從 1 開始重編.可從 User/Preferences 設定 fst_ref_des 參數改變其開頭序號 

 

 

B. 手動更改零件序號 

 
執行 Edit/Text 

    

 

 

 

若零件編號不想被更動，可於零件的 Properties 設定 Hard Location 的參數,在你更改其零件序號時,會出現以下

提示訊息 
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C. 零件序號回編線路圖 

 
為了保持 PCB 與 SCH 的一致,需做 Backannotation 到原來的線路圖 

 

  

 

 

 

 

 

 

 

A. 排序前 

 

 

 

 

 

 

 

 

 

B. 排序後 
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(1) 若使用 PCB Editor 轉 Netlist, 

     OrCAD 執行 Tools/Back Annotate,並選擇目前的 PCB 檔案. 

    

   

 

 

 

 

 

 

 

 

 

(2) 若使用 Other 轉 Netlist 

OrCAD 執行 Tools/Back Annotate,手動編輯成 WAS/IS 格式的 Rename.swp,並載入此檔 
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(3) 成功載入 
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第十一章 AutoSilk & Report 
通常文字油墨印刷面只要選相關的名稱及外形層湊成文字面輸出即可，AutoSilk 為文字面選擇性指令，可將油墨

印刷蓋到焊點或防焊的部份刮除及移動文字位置，另也可顯示不同層面相關資訊將不同層的資訊疊合成專屬層

面，例如零件名稱在零件中央的另一份文字面可供工程師行參考，另外本章還介紹 Allegro 常用之 Report 或自

行定義 Report 之格式。 

 

A. AutoSilk 
 

執行 Manufacture >Silkscreen，並出現設定參數之選單 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Layer：選擇所要執行的層面 

 

 

 

 

 Element：選擇所要執行的物件 
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 Classes and subclasses：選擇所要出圖之層別 

 

 Any：選擇 Classes 內所包含的圖形資料 

 Silk：以 Silk 層之資料為主 

 None：不選擇此層之資料 

 Text：文字控制 

 

 

 

 

 

 

 

 

 Rotation：允許文字旋轉方向設定 

 Allow under components：允許文字放在零件底下 

 Lock autosilk text：當 Update autosilk 時,會鎖住原文字之相對零件之位置 

 Detailed text checking：可直接檢查文字本身，而不會只抓到 Text Block 進而更有效率的檢查文字面的文字

及其空間。 

 Maximum displacement：當移動文字時, 允許距離本體的最遠距離 

 Displacement incremen：在離本體的最遠範圍內,文字每移動一次增加的單位 

 Minimum line length：設定 Line 或 Arc 線段節點最小單位 

 Element to pad clearance：與 PAD 之間的間距 

 Clear solder mask pad：依據 Solder Mask 的範圍作為距離的控管條件 
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 Audit：檢查 Silk，並將此結果輸出至 autosilk.log 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

或產生於                            這二個層面 
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B. Report 
 
若要在 allegro 產生 report，可執行 Tools/Reports 

 

其輸出格式為： 

 

a. 一般 HTML 模式： 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

逆天PCB论坛，www.ntpcb.com

逆天PCB论坛，www.ntpcb.com



 

11  -  5 

   

b. 帶分隔符號號模式： 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

c. 常用的報表如下： 

Bill of Material Report：BOM 表 
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Design Rules Check Report：DRC 列表 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Etch Length by Net Report：訊號長度列表 
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Net Loop Report ：對於非電源網路的環狀迴路走線產生報告 

Net Loop 

 

 

 

 

 

 

 

 

 

Net Loop 報告列表 

 

 

 

 

 

 

 

 

 

 

 

d. 若要自訂報表，可點選 New/Edit 進入其編輯模式 
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   將想要的內容點選到右邊的清單上，也可將自訂之新報表用 save 將其儲存或用 Load 載入修改 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

選擇自訂之報表名稱即可產生出自行定義之報表 
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第十二章 Gerber 
本章節主要介紹輸出底片，常用格式有 Gerber RS274D(包含 Gerber4x00,Gerber6x00)、Gerber RS274x、Barco 

DPF、MDA 其中以 Gerber6x00、Gerber RS274x 較多人使用。 

 

A. 輸出底片 

 
(一)  Gerber RS274D (以 Gerber6x00 為主)  

Gerber6x00 資料輸出時需多附加一個鏡頭敘述檔 art_aper.txt 

 

 Gerber6x00 產生底片檔 

1. 執行 Manufacture>Artwork 選擇 General Parameters 設定參數 

Device type --- Gerber 6x00 

Format --- Integer places:3 ; Decimal places: 5 (用英制 inch 必選 5，表示 mil 後兩位) 

NOTE:若未設定好小數位數，將會出現以下的提示訊息 

 

 

 

 

 

 

 

2. 選 OK 產生 art_param.txt File 

3. 選擇 Apertures --- 彈跳出 Edit Aperture Wheels 執行 Edit 
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編輯鏡頭表資料 

選 Auto 鍵再選 without Rotation(鏡頭不能旋轉) 若確定後面承接的系統可支援該條件可旋轉才選 with 

Rotation，若不確定則建議使用 Without Rotation。 

底下列出所使用鏡頭，選擇 OK 鍵產生 art_aper.txt 檔 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. 回到 Film Control 編輯輸出的 Artwork 內容 

 
 

 黃色資料夾部份-為輸出底片之名稱,如 BOTTOM, GND, TOP, VCC 即為輸出之底片名稱。 

 粉紅色部份 - 為底片所疊合之層面，如 BOTTOM 是由  ETCH/BOTTOM,PIN/BOTTOM,VIA 

CLASS/BOTTOM 三層資料所疊合之底片。 
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5. Film Options 介紹 

 
 

.Rotation – 底片檔轉出之旋轉角度 ( 以預設角度使用 ) 

.Offset X: / Y: – 底片檔轉出之偏移值( 以預設角度使用 ) 

.Undefined line width – 定義圖檔案未被設定線寬的資料所要套用的替代值 

.Shape bounding box – 底片資料周邊的邊界線，由 Outline 的中心點往外擴 (只有負片才有用) 

.Plot mode – Positive (Artwork 為正片) ，Negative (Artwork 為負片) 

.Film mirrored – 該層 Gerber 資料做鏡射翻轉的圖形處理 

.Full Contact Thermal-Reliefs – 忽略 Thermal 圖形，改採用全導接的方式 (只有負片才有用) 

.Draw missing pad apertures – 在 Aperture 中無法直接敘述 D-Code 的 Pad，則採用 Line Draw 的方

式描繪 

.Use aperture rotation – Aperture 可定義 rotation 的資料形態 

.Suppress Shape Fill – 銅箔大包小的時候勾選(只有負片才有用) 

.Vector based pad behavior – 用向量來描述鏡頭檔，資料檔案比較小(Gerber RS274X 才有) 
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6. Artwork 內容有兩種一是正片(Positive)另一是負片(Negative) 

RS274 正片內容如下: 

 

 

Ex: 

以 Top.art 為範例，先將預輸出的 subclass 加至 Top.art 的公事包中， 

內容是 VIA CLASS/TOP 

  PIN/TOP 

  MANUFACTURING/PHOTOPLOT_OUTLINE 

  ETCH/TOP 

  DRAWING FORMAT/OUTLINE 

螢幕上顯示的即是未來 Gerber 轉出的結果圖形。 

 

可點滑鼠右鍵 Display，會在 Allegro 顯示目前公事包內所設定的層面，或在 Allegro 開好層面， 

再使用 match display 將其層面加進來。 

若想將目前各張底片的設定層面儲存可使用滑鼠右鍵選擇 Save，將其儲存。下次要重覆利用時，只要選

表單上的 Load 即可。 
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RS274 負片的內容如下: 

 

 

Ex: 

以 Gnd.art 為範例，先將預輸出的 subclass 加至 Gnd.art 的公事包中， 

內容是 VIA CLASS/GND 

  PIN/GND 

  MANUFACTURING/PHOTOPLOT_OUTLINE 

  ETCH/GND 

  DRAWING FORMAT/OUTLINE 

  ANTI ETCH/GND 

 

規則跟正片的設定是一樣的只是多了 Anti etch 的層面(隔離層) 

Gerber 6x00 格式必須夾帶 Anti Etch 才會形成隔離狀態 

Gerber RS-274D-X 格式不能夾帶 Anti Etch 才會形成隔離狀態，否則會造成銅箔之間短路現象 
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7. 選 Create Artwork 產生底片檔 .Art 

其中的 Check database before artwork 用意是在出 artwork 之前先幫您檢查 database 

 

 

8. 利用 CAM Tools 將 *.art 檔案載入看看 

Top.art 轉出的結果： 
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Gnd.art 轉出的結果: 

 

 

Note:  

Gnd.art File 中出現的 Thermal 需要另一個定義檔宣告。 

此例之 D21 的 T188X174X40 只是一個”名稱” 需再 CAM Tools 中另行定義其真實值如外徑、內徑、開口寬度、

角度、開口數量等。 
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(二)  Gerber RS274X 

Gerber RS274X 資料輸出與 Gerber6x00 不同的地方即是 RS274X 是將鏡頭描述及相關的參數條件資料加入

Gerber File 檔案前段中，所以不需額外的鏡頭檔 art_aper.txt。 

 

Note:出 RS274X 時有一個口訣,”所見即所得” 意思是說目前看到的即是未來的結果。 

 

 Gerber RS274X 產生底片檔 

 

1. 執行 Manufacture>Artwork 選擇 General Parameters 設定參數 

Device type --- Gerber RS274X 

Format --- Integer places: 2；Decimal places: 5 ( 以 inch 為輸出單位時 ) 

 

 

 

 

2. 點選 OK 產生 art_param.txt File。 
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3. 回到 Film Control 編輯輸出的 Artwork 內容。 

 

 

4. Artwork 內容有兩種一是正片(Positive)另一是負片(Negative) 

RS274X 正片內容如下： 

 
Ex: 

以 Top.art 為範例,先將預輸出的 subclass 加至 Top.art 的公事包中， 

內容是 VIA CLASS/TOP 

  PIN/TOP 

  MANUFACTURING/PHOTOPLOT_OUTLINE 

  ETCH/TOP 

  DRAWING FORMAT/OUTLINE 

 

螢幕上顯示的的即是未來 Gerber 轉出的結果 
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RS274X 負片的內容: 

 

Ex: 

以 Gnd.art 為範例, 先將預輸出的 subclass 加至 Gnd.art 的公事包中, 

內容是 VIA CLASS/GND 

  PIN/GND 

  MANUFACTURING/PHOTOPLOT_OUTLINE 

  ETCH/GND 

  DRAWING FORMAT/OUTLINE 

 

與 Gerber6x00 不同之處是不要將 Anti etch 的層面(隔離層)加進來 

 

5. 選 Create Artwork 產生底片檔.Art 
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6. 利用 CAM Tools 將 *.art 檔案 Import 進來 

Top.art 轉出的結果： 

 

 

Gnd.art 轉出的結果： 

若在 cam tool 中會顯示未疊合之狀態，必須以 composite 的方式才能顯示出此效果,才是真正出底片的

結果。 
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B. 底片檔圖形資料檢視 

執行 File/Import/Artwork，選擇完檔案後，點選 Load File 
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C. Drill Customization 
 
執行/Manufacture/NC/ Customization,即可出現此 Drill symbol 的編輯介面 

 
 Validate：檢查鑽孔資料是否正確 

 Merge：若有相同的鑽孔,但符號不同,可選擇合併 

 Reset to design：重新載入 Library 資料 

 Reset to Library：將新資料載入 Library 

 Auto generate symbols：自動產生新的鑽孔符號 

 Write report file：將目前的狀態產生報表 

 Library drill report：將零件庫的銲點鑽孔資料產生報表 
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D. 產生鑽孔符號表 

執行 Manufacture/NC/Drill legend 
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E. 產生鑽孔檔 

執行 Manufacture/NC/Drill Parameters 設定 NC 相關 

參數。 

 

˙在 NC Parameter 裡面設定有效資料位數 

 Format 資料建議與 Gerber 的內容設定相同。 

 可避免位數不同時發生孔偏的問題。 

 

 

 

 

 

 

 

 

 

 

 

˙執行 Manufacture/NC/NC Drill，輸出鑽孔檔，並勾選以下項目： 
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F. 產生槽形孔資料檔 

對於產生長槽形孔，即使沒有銑刀檔（nc_tools_auto.txt），只要執行 Manufacture/NC/NC Route，也可以產生

NC Route 檔。 

 

Separate files for plated/non-plated routing： 

將 plated 和 non-plated 的 NC Route 分開出在兩

個文件中。 

 

 

 

 

 

 

 

銑刀參考檔 

 

 

 

 

 

 

NC Route 檔案內容： 

 

 

PS. 在 16.6版以前要手動編輯銑刀

檔。現在軟體會自動依照槽孔的窄

邊尺寸為依據產生銑刀檔。 

但是如要要和板廠的實際狀態要能

對應的話 , 建議依照板廠所提供的

銑刀資料自訂 ncroutebits.txt 的內

容 
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第十三章 CADIn 
 

本章節主要介紹其他 CAD 界面之載入，主要介紹常用之 PowerPCB、PCAD 及 OrCAD Layout 軟體之 PCB 檔

案載入方式 

 

A. PowerPCB to Allegro 
 
步驟如下: 

 

1. PADS 輸出 .asc 檔 

(1) 進入 PowerPCB 並載入要轉換至 allegro 之圖檔  

(2) 執行 File>Export 存檔類型選成 .asc ( 非直接以 Save 指令所存成的檔案 ) 

(3) 輸入要產生的 asc 檔主檔名 output file name  

(4) 點選 Select All 輸出所有項目 

(5) Format 項目：建議選到 PowerPCB V3.0 ~ 2007 格式 

(6) Units 項目：選 Basic 或 Current.  

(7) 不要勾選 reuse 項目 

(8) 選 OK 產生輸出檔 .ASC 

 

2. ALLEGRO 載入 .ASC 檔 

(1) 進入 ALLEGRO 

(2) 執行 File>Import> CAD Translators >PADS… 

(3) 點選 PADS ASCII input file 以右下角之 Browse 選取要載入的 pads 之.asc 檔  

(4) 點選 Options File 輸入新對應檔名稱，如要套用先前對應檔才以 Browse 選取，若設新對應檔則會詢問

層面對應之宣告。若是套用先前設定則不會再詢問一次  

(5) 在 Output Design 指定輸出路徑及檔名  
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(6) 點選 Run 鍵開始轉檔,若要建立防銲層選 create solder layers 並設定放大值  
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B. PCAD to Allegro 
本轉換功能僅支援 PCAD 舊版本 PCB 格式 ( PDIF ) 

 

1. 執行 File>Import>CAD Translators>PCAD 

 

 

2. 點選 Run 鍵執行轉檔及圖層對應 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. 轉檔完後，執行 File/Open 載入已產生的 brd 檔 
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C. OrCAD Max to Allegro 
 

1. 執行 File>Import>CAD Translators>OrCAD Layout  

 

 

2. 選擇來源 *.max 檔(Input Layout file)，及選擇轉檔後輸出之路徑(Output Directory)點選 Translate 即可 
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